Updated guide to KNX with Raspberry Pi 3 and Busware pigator TPUART?

Hi guys,

Smart home noob here, but trying to learn.

I’ll be setting up a smart home with KNX for lights/blinds and possibly security, and HomeMatic for heating. To integrate both systems, I’m trying to get a Raspberry Pi 3 running with openHABian.

For the interface with KNX bus, I chose a Busware pigator TPUART interface instead of the USB module or the IP bridge. But I’m having a hard time convincing rPi to turn off the on-board serial console and wifi and bluetooth, so that the serial interface in pigator is ttyS0. The guides I’ve been following are somewhat outdated, with the consequence that openHABian doesn’t see the serial port. I’m at the point of re-flashing the microSD and starting from a clean slate again.

Does anyone have a more up to date guide on rPi3 + pigator + openHABian, please?

Many thanks in advance!

So, let me detail what I have done so far.

I have a Raspberry Pi 3, and a busware.de ROT module, consisting of a HAT board with a OneWire interface and Real Time Clock, plus a piGator module with KNX interface.

I installed openHABian and performed the following steps:

  • expanded partition to full microSD size, updated/upgraded openHABian, updated the Raspberry Pi firmware (rpi-update);
  • disabled the RPi on-board serial port and bluetooth, added in /boot/config.txt the directive dtoverlay=pi3-disable-bt;
  • stopped and disabled the serial-getty service on ttyAMA0 port;
  • disabled the hciuart service.

In PaperUI I added the KNX binding, then added the KNX FT1.2 Interface as a thing. It allows me to choose between /dev/ttyS0 and /dev/ttyAMA0, but both result in the interface being offline with the message “resetting BCU failed”.

What am I still missing, please? Is this behavior normal, considering that the KNX interface is not yet connected to a powered KNX bus? Do I need to modify some configuration files by hand?

Reference links I have used so far:

I would really, really appreciate any guidance. Many thanks in advance!

I think i have exactly the same issue, but unfortunately i created a new tag : Connecting knx to openhab fails with resetting "BCU failed (no acknowledge reply received)"

Hey Kurt! Thanks for sharing your issue, even if it’s in a different thread :slight_smile:

Meanwhile, out of frustration, I ditched the busware TPUART pigator and bought another interface for Raspberry Pi - the Weinzierl KNX BAOS 838 kBerry. It has a smaller footprint as it doesn’t have a OneWire interface nor a battery-backed Real Time Clock, but essentially it would also present a serial port to the RPi and OpenHAB.

I didn’t have any time to progress beyond a default openhabian installation on the microSD. However, searching online for instructions on making the Weinzierl kBerry run, I ran into some interesting instructions which may be applicable to the TPUART as well. As far as I can remember, the UART must be enabled in the config file, then something about permissions, and also found that the working solution meant compiling knxd and making it run on localhost. This way, OpenHAB didn’t directly access the serial port, but used the network loopback address.

Can’t be too sure on my memory at this late time of night, but google the kBerry and see if the instructions also help with the TPUART pigator.

woow, Thx for the posts on the Weinzierl kBerry, i solved my issue, which means that now i have my raspberry communicating over knxd via openhab2.

I’m more and more convinced that getting knx connected to OH2 is impossible via the paperui interface.

Imo, the only way is to write your own things - config file, mine looks like this (of course replace the ip by your own), i started on a raspberry pi 2, installed openhabian, and afterwards installed knxd.

I will do the same experiment on raspbian wheezy using eibd, will keep you posted on how successfull my experiments will be …

Bridge knx:ip:bridge [
   Thing device generic [
      Type switch : buroSwitch   "Light" [ga="0/0/13"]
1 Like

Oh cool, happy to hear it worked! That’s a good incentive for me to get motivated and work on it as well :smiley: Thanks for the update, @kurt323433 !

So basically you’re still unable to make openHAB work directly with the serial port, right? Only the virtual network interface provided by knxd works. It’s kinda stupid to go this route, but oh well. At least the kBerry interface was on eBay about 46€, while the busware TPUART pigator was manufactured on demand for 90€, and a KNX-Ethernet bridge goes for at least 150€.

And it’s not just the lower cost, but also the ability to update the software and limit access from the network directly through the software configuration. With a stand-alone KNX-Ethernet interface, I’m not sure how secure this is and how often do manufacturers release firmware updates to address network exploits, but definitely you’d want to use a smart switch and connect the home automation devices in a separate VLAN so that they are segregated from the rest of your home network.

By the way, why’d you still use eibd? I thought it was considered old and deprecated, being replaced by knxd. (I’m a noob.)

The reason i still use eibd is because i have a raspberry image on wheezy that i used for years in combination with a busware - ROT module. Now the ROT completely crashed, even my old raspberry 2 was taken into the darkness.
So now i bought a pigator, and i’m experimenting with this new tool, but i not decided yet on the user interface.
On the ROT i had Smartvisu as front end, but now i’m moving to new hardware, i wanted to give OH2 a chance. Starting from stretch and knxd (https://michlstechblog.info/blog/raspberry-pi-eibknx-ip-gateway-and-router-with-knxd/) or calimero (https://michlstechblog.info/blog/eib-knx-knxnet-ip-gateway-with-calimero-server-on-raspberry-pi-orange-pi-pc/), i now have my smartvisu up and running again, but imo the OH2 is more open, and at least has more external interfaces.

1 Like