Upgrade to 2.5.0-1 from M4 was a disaster

Upgrading from 2.5.0M4 to 2.5.0-1 was a disaster.

Stopped openhab
upgraded and chose to keep the existing configuration and started OH again.

Numerous errors, in rules, icons, sendmail… so I decided to roll back to the M4 version
Still had many of the same errors but I started tweaking and saving the sitemap and then everything started working as before and errors disappeared.

I know there were some breaking changes for the final 2.5 but the thing is, M4 was working fine.

Before I attempt the upgrade again, anyone have advice on a process to follow?

I think a few of us have has numerous errors when upgrading. I found a restart of openHAB worked. Some people say try restarting 3 times.

I also have some rules issues (system started triggered every minute…) since going from M4 to final.
Rebooted 100’s of times.
I think we’ll have to wait for a test version 3.0 :wink:

i hope you cleared your OH cache folders

I found that touching all of the config files helped me get rid of errors. It was as if openHAB did not read in my config files even though it said it did.

My errors were for missing items and things. I simple did a touch on the things and items files and errors were gone.

1 Like

I found that too and a restart of OH fixed that.

1 Like

Thanks Markus
Despite searching, I missed your very helpful post.

I’ll try to upgrade again and post my results to this thread

touching files and restarting is another way of… refreshing the cache lol



Touching the files will require one of two things. The command line interface method (Linux based system.). Login to your openHAB server over ssh and change(cd) to the conf directory most of the time this is /etc/openhab2 on a Linux based system.
Once there issue the touch command

touch */*

You should see in the logs the openHAB instance re reading all your config files.

The open and save method, browse to your conf directory in your favorite editor. Open files in your things, items and rules directory one file at a time. When open insert a space somewhere and save the file.

I prefer the command line as there is less risk to corrupt a file.

I almose thought you messed up. I did not notice both *
Let’s see if this looks clearer for the user. touch */*
Use backticks “`” (beside the 1 key) instead of quotes.

1 Like

@Bruce_Osborne good catch! Error in how the forum interpreted.

1 Like

It is easier to catch other peoples errors than to catch your own. You KNOW what you wantd to say so your brain’s instant error-correction kicks in. :face_with_raised_eyebrow:

1 Like

Tried the upgrade to 2.5.0-1 with much better success!

cleared the cache which apparently reduced most of the errors I got from the last upgrade.

I got an error from a rule I use to convert a string to a number (probably not the most elegant way to do it.). But it worked again after I “touched” the rules file.

Rule ‘onewiretempValue2 String to Number’: The name ‘onewiretemp2Value_num’ cannot be resolved to an item or type; line 151, column 5, length 21

Only error not resolved is regarding sendmail
[ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule ‘Back_Door_Closed’: ‘sendMail’ is not a member of ‘org.eclipse.smarthome.core.thing.binding.ThingActions’; line 56, column 5, length 161

I remember seeing something in the release notes about sendmail so I’ll look further into it.

I got it working but still get an error
21:38:47.418 [WARN ] [javax.mail ] - expected resource not found: /META-INF/javamail.default.address.map

It’s only a warning but any ideas on what it means?

1 Like

As Bruce pointed out in another thread, it’s always worth reading the release notes

1 Like

Ideally read the Release Notes for every version between your starting and final versions.

For example, if upgrading from 2.4 to 2.5.8 many breaking changes are only in the 2.5.0 release notes. Some bindings may list breaking changes in later versions.

1 Like