Using a Fibaro Motion Sensor - getting "Error 404"


i just installed an AEOTEC Stick Gen5 with a Motion Sensor already included on the Z-Wave network. Both show up on my Paper UI as things. I linked the channel for luminence by clicking on it, same for the batterie status and termperature. They now show up under Paper UI -> Control, but no sensor collects any data (NaN or -NaN is shown).
When i try to update certain properties (luminence threshhold e.g.) i sometimes get “Thing updated” followed by “404 - not found” or i get only “404 - not found”. It never updates anything though. Same for unlinking channels, sometimes it doesnt work and gives me a 404, sometimes it works.
I tried to add items to my items.conf and sitemap.conf but i dont get any values there either (maybe i messed up the item configuration, i just uses the channel displayed in Paper UI).

What do i have to do in order to get this motion sensor to work? Most posts on the board evolve around other sensors and/or OH1, so i dont know how to apply that.

Which device is the Motion Sensor? (the FGMS-001 ?)
Does it appear as Online in PaperUI->Configuration->Things?

The 404 happens to me also sometimes. I use HABmin to change my Z-Wave things configs and it works better.

If you can: post a screenshot of the Motion Sensor Thing channels from PaperUI and your relevant *.items entries

Yes, it’s the FGMS-001.

I get the things displayed in control (Paper UI) without having any items specified. I assume i should get values there without having corresponding items, right? At least this works for things like network (device online or offline). When i want to use the data in rules or on a sitemap i have to have items, correct?
I am still trying to figure out OH2, so my questions may be a bit stupid sometimes :wink:

I will post screenshots as soon as i get home again.

p.s.: i read your breakfast-example and i think i defined the items as you did (using the displayed channel), but i will check in detail if i have a typo somewhere.

To get stuff displayed in the control tab of the PaperUI, you must have Items defined and linked to the channels of the things.

By default, PaperUI has “Simple Mode” activated for Item Linking (PaperUI -> Configuration -> System)
With this mode on, when you click on the channel radio button (within the configuration of a Thing), you get the Items auto-created and auto-linked to the respective channel. Most likely, you already did this step (check the radio buttons under the Thing channels in PaperUI… expand them and see if there any linked items listed there)

Since you already have auto-created (and auto-linked) Items, yes… you should have values for each item… you don’t?


In my breakfast, I defined my Items manually (using a /etc/openhab2/items/ZWave.items file)
I recommend the same (switch off Simple Mode, use the Channel names as they appear in your PaperUI and create an *.items file)

Ah, i totally forgot about simple-mode. So with that turned off i always create items via the items-file, i will do that in the future.

I can see my things in “control” (with the auto-links due the simple-mode), but i get no values, i only get “NaN” or “-NaN”. I tried luminance, battery and temperature so far. Sometimes i have numeric values (0 or 0.00) for a few seconds, than “NaN” again.

1 Like

hmmm… strange… I don’t know what could be the root cause.

I propose the following:
Turn off Simple Mode, break the links from the channels, delete the auto-created items, define the items linked to the channels manually, restart OH2 and check the control tab of PaperUI

When you turn that off, you will see a new menu appearing on the left side of PaperUI titled “Items” (under Configuration).

You can continue using PaperUI to create Items and link them to the channels of the Things.
The only difference is these configs (done via PaperUI) will be stored in the jsonDB.

Flat config files (like *.items) will co-exist with your PaperUI defined stuff.

I will do that and report if i get any values then :slight_smile:

1 Like

Well this is a bit weird now … i switched simple-mode off, and had the items under configuration in paper ui - but i did not delete any items because i had to do something else.
The next day i could not see the items under configuration, but the sensor reported correct values under configuration! Then i restarted OH2 and saw the items again under configuration. I deleted the auto-created items of the motion sensor and now im struggling to get my manual configured items to receive any values …
My item definitions were like yours are in breakfast. And i can see the linked items for each channel in paper ui, too, so i guess the items should work. Maybe some typo somewhere …

edit: to sum this up: after 2 days waiting the auto-created items reported the sensor values. Now i got rid of those items, have my manual-defined items and get no values again :smiley:

After a day waiting i get reports for temperature and luminance, not for alarm, batterie and movement. And it’s displayed slightly odd, that looked better the other day.

I guess i have to tinker with refresh-intervalls or something … but why dont i get all reports?

Hi Florian,

long time ago but I thumbled over your post from June 2017. I’m struggling with the same issues at the moment. Did you manage to find a solution finally?
Many thanks for you help!


Hi Patric,
If your device is battery driven you should wake it up several times.
For me this behavior looks like it is not fully included in your z-wave network.
I have a similar Fibaro sensor and inclusion took also very long, I think more than a day or so.