Velbus VMB7IN - kwh counter item linkage


in my velbus setup i have several kwh/water consumption counters connected to several VMB7IN input modules of Velbus. I am not able to visualize them in openhab.
I can’t link an item to this. In velbuslink i see something following.


I think i need to read out as a string? And then convert to 2 numbers? Total consumption and the consumption at this moment?

The same i have for watercounters.

Who can help me? Tried to connect an item in simple mode but doesn’t work. Manual i didn’t try because i don’t have any clue how to read out this values.



As it happens, Cédric has found some time in his extremely busy life to experiment with adding the counter channels to the VMB7IN.

This link will get you the very latest version of the Velbus binding.

Be aware that this version is untested.

The above link is only valid for 6 days.

You will need to —

  • Stop openHAB

  • Remove all traces of your current binding jar file.

  • Put this version into your addons folder

  • Restart openHAB

  • Remove the VMB7IN things that you want the new channels.

  • Use the PaperUI Inbox search to re-detect your Velbus network/s.

Once you add a VMB7IN, you should see 8 extra channels in each thing.

As this is an experimental version of the binding, please give us some feedback to help with the development.

Good luck,



thank you for the quick reply.
I have tried but haven’t seen the new channels in the things.

How can i make sure that i am using the new binding instead of the old one?
I will try to search my way through this week. Very busy at work at this moment.



I typed up a reply some time ago about a similar situation.

Please take a look at this post for some ideas…

Please let us all know how you get on.

Good luck,



just tried to install the new binding, i think it is ok the install.
But cant find the extra.

What can i do to help?


Sorry for the delay in answering, I just didn’t see your question.

It’s probably simply that the module needs to be reprofiled in openHAB2.

Just delete the module and add it again.

Cédric has also released another version of the binding with try more functionality.

I’ve put it in a zip file on my website.

Will there be support for the analoge module? I have also one in my setup, measuring the air quality in the house.

I will try as soon as possible?
I have deleted the modules and added over.

I will try to first delete the modules and then remove the existing addons and replace it with the new.
Can I remove a file somewhere of the module? Maybe openhab is using the old config files or something?


The VMB4AN isn’t yet supported, but I’m sure it will be available soon.

Cédric has a lot of other work, so he can only work on this binding in his ‘spare’ time.

Keep you eyes on the forum for information.

As for the rest of your question, I’m not entirely sure what you mean.

Can you rephrase please?

I think your question has been asked on the Velbus forum, for which the link in is post No. 4


I have just tried all over but don’t have any new counter channels.
Can i debug something to see what’s going wrong?

First I deleted the input modules.
Second stopped openhab
after i delete the jar file in the addons folder
placed the new one in there and started openhab
but the only channels i see are the once i see above Input and Clock alarm

bundle:list in karaf gives me that is installed.

I have also tried to change the adres in de velbus of these input module. But the same output comes.


Can you provide a screen shot of what you can see please.

For example, this is what I have for a VMB7IN.

I think there is a cached version of the previous binding.

If i login to the karaf console:

I see that the version is installed

I don’t know how to see that response from Karaf, which command do you use?

I’ve refreshed the zip file on my website, just to be sure it’s the correct one.

Maybe you can…

Stop openHAB2

Hunt for any Velbus binding and remove every sign of it.

find / -iname *velbus*jar

Put the new one in

Restart openHAB

Delete and rescan for the VMB7IN, which should force openHAB2 to reprofile the Thing.

Please let us know how you get on.


just tried what you mentioned.
The find command found only the jar in the addons folder.
I deleted it afterwards i used again a find command. Found another cached version.
Also deleted it, then copied the version from your website in the addons folder.
Deleted the VMB7in module and rescanned, but that didn’t solve anything.

The reprofile didn’t do his job. Maybe there is a configuration file somewhere cached?
The reprofile is’nt running as it should.

If i check the karaf console:
“ssh openhab@ -p 8101”

password “habopen”

Afterwards “bundle:list -s | grep velbus” command.
I saw also a Velbus 2.3 active, uninstalled that version using
“bundle:uninstal 203” where 203 was the id

Now i have the counters! Super!

1 Like

Thanks for the detailed explanation :slight_smile:

That’ll help other people :smile:

I’m really glad that you’ve got it working now :smile:


When I try the bundle:list -s

I see this…

190 | Active │ 80 │ | org.openhab.binding.velbus