VELUX Binding stop working

I’m using KLF 200 and Velux binding
Problem is, that this binding stop working and I don’t know why.
KLF 200 I can see on the network :

also I can ping a device:

also I can connect via wifi directly to web page of the device

but under openhab I have a error :

configuration is the same how it was working before

Please how to trace a root cause of the problem ?

Thank you

Did you set the correct password? It is not the default password „velux123“ according to the binding‘s documentation.
If I remeber correctly it is the web user‘s password.

yes, it’s password from the back side of the unit

Hi Alex,

The KLF200 has the annoying habit of going zombie every now and then for quite a lot of us. Try disabling the bridge thing, unplugging the KLF200, wait some time (10 seconds, or a bit more) before plugging in the KLF200 again. Wait a little more (solid green light on the KLF200) and enable the bridge thing again.

I now have a rule thet does this automatically with the help of a smart plug.

ok, I will try restart. Please can you share your automatic restart solution ?

See this topic

ok, thanks. Is there any other way how to control velux roller shutters without problematic KLF200?

It can also be done in blockly


Just change the name of the bridge thing and add the name of your switch item…
AFAIK, the WiFi connection of the KLF200 closes after 10 minutes, therefore I set the second timer to 11 minutes.

means if wifi is running LAN connection isn’t possible ?

Correct. If you enabled the LAN connection, WiFi will be available for a short time after reboot and then shuts down. Communication is possible over LAN only then.

LAN must be enabled, is used for the “data” communication
Wifi I can set off for always (if block LAN), because is used only for direct setup via web page

See the Bindings docs :

I did not disable Wifi on the KLF200 completely.

Which imho is needed when adding new devices to the KLF200…

oh, thaks. Means every unexpected power shut down can make a big trouble with Velux bridge

Yes, this can lead to the condition you are actually seeing.

ok, clear.
Problem is, it looks like when bridge is in the error, is still trying connect with KLF200 and finally will block LAN communication with openHAB at all.

This is the so called zombie state. The KLF thinks it still has a live connection from OH and it won’t accept any other connection attempt from OH. Whereas OH thinks the connection is down so it retries making a connection. The only solution is to disable the bridge in OH, then power cycle the bridge, then re-enable the bridge in OH.

Thanks all for help.
Now Velux Bridge is running again.
Now I must implement automatic stop of the bridge when communication stop working

Quite simple with the here posted rule examples :wink:

only one proble is that rule to disable a bridge doesn’t work for me
I did it as I found :

sendHttpPutRequest("http://localhost:8080/rest/things/velux:klf200:192_168_1_55/enable", "text/plain", "false", headers, 1000)

But Bridge is still ONLINE

Why not going the Blockly way and avoid old DSL rule ???