VS Code openHAB Extension!

syntax
ide
vscode
Tags: #<Tag:0x00007f6ce5be46d8> #<Tag:0x00007f6ce5be44d0> #<Tag:0x00007f6ce5be4368>

(Jerome) #61

I think it is currently not possible to make it compatible with other VS products.

As far as i know, the only thing that those extension types have in common is the .vsix file ending.
Nothing more. :smiley:


(Mike Bagdanoff) #62

Bah, oh well. I'll survive having both :grinning:


(Dan) #63

OH2.1 seems not to pick up Visual Studio edits correctly.

I usually get a "model is empty or cannot be passed" error in the logs, followed by the model being loaded correctly. Sometimes models open twice, with strange results.

SublimeText doesn't have this problem. Has anyone else noticed this? Is there a fix?

OH and Visual Studio are both running on Ubuntu 14.


Openhab 2.1 config files not reloading
(Jerome) #64

I can confirm that.


(Kuba Wolanin) #65

Please submit an issue on github with steps to reproduce, I'll take a look at it. Thank you


(SiHui) #66

I don't think we should blame VSC or this wonderful extension for that issue:


(Jerome) #67

I didn't want to blame anything here. :smiley:
Thanks for clarification.


(Dan) #68

I'm working locally, not on a remote filesystem. So a different issue. But certainly not blaming anybody!


(SiHui) #69

This forum has many, many posts about this issue and those occur with different editors: ESHD, Notepad++, ...
If you are working locally, then this is the first time I've read about this.
In that case @kubawolanin is right I guess and an issue should be created.


(Dan) #70

stupid question, but presumably you mean an openhab issue, not a VS extension issue?


(SiHui) #71

Because of this

an openHAB runtime/core issue should be created.


(Sebastian) #72

Hi,
I had a similar issue. But in my case completely nothing happened when saving the config files from vs code. Actually I'm not sure about the root cause because I never tried to edit the files with a different editor in this setup. And know everything works.
My setup is similar to @dan12345's. oh2.1 local install on Ubuntu 16.04

Greetings
Sebastian


(Mike) #73

Way better than HomeDesigner. Thanks & Kudos


(Dome) #74

Being a Mac user, I never even thought to try out Visual Studio. After seeing the positive reception here on the forum, I gave it a go and am very happy using this new extension - far better than Designer. The only problem, and I suspect it’s probably on the roadmap, is that it doesn’t have quite the same level of syntax validation as the Eclipse Designer. I do occasionally open up Designer if I’m having trouble with a rule, but otherwise VS with this extension is my go-to editor!

So, for any Mac users who are wary - don’t be!


(Christian W) #75

Hi nice work!
Just tried to install it in Visual Studio Community but it failed. Should it work with the community edition?
Maybe I just need some other Extension as dependencies?

05.08.2017 08:32:48 - Microsoft VSIX Installer
05.08.2017 08:32:48 - -------------------------------------------
05.08.2017 08:32:48 - vsixinstaller.exe version:
05.08.2017 08:32:48 - 15.0.26430.16 built by: D15SVC
05.08.2017 08:32:48 - -------------------------------------------
05.08.2017 08:32:48 - Command line parameters:
05.08.2017 08:32:48 - C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VSIXInstaller.exe,C:\Users\chrisw\Downloads\openhab-0.1.0.vsix
05.08.2017 08:32:48 - -------------------------------------------
05.08.2017 08:32:48 - Microsoft VSIX Installer
05.08.2017 08:32:48 - -------------------------------------------
05.08.2017 08:32:48 - Initializing Install...
05.08.2017 08:32:48 - Extensiondetails...
05.08.2017 08:32:48 - 	Identifier         : openhab
05.08.2017 08:32:48 - 	Name               : openHAB
05.08.2017 08:32:48 - 	Author             : openhab
05.08.2017 08:32:48 - 	Version            : 0.1.0
05.08.2017 08:32:48 - 	Description        : openHAB syntax highlight, code snippets, integrated Basic UI preview and docs search
05.08.2017 08:32:48 - 	Locale             : en-US
05.08.2017 08:32:48 - 	MoreInfoURL        : 
05.08.2017 08:32:48 - 	InstalledByMSI     : False
05.08.2017 08:32:48 - 	SupportedFrameworkVersionRange : [0.0,2147483647.2147483647]
05.08.2017 08:32:48 - 
05.08.2017 08:32:48 - 	SignatureState     : Unsigned
05.08.2017 08:32:48 - 	Unterstützte Produkte : 
05.08.2017 08:32:48 - 		Microsoft.VisualStudio.Code
05.08.2017 08:32:48 - 			Version : 
05.08.2017 08:32:48 - 
05.08.2017 08:32:48 - 	Verweise           : 
05.08.2017 08:32:48 - Signaturdetails...
05.08.2017 08:32:48 - 	Extension is not signed.
05.08.2017 08:32:48 - 
05.08.2017 08:32:48 - Er wird nach passenden Produkten gesucht...
05.08.2017 08:32:48 - Installiertes Produkt gefunden - Globaler Pfad
05.08.2017 08:32:48 - Installiertes Produkt gefunden - Visual Studio Community 2017
05.08.2017 08:32:48 - VSIXInstaller.NoApplicableSKUsException: Diese Extension kann auf den derzeit installierten Produkten nicht installiert werden.
   bei VSIXInstaller.App.GetInstallableData(String vsixPath, Boolean isRepairSupported, IEnumerable`1& skuData)
   bei VSIXInstaller.App.Initialize(Boolean isRepairSupported)
   bei VSIXInstaller.App.Initialize()
   bei System.Threading.Tasks.Task`1.InnerInvoke()
   bei System.Threading.Tasks.Task.Execute()

(Kuba Wolanin) #76

Hi Chris,

It’s a plugin for VSCode, not Visual Studio Community. Cheers


(Dome) #77

Yes, what he said. If it makes you feel better, I did the same thing.


(Christian W) #78

Thanks! Now it’s running :slight_smile: Very neat!


(Yannick Schaus) #79

@kubawolanin I’m wondering why it doesn’t have been published to the marketplace yet? v0.1.0 is pretty good and definitively worthy of being published.


(Kuba Wolanin) #80

There was some issue with authorizing new members to the visualstudio.com account.
@Kai do you think we can try again with this?