VSCode - Deprecated?

All, Any idea why this is all of a sudden coming up. Doesn’t seem to effect anything, currently using OH 2.5.

image

image

This is probably because your VSCode openHAB addon has been upgraded to ver. 1.0.0

You have to adjust your config values.
See “openHAB update notice” in VSCode for details.

1 Like

As @kristofejro already said.

We have changed some config parameters to an improved structure and will replace the outdated ones at some point.
This is why the message showed up.

You can open the update notice with cmdshiftp and then seraching for openHAB update notice.

It will tell you which parameters have changed and how the new ones are called.
A simple rename to the new parameter names should then solve this warnings.

Noob question, where are these changes made ?

Read the post just ahead of your post!

This depends on your personal installation of vscode. (Sorry no one-click answer available here.)

You can go to settings (while having your openhab folder opened):
image

And search for openhab.
image

In my case there are settings available on user and workspace level (which are the main places to configure something).

I would then switch to json view with the
image
button and check if you have anything configured.

The json view will show default available settings and tabs for each of the config locations that are aavailable/used in your case.

You can then check for the outdated values from the update notice and replace them with their new namings.

A post was split to a new topic: RPi 4 high load with openHAB extension 1.0.0

In my case I have to change:
Usage of deprecated config => openhab.username <= detected.
Usage of deprecated config => openhab.host <= detected.
Usage of deprecated config => openhab.port <= detected.
I followed the instruction above, but cant find the values or the all have allready the new naming.
I have a Raspberry Pi 3.2 installation.
In which files can I make the changes?

I got a similar issue.

VSCode says:

Usage of deprecated config => openhab.port <= detected.

But on all three levels the parameter was not found (because i already removed it):

The same problem remains in my installation! Any solution?

You should be able to use the following entries with the latest version, they work fine for me (with OH3) :slightly_smiling_face:

openhab.connection.host
openhab.connection.port

If you use an auth token (in OH3):

openhab.connection.authToken

Or if you use just basic authentication:

openhab.connection.basicAuth.username
openhab.connection.basicAuth.password

Probably a complete extension uninstall may help, since it is possibel that the problems occur due to some cached config values lying around somewhere.

That didn’t help for me, the “Usage of deprecated config” messages still appear for config entries that I don’t put into my settings.json because I don’t need them.
I think those are provided by the extension by default, so just ignore them.

Same problem here, fresh install and i still see “Usage of deprecated config => openhab.username <= detected.” …