WeMo Binding News

Hi all WeMo users,
it has been a long time since I have done major changes to the WeMo Binding, but actually, there are some important news.

Some might have noticed an ugly bug regarding the WeMo socket devices, causing communication issues cause of random port changes. This issue has been fixed a while ago, thanks to @jwiseman for his extensive testing and patience :slight_smile: , and is available in the latest Milestone or SNAPSHOTS.

Implementations of the WeMo Dimmer Switch is finished and also available in the latest SNAPSHOTS.

Somehow, my implementation for the Crock-Pot Smart Slow Cocker got lost within the binding and was readded in the last Days.

Really new is the implementation for the holmes series of Devices
Holmes Smart Air Purifier with WeMo
Holmes Smart Humidifier with WeMo
Holmes Smart Heater with WeMo

Please note, that these devices are in a experimental state, so expect some issues while testing.

You can find the new test version of the WeMo Binding here :
(Goto the link and press Download).
Please uninstall your old WeMo Binding, stop openHAB and clean its cache.
After a restart, put the .kar file into your openHAB addons folder and wait a few minutes for your devices to appear.

Attention: Usiers of older Binding versions with Crock-pot or Dimmer support need to delete the old Things, as the channel structure has changed a bit.

Complete new Readme with examples for Things, Items and Sitemap can be found here:

If you encounter any issues with the new devices, please enable trace log in Karaf console

log:set TRACE org.openhab.binding.wemo

and send me the trace log via PM.

Happy testing :slight_smile:


Nobody ???
Even positive feedback is appreciated :wink:


I tried to install the .kar file.
But it appears that this is not working.

I get the following message in the log-file:
[ERROR] [org.apache.felix.fileinstall ] - Failed to install artifact: /opt/openhab2/addons/org.openhab.binding.wemo-2.5.0-SNAPSHOT.kar
java.lang.NullPointerException: null
at org.apache.karaf.kar.internal.KarServiceImpl.findMissingDependency(KarServiceImpl.java:159) ~[?:?]
at org.apache.karaf.kar.internal.KarServiceImpl.install(KarServiceImpl.java:115) ~[?:?]
at org.apache.karaf.kar.internal.KarServiceImpl.install(KarServiceImpl.java:94) ~[?:?]
at org.apache.karaf.kar.internal.KarServiceImpl.install(KarServiceImpl.java:86) ~[?:?]
at org.apache.karaf.deployer.kar.KarArtifactInstaller.install(KarArtifactInstaller.java:50) ~[?:?]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:950) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:884) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:489) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

I’m running Openhab 2.4 on a Raspi 3.
Any suggestions?


Would you please provide some more information about your system, what os and what Java version do you use ?
How did you download the file ? Your errors seem to be related to a corrupted file.

Btw, where are you located? The new version is interesting for US users mainly, as the new devices are 110V units.


I’m running a Raspi 3 with Java “openjdk version 1.8.0_152”
I downloaded the file from you link above to my Mac and copied it directly to the Raspi.

I’m using the system in the US and having problems with the WeMo’s Smart Plug minis.

There are no changes in the testing version you could benfit from. It is just implementing new devices. For your Minis, I would reconmend openHAB 2.5 release, which included the mentioned fixes.

I have problems with changing ports and try to resolve this with this update.

For sure I will update to 2.5 in the future but want to wait until there are more experiences in the community. Maybe I should not wait too long.

Anyway thanks for your help.

The port issue was solved before 2.5 release. Try to downloaf the file again, as it did work for other users.

Anybody testing the new device support ???