WeMo motion?


Just wanted to check if something happened with supporting wemo motion in the wemo binding? Still waiting patiently… :slight_smile:

I am making slow progress on the ESH version of the WeMo Binding, but nothing to be published yet. Still facing reliability issues while communicating with the WeMo’s.

Probably, these extensions might not be implemented into openHAB 1.8.


Hi Hans-Jörg, I think I might see an issue with the current code. In the most recent commit in line 186 it’s looking for the word “motion” in the UDN, however the WeMo motion’s UDN doesn’t contain “motion”, it contains “sensor”. Could this by why the device isn’t working? I would try it myself but I don’t have a dev environment set up that will build the stuff at the moment.

You are right, the recent changes to the WeMo motion are not implemented.
I will update this over the weekend.


Fine by me, I’m patiently waiting for the android app to openhab 2, then
I’m switching as well…

I noticed that in OpenHab2, Wemo Motion devices will only allow me to link to Switches, even though thats not the info they’re supplying. They won’t connect to Motion items. Is everyone else having that problem?

Hm, never noticed that there are explicit motion devices and what State they need.
I will have a look and see how to change this.

Update :

According tho the documentation, the switch item type is correct :

Channel Categories

The channel type definition allows to specify a category. Together with the definition of the readOnly attribute in the state description, user interfaces get an idea how to render an item for this channel. A binding should classify each channel into one of the existing categories. This is a list of all predefined categories with their usual accessible mode and the according item type:

Category Accessible___Mode____Item Type

Full list can be found here :

hi all - just reviving this thread. So my binding detects the wemo motion sensor, but putting in a contact item doesn’t seem to be doing much. From what I read about, the 1.8.1 binding doesn’t support wemo motion as yet? is that correct?

If so, I guess I could look at IFTTT recipes although this isn’t an ideal solution given that it has to traverse the internet twice to actuate stuff

If you read the WiKi, the binding supports motion sensors, but it is limited in the 1.8 Version, cause of polling mode. So for this use case, I would recommend openHAB 2.0 with the ESH version of the Binding.

@hmerk, do you think you could show me example of a working scenario with rules where motion from the WeMo triggers an event? I’ve tried this:

	Item Motion1 changed
	sendCommand(HueColor1, OFF)
	sendCommand(HueColor2, OFF)
	sendCommand(HueColor3, OFF)

With just “Switch Motion1” in my items. But it doesn’t seem to work.

What about having a look into the WIKI sample-rules :slight_smile:

Hi all, sorry for the double post but I thought this might be a good thread to ask my question.

For all the success I’m having with OpenHAB2b4, I just can’t seem to get my Wemo motion sensor to “stick”. Starting from a clean install, I can add the binding and my motion sensor is detected. I add it as a thing and can see the status switch on and off in my sitemap as I create motion. However, after a period of time - the latest being around 24 hours - OH no longer receives/responds to motion. On the paper_ui page, the sensor status is Online. If I restart OH, I can see in the logs that the sensor goes from UNINITIALIZED to INITIALIZING then INITIALIZING to ONLINE. However, motion still isn’t detected. The weird thing is that if I take a fresh OH2b4 folder and replace my install, then install the Wemo as a thing, it starts receiving/responding to motion again. I can even simply copy over all my previous items, sitemaps, rules etc. and the sensor will continue to work… for a while. Does anyone have any advice? Am I doing something wrong at my end? I know the sensor is still working because if I also use IFTTT to send me a message, I receive a message saying motion was detected. Thanks for any help!

Please post you debug log so I can see if there are any errors.

Logs attached. I added some logging to see if my rules were being run correctly. Around 2016-10-20 is the last acknowledgement of motion. However, several times after that the sensor is detected and goes through initializing to online. It doesn’t appear that any errors are raised and I can confirm that the wemo socket continues to work. Thanks for any help!

events.log http://pastebin.com/isaFYFcd
openhab.log http://pastebin.com/ghXxuJPj

You should try the latest snapshot, cause I see a WeMo related charset error which has been solved.

Will do. Cheers.

Hmm i thought i knew where to download the nightlies but i must be confused! Can you point me in the right direction?

Offline Distro

Online Distro

DId this work for you? I still can’t get mine to work.

I haven’t tried in a while tbh, can’t find any information about WeMo being
more supported in 2.0. I went back to node-red and a very nice package
someone wrote there for wemo. Both inputs (with motion) and outputs works
perfectly. Will connect this to openhab using mqtt until I know the
built-in support works fine.