Wemo Switch Working but Can't Show Power

Hello I have successfully configure a WeMo Insight Switch so that I can turn if off and on. In Items it is as follows:
Switch BedroomLights “Bedroom Lights” (FF_Bedroom)

I can switch it off and on whichis good but the Wemo OpenHab page also shows that powerconsumtion can be shown but it is not working.

I have tried:
Switch BedroomLights “Bedroom Lights” (FF_Bedroom) { channel=“wemo:insight:BedroomLightsr:currentPower” }

not working. I have also tried using VisualCode and right clicked the Create Items from CHannels and only the state comes up IT can definitely show power but I can’t see what is wrong.

Please read the Binding docs


You need a number Item, not a Switch

Yes that is what I have been reading. I have added the following:

Switch BedroomLights “Bedroom Lights” (FF_Bedroom)
Number InsightPower “Bedroom Lights” (FF_Bedroom) { channel=“wemo:insight:BedroomLights:currentPower” }

When I add this to the items file nothing changes and the swicth in basic ui just has a switch still.

Apologies I spotted my mistake and now have the following:
Switch BedroomLights “Bedroom Lights” (FF_Bedroom)
Number BedroomLights “Bedroom Lights” (FF_Bedroom) { channel=“wemo:insight:BedroomLights:currentPower” }

I restared the openhab2 services as well just to see if that changed anything but this time it has a number 1 that I can change by clicking on it and then it has an and an down arrow.
Odd

Oh and the toggle switch has gone. I must have a formatting error or something I think but i can’t figure it out from the guide that you posted.

Sorry, you did not read the docs carefully.
There are examples for your the sitemap definition.
To show the power in BasicUI, you need to define a Number Item there as well.

Ok forget basic UI for now I’m using groups so I don’t need to add anythign in there as all of my switches already appear in Basic UI and they are not listed in the sitemap. That groups idea is great and I am looking forward to trying the new happanel once I get the Insight switches working correctly. . The paper UI is not working but showing a number with a button next to it as previously shown in my last post picture. There isn’t really much in the guide so it looks like it shouuld be simple. If i am missing something obviousl I can’t see it.

Also I don’t know if you are a moderator of this site and have some sway with the OpenHab developers. Perhaps you do. From a new comers perspective if the application was developed so that the configuring in the paperui would write to the configuraion files instead of or alternatively to the internal database where the code can’t be seen then this application would be awesome and practically self teaching. Probably difficult to do but sometimes good to get a new comers user perspective.

I am a moderator and the developer of WeMo Binding. :wink:
You first should get familiar with the concept behind openHAB, so reading the docs, especially beginners section, is strongly advised.
You posted two items, a Switch without a channel definition and a Number Item linked to powerConsumption. This is not going to work
You need to link the Switch to the binaryState channel.
Afterwards, you should see a Switch in PaperUi and below an entry for average Power.
You can copy and paste the channel definitions from your thing with the little symbols on the right.

Regarding your suggestion, items and sitemaps are not copied to an internal database, their files are loaded into memory at runtime.
This might change with openHAB 3.0

Hello all please see the attached code that I have tried for a Belkin WeMo switch. The switch appears but the power used doesn’t show. Does anyone know if there is a quirk that I have missed out please. It looks fine from the openhab guide

The Paper has the name and now switch anymore, the power symbol and 1 next to it. If I remove the channell part of the code then it works for the switch only but doesn’t show any poer consumption. The guide is short and there is not much more that I can glean from it unfortunatley.

As I wrote in my last post, your Switch item is missing the state channel definition, like shown in the docs.
Like you have it right now, openHAB does not know what Binding to use for the Switch Item.
Another thing, your Switch and Number Item need to have different names.
Your Items should look like this


Switch InsightSwitch “Bedroom Lights On” (FF_Bedroom) { channel=“wemo:insight:BedroomLights:state” }

Number InsightPower “Bedroom Lights” (FF_Bedroom) { channel=“wemo:insight:BedroomLights:currentPower” }

1 Like

I’m sorry I dodn’t see your last post. I don’t hink I refreshed my page in time. I have been reading the documentation over and over for weeks now. A lot of it has sunk in and I have made good progress. Using the Paper UI works quite well and I have used that previously and got the power showing on that as it does it automatically. I just wanted something a little more that I cold see and save for resilency and realised that I diodn’t want to go thorugh all the config if I had to re-install. That is the main reason that Ihave moved from OpenHab for hassio. Also you installtion is massively easier that hassio. Seriously your install procedure really is to be commended. It’s great.

So now I have tried the following:


That leaves me with WeMo switch and switch in Paper UI so everything for Bedroom Lights has gone. Kind of makes sene though with the Insight Switcgh and insight Power Names.

Then I tried the following:

That just leaves me with the name of the switch correct but a 1 and no Watts after it and no toggle switch.

I restarted the openhab2 services again as I have made so many small changes back and forth just in case as well but still no luck.

It’s getting a bit late for me to carry on now but thanks for trying I will try and post again after work tomorrow as I really want to get this fixed.

Small update still now toggle switch after restarting services but now saying NaN where the power should show.

You must give every Item a unique name. You cannot have a Switch type and a Number type both called BedroomLights

Show us your WeMo Thing in PaperUi with the Channels section

Here is items file:

Here is things I have redacted a bit as I wanted to kep the name secret for security. I may be going over the top a bit there though:
Things

The redacted bit says BedroomLights I have selected add a link but there is nothing there to add for Bedroom Lights any more ie the Power State although I didn’t think that there would be. Now the PaperUI is a bit better as it shows the toggle switch but no power display at all.

This is not an Insight Switch, so no power readings. If it would be an Insight, you would see the other channel here.

I’m sorry it really is an insight switch

Have you clicked on the “SHOW MORE” button, located on right side of page? For some bindings, not sure about this one, it’s required to see all channels.