What does it actually mean when a binding has 'expired'?

The openwebnet binding users have a problem. The binding appears to have expired.

openwebnet binding thread

It’s happened before and the developer fixed it. Only this time the developer(s) have gone awol.

Its an important binding for those us who have the Legrand/BTicino home automation BUS system. So, I am trying to dig a bit deeper to see if anyone of us might have the skills, time, and could learn how to fix the issue without the main developers. I believe it’s something to do with Eclipse IDE. Is that the correct direction?

You can place a bounty on it and see if anyone will help.

1 Like

What really needs to happen to fix the problem you’re in is to have the binding become an official OH addon so that its code is available in the OH repository and can be modified by anyone.

Yes, I believe that was what the developer was doing a year ago after the first time it happened. I remember him saying that he was struggling to get the official release for his addon. I never saw those ‘developer’ conversations and so its just speculation that he decided to abandond openHAB and the community; so far its been one year since he posted. It would be great if someone could shed some further light on why this happened.

Some kind other has now hacked the byte code and changed the expiry date so that the binding has another year lease of life.

I found the PR that’s trying to accomplish that.

1 Like

Thanks. That fits with what I remember. gitHUB Mvalla is openHAB massi. I did see signs of activity when searching gitHUB but did not find the details you link to. I must searching wrong or more likely I am clueless about how gitHUB is organized.

So, massi was working on the binding official release 4months ago and just now someone is asking questions :wink: on the PR. I can only hope he still is active but just highly focused. However, it does seem strange that he doesnt communicate or respond to the binding testers anymore to let them know.

I hope it does not have anything to do with the actual covid situation we have in nothern italy. i really home @massi is up and running…

Actually, he last posted on January 19, 2020. Not in January 2019.

image

So while he may have left OH, he may also just have been preoccupied for the past two months.

The sad thing is that the binding is working well and now is blocked for a “stupid” expiration thing. If @massi could just recompile and extend the expiration date even for a year or so that would be awesome.

Ooops , you are correct. The side bar thing is a bit confusing. At the top it shows the year and for posts also the year next to the month except for when its the current year… bad luck for me it was Jan 19 and not Jan 2019. My memory is so bad I should have known it was not that long ago!

However, the developer is still not replying to posts or responding to PM’s. I hope you are correct and that he is just ‘busy’ and comes back to continue the work one day.

Meanwhile there have been quite a few people coming to look for a fix to the expired binding issue with more coming back to the thread all the time.

Yeah, easy mistake to make with the 19 and 20. And it doesn’t change anything about the situation you find yourselves in, unfortunately.

I thought post 4 was the answer.

The binding is working again thanks to a date hack. Its got another year before we are back in the same boat. Unless massi returns.

That’s true but it’s an hacked version that has been reported to be perfomring poorly.

Hi everyone,
How can be possible that my binding worked till yesterday (24/03/2020) and suddenly stopped working (gateway communication error). I’ve installed the beta release from the PaperUI add-on section.
Now I’ve uninstalled it and used the modified jar and everything is working again but the question is:
why today? how can be possible that “my” versione expired later that the others (i saw some posts of 11 days ago)
The only “strange” thing is that today i’ve restarted the Raspberry on which OH runs… can this be the reason why it worked till yesterday (and stopped today)? [I mean maybe is the first restart since the expiration of the binding]
Thanks
Francesco

The expire date doesn’t come into play until OH is restarted.