What to do when Z-Wave secure inclusion fails?

I have bought my first secure Z-Wave device, a Danalock V3. I included it and was very happy with how smooth the inclusion went until I realized it wasn’t securely included and thus don’t work at all. I’ve skimmed through some threads on the topic but hasn’t really found out what to do. Do I need to exclude it and include again? I’ve understood that proximity is of the essence, so I guess I need to dismount it from the door (which is about 2 meters from my OH server) and hold it much closer while including. But is it just a matter of reincluding time after time until it’s securely included?

For the record, here’s what I find in the log concerning this:


You need to include it through the binding within 15 seconds. Don’t use any buttons on zwave sticks if any.
After each failed attempt you need to factory reset the device.
Distance should not be a problem.

Oh, crap. So I need to:

  1. Exclude the device
  2. Factory reset the device
  3. Redo the setup in the app, including BT coupling
  4. Try the inclusion again

…and then do all of this again for every time it’s included non-securely?

From where are the 15 seconds started? I guess it’s from when I click “connect” in the app and the inclusion is started from the lock’s point of view? If it’s from when it’s factory reset I don’t see how it would be possible…

Yes, for 1, 2 and 4.
For 3 I have no idea, what does BT have to do with the zwave binding?

From where you click the add button in PaperUI or HABmin. Then you have 15 seconds to finish the inclusion on the device (push the appropriate buttons, see you manual)

Again, this has nothing to do with openHAB.

The steps for putting the device in z-wave inclusion mode is to push a button in an app, and in order to do that the lock has to be BT paired with the phone first.

Is the order important? Now when I paired I did put the lock into inclusion mode first and THEN I put OH into inclusion mode (clicked the “Scan for Things” button in PaperUI). And seconds after that it was found and included, but maybe doing it in that order could ruin things?

If it is included now properly (and securely) you did it all right :grinning:

No… That was my description of how I did when I included the first time, and it got included not securely. Haven’t tried again. I want to do it all right since it’s quite a procedure…

Start binding inclusion, finish device inclusion within 15 seconds.

Ok, I’ve done some struggling with this. I fail on the first step, the one excluding the device. No matter what I do I can’t seem to get my Z-stick to understand that I want to exclude it. I actually don’t think the lock sees itself as included, it’s more of a ghost node on the controller. Any idea how to get rid of it? I’ve tried every exclusion and removal button I’ve found in both paperui and habmin, no matter what I do it just turns up again in the inbox :frowning: