What Z-wave binding am I running?


Trying to get some brightness problem resolved with my Zipato RGBW lamp. It seems to be resolved according this thread

I tried to update my zwave binding in karaf

bundle:uninstall org.openhab.binding.zwave
bundle:install https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastBuild/artifact/bindings/org.openhab.binding.zwave/target/org.openhab.binding.zwave-2.0.0-SNAPSHOT.jar

and when I do a list, I see:

200 | Installed |  80 |    | ZWave Binding


  • When I use the Basic UI web interface it the brightness is still low and I can’t get it to full brightness (I have a reference lamp still running on OH1 which is much brighter).
  • When I try to change the items on the lamp java errors are all over the place and it shows binding-wave:2.0.0.b4 (see snippet blow).
  • When I look in the Paper UI, I see binding-wave-
21:40:34.118 [ERROR] [ve.internal.protocol.ZWaveController] - Exception during ZWave thread: Input 2. {}
	at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveColorCommandClass.processColorReport(ZWaveColorCommandClass.java:182)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveColorCommandClass.handleApplicationCommandRequest(ZWaveColorCommandClass.java:104)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.serialmessage.ApplicationCommandMessageClass.handleRequest(ApplicationCommandMessageClass.java:119)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingRequestMessage(ZWaveController.java:242)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingMessage(ZWaveController.java:208)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController.access$7(ZWaveController.java:202)[191:org.openhab.binding.zwave:2.0.0.b4]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController$ZWaveInputThread.run(ZWaveController.java:1298)[191:org.openhab.binding.zwave:2.0.0.b4]

I hope the answers to the following questions can help me further:

  • what version of the binding am I running?
  • where are the files for the different UI’s located? I can update them manually.
  • what is the best way to update the packages.

Other things I tried that failed:

  • The solution in this thread. It resulted in ‘no sitemap found’ or ‘file not found’ in all available UI’s
  • Put the latest jar file in the addons directory. Had no result whatsoever.

From the above, I would have said you had the right version, but you’re right, the org.openhab.binding.zwave:2.0.0.b4 leaves me thinking that you might really be running an older version from beta 4.

I further suspect that it’s an old version by the fact that the line the error is reported on (line 182) doesn’t have any code in the current version.

Probably an old version - probably beta4 from about 3 months ago.

I’m not sure why this is relevant - sorry. This issue was resolved in the binding :confused:.

It probably depends on how you installed your system. If you’re using a package manager such as apt-get, then upgrade through that. Otherwise there are scripts around to do upgrades of manual installs if you search the form.

1 Like

Thanks for the very fast response Chris!

I noticed one awkward thing; The ‘list’ result shows the status ‘Installed’ for the ZWave Binding and not ‘Active’. Tried to find a solution for that but after another hour of searching I gave up. I did a full reinstall of my Pine64 and I managed to get OH2 running with the latest version now. Most important: The problem with the Zipato light has been solved as well.

I missed that, but it almost certainly means that there’s a second binding running. A full install has fixed it, but if you have this again, do a list |grep ZWave to see. You can then uninstall XXX to uninstall the older one.