WOL RPC not working

Just installed the latest stable build of openhab2 on a new VM; going to rebuild openhab from scratch.
I’m trying to rewrite everything.
I installed the WOL and exec binding.
Trying to get WOL working first.

ON, seems to work.
OFF, does not; it is a windows machine.

My item looks like this: Switch WOLWorkVMs2 “Work Two” [ “Switchable”] { wol=“”, exec=">[OFF:net rpc shutdown -C MESSAGE -I -U username%%password 3 -f -t 1]" }

I know windows is configured correctly, it still works in other apps and my 4 year old instance of openhab. The difference between then and now is it looks like I don’t need a rule now.
All the code is basically in the item.

Prior to this, in the old openhab instance, i had a rule that would run when the switch was turned off:
executeCommandLine(“net rpc shutdown -I -U User%Password”)

If i send this in from the terminal:
net rpc shutdown -f -t 0 -C ‘message’ -U user%password -I
The windows machine DOES shutdown.

I also ran that from the command line with sudo -u openhab and it worked.

No idea why it won’t run from the binding/item

Do you find any hint / error message in the openhab.log / events.log file or in the windows eventlog file of the target system ?

Openhab log says nothing at all when i attempt to turn it off; i’ll check out the windows machine

Nothing in the windows log files either

I set the log to trace on the wol binding then did a log.tail and when i execute the switch to off…nothing shows up in the log file in openhab

I’ve literally tried everything; looked at that exec binding white list page…I can’t make heads or tails out of it. Item: Switch WOLWorkVMs2 “Work Two” [ “Switchable”] { wol=“”, channel=“exec:command:NetRpcWorkVMs2Off:run” }

If i do this and make a “thing” : Thing exec:command:NetRpcWorkVMs2Off [command=“net rpc shutdown -I -U user%%pw -f -t 0”, interval=0, autorun=false]

and i toggle the switch, it goes on off on off and i finally see something in the log:

Tried to execute ‘net rpc shutdown -I -U user%%pw -f -t 0’, but it is not contained in whitelist.

However i don’t know what exactly to put into that file; i’ve tried numerous combinations of things. also no idea why the switch goes ON and OFF when i push it once.

This is not going to help for switching off - WOL = Wake On Lan, it never turns anything off.

The message tells you what it was looking for, have you tried that? You have to put the whitelist file in the right place as well.

Because the exec Thing run channel tells you what the binding is doing, as it explains in the docs. When the script starts to run, the channel turns on. When the script exits (probably just a few milliseconds later), the channel turns off.
You will not be able to use this channel to represent the on/off state of some remote PC

Have you looked at this thread?

I guess the only thing i can ask at this point is are there clear examples of a thing defined as a command, like rpc shutdown and how does one define that in that file…because i’ve already exhausted numerous amounts of combinations of me trying after reading those posts.