Xiaomi Aqara Temperature and Humidity Sensor sensor not sending information

I bought two Xiaomi Aqara Temperature and Humidity Sensors and some Aqara Door and Window Sensors. Now I want to connect them to my openHAB. For the connection I’m using a TI CC2531EMK USB Stick.
The Door and Window Sensors connected without problem and they send their information correctly.
But the Temperature and Humidity Sensor makes a lot of problems. First, I have to turn it on multiple times until openHAB connects it correctly and it shows the online status. But when I link it, it doesn’t show me any information.

This is what the log tells me, but I don’t know what to do with this information.

2019-12-28 02:22:07.559 [me.event.InboxRemovedEvent] - Discovery Result with UID 'zigbee:device:89fbc39a:00158d00045065dd' has been removed.

2019-12-28 02:22:07.629 [hingStatusInfoChangedEvent] - 'zigbee:device:89fbc39a:00158d00045065dd' changed from UNINITIALIZED to INITIALIZING

2019-12-28 02:22:07.658 [hingStatusInfoChangedEvent] - 'zigbee:device:89fbc39a:00158d00045065dd' changed from INITIALIZING to UNKNOWN

2019-12-28 02:22:07.702 [nt.FirmwareStatusInfoEvent] - Firmware status of thing zigbee:device:89fbc39a:00158d00045065dd changed to UNKNOWN.

2019-12-28 02:23:19.798 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:89fbc39a:00158d00045065dd' has been updated.

2019-12-28 02:23:19.811 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:89fbc39a:00158d00045065dd' has been updated.

2019-12-28 02:23:43.885 [ERROR] [r.ZigBeeConverterAtmosphericPressure] - 00158D00045065DD: Error 0xffff setting server binding

2019-12-28 02:23:43.889 [INFO ] [ng.zigbee.handler.ZigBeeThingHandler] - 00158D00045065DD: Channel zigbee:device:89fbc39a:00158d00045065dd:00158D00045065DD_1_pressure failed to initialise device

2019-12-28 02:24:44.011 [hingStatusInfoChangedEvent] - 'zigbee:device:89fbc39a:00158d00045065dd' changed from UNKNOWN to ONLINE

2019-12-28 02:24:44.032 [me.event.ThingUpdatedEvent] - Thing 'zigbee:device:89fbc39a:00158d00045065dd' has been updated.

2019-12-28 02:25:08.086 [ERROR] [r.ZigBeeConverterAtmosphericPressure] - 00158D00045065DD: Error 0xffff setting server binding

2019-12-28 02:25:08.091 [INFO ] [ng.zigbee.handler.ZigBeeThingHandler] - 00158D00045065DD: Channel zigbee:device:89fbc39a:00158d00045065dd:00158D00045065DD_1_pressure failed to initialise device

Hi there, maybe the distance to the gateway is to far. Check first if the sensors working close to the gateway. My experience is that the Xiaomi temp sensors have a limited transmission range compared to other Zigbee components and it depends on the building situation how far they can transmit. In my situation it worked reliable after installing a Zigbee plug „somewhere in between“.

Well I sit closer to the gateway with the humanity sensor than the window sensor.

I also tried to remove and reset the humanity sensor, nothing helps.

Maybe the firmware in the device needs updating or it’s too new and the binding does not have this info?

I didn’t update them, because I read that it blocks the zigbee communication in Europe. Or does it that when I use the Xiaomi Gateway, which I’m not using?

I’m in US and haven’t a clue,:neutral_face: hopefully someone from Europe will jump in and help with your question.

You can ignore this firmware status UNKNOWN message - it will not be relevant as to why this isn’t working.

I just remembered, after it gets the online status (i have to reconnect it multiple times) openHAB shows me a firmware name, but I don’t get any information from the sensor

A logfile could possibly help if you can get one - although it depends on where the problem lies. In any case, it can’t hurt.

The log file from the sensor? How can I get it?

No - from the binding (I doubt the sensor has a way of creating a log file).

I connected the UBS stick directly to openHAB without zigbee2mqtt. Where can I find the log file?

Sorry - I completely missed that you are using zigbee2mqtt here. I thought you were using the ZigBee binding?

Well yes, I’m using openHAB WITHOUT zigbee2mqtt :sweat_smile:

Ok, sorry - I’m a bit confused now. If you’re not using zigbee2mqtt, why mention it?

Anyway, have you read the ZigBee binding documentation?

I read the documentation, but I didn’t memorize it. What are you trying to tell me? The biding itself works fine, with other xiaomi devices and hue lamps.

You asked how to create a logfile. I simply pointed you to the documentation :wink:

Okay i understand :smiley:
I’m currently not at home. I will show it up later :slight_smile:

1 Like

To eliminate transmission issues it is better to check the functionality right at the gateway. If it is not working there then it makes sense to search for other sources.

Is there a way to enclose the debug information? I turned off all zigbee devices, until the both xiaomi ones, I can’t turn them off. But I get so much in the log, I guess the most things are not relevant for this topic.

@dontplay I don’t have a xiaomi gatway.