Xiaomi Mi Home Gateway Binding not working on OpenHAB 3.1.0

Hi all,
I don’t know if someone have the same issue, I have just updated OH from 3.0.2 to 3.1.0 (Windows 10 machine) and Xiaomi Mi Home Gateway binding has stopped working. Until now it works perfectly, but now can’t bring Bridge to online.

Console is reporting me this issue that never has happened before update:

Exception in thread "XiaomiSocketReceiveThread(9898, 704f57809754)" java.lang.NoSuchMethodError: 'com.google.gson.JsonElement com.google.gson.JsonParser.parseString(java.lang.String)'
        at org.openhab.binding.mihome.internal.socket.XiaomiSocket.receiveData(XiaomiSocket.java:199)
        at java.base/java.lang.Thread.run(Thread.java:834)

Someone knows about this issue?
Thanks a lot in advance.

PD: Is strgange, I remember that wrote Xiaomi Mi Home Gateway binding… but changed to Mi IO…

It seems due to some bug on update script… because I am testing a new fresh OpenHab 3.1 Installation, and doesn’t seems to throw the error with this binding.


I have solved it, adding the serialNumber parameter to the Bridge definition.