Xiaomi Mi Mijia Gateway V3 ZNDMWG03LM try to open port 9898

I’ve a problem to open the port for the new Xiaomi Mi Gateway 3.
At the end I like to connect the gateway to my Iobroker without the xiaomi cloud.

I’ve tried a few things already…

  1. I’ve followed a few different steps like descripted in following topic:
    [SOLVED] Openhab2 - Xiaomi Mi Gateway - does not respond
  2. I’ve connected the GW like below picture… (without VCC+ (yellow))
    2.1 The serial band rate speed is 38400
  3. So I can read and receive a few commands but cannot transmit any
  4. Does anybody know what I have to do, maybe @Ingo1977 ?

…and here a section of the recorded data:

=== RootFS Firmware ===
== 10 == factory test failed, can not run apps!!!
== 9 == factory test failed, can not run apps!!!
factory_test bulid time:20:16:38 Nov 15 2019
== 8 == factory test failed, can not run apps!!!
file=/var/device_config,did=xxxxxxxx //changed
key=xxxxxxxxxxxxxxxx //changed
check did xxxxxxxx //changed
*cat: can’t open ‘/device.conf’: No such file or directory *
cp: can’t create ‘/device.conf’: Read-only file system
gobal_cmd_list size 4804
ble uart port: 1
zigbee uart port: 2
homekit i2c port: 1
factory udp_init!
Input cmd:[ 10.660000] store_tty0_enable buf=disable
[ 10.660000] , count=8

Did you read this thread:

There seem to be some different V.3 gateway boards.

Probably I am a stupid, but this thread began in 2018 about Xiaomi miija upgraded version, the same, like I have:(

@coupeaze I think nobody succeeded so far in opening port 9898 on this multimode gateway. Btw. thanks for opening this new thread. Have you been successful meanwhile?
Is there anybody else who can support here?

Can someone please help us with the gateway?

@Victor_Romanchuk This is a new Xiaomi Gateway supporting also Zigbee 3 devices. But so far @coupeaze and myself are not able to open port 9898 for communication. Can you please help or support?

As I understand, it’s upgraded, but second version. I have bought it long time ago. Unfortunately I didn’t find a solution, kicked this device away and successfully installed CC2531 stick with mqtt2zigbee. That works and useful

This device has a big advantage and this is its range! Therefore I want to use it locally and cut the internet connection. In addition it supports Zigbee 3.0 devices which is also a big plus here. We just need to identify the RX pin and then we can probably find a solution using this device.

@coupeaze Can you post a photo from the other side of the latine as well?
Can you see which chips (names) are used and list them here?
We can then look for the oinout on the web…

If there is anyone that can’t use his gateway now and does not mind to experiment
I’d like to try if it can communicate with the miio protocol.

Just to be clear: It would involve either sending your device or sharing it in the micloud. (or allow me remote access a OH karaf ssh which can ‘see’ the gateway, does not need to be a ‘production’ one)
Note: my aim is to communicate with it without the need for opening/soldering.

Until now I wasn’t successful. I can read only information via Putty thats all.
Below you can see the other side from the board.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.