Xiaomi Yeelight Strip & LED Bulb

xiaomi
yeelight
Tags: #<Tag:0x00007f6ce65d2230> #<Tag:0x00007f6ce65d2050>

(Johan Potgieter) #1

Hello all,

I just purchased the following items.

  • Xiaomi Yeelight Smart Light Strip
  • Xiaomi Yeelight AC220V RGBW E27 Smart LED Bulb

I need some help setting them up. I am running OpenHABian on a Raspberry PI 3 (OpenHab 2.1.0-1). I already downloaded the “org.openhab.binding.yeelight-2.1.0-SNAPSHOT.jar” and placed it in “/usr/share/openhab2/addon/”.

I setup the 2 items using the Yeelight app and confirmed that the both work. I also set the strip to “Developer Mode” within the app.

The binding is showing in PaperUI but I don’t see anything in my inbox. I added both the light by ip manually, like this:
YEELIGHT://172.20.1.122:55443

They still show as offline.

I also tried adding a item like this:

Switch YeelightStrip “Yeelight LED power” { yeelight=“172.20.1.122:55443” }
Switch YeelightStripToggle “Toggle Yeelight LED strip” { yeelight=“172.20.1.122:55443#toggle” }
Dimmer YeelightStripBright “LED brightness [%.1f]” { yeelight=“172.20.1.122:55443#set_bright” }
Dimmer YeelightStripCT “LED color temp [%.1f]” { yeelight=“172.20.1.122:55443#set_ct” }

I also read about LAN and wifi connections so I setup my OpenHabian to use wifi instead of LAN but it made no difference.

I’m not entirely sure if I’m on the right track or not. Any help would be appreciated.


(yaazzz) #2

Hi Manbearpig73, Did you input the token?


(Johan Potgieter) #3

No. What token? Can you explain what I need to do, please.


(yaazzz) #4

Here is how I install it for the strip :

  • Install Openhab Xiaomi Mi IO Binding
  • Setup a new thing by discovering or manually
  • In the thing setup input the ip address et the token

(Johan Potgieter) #5

Thanks for the help. I changed the items to “Developer Mode” in the app and it could be discovered on my Inbox (PaperUI). Both work now without a problem.

Thanks again.


(Johan Potgieter) #6

Do you have any example on how to add these as items and things? I want to not use the PaperUI.

I managed to add the following to items:
Dimmer l01_brightness “Bright” {channel=“yeelight:Wonder:0x000000000xxxxxxx:Brightness”}
Color l01_color “Color” {channel=“yeelight:Wonder:0x000000000xxxxxxx:Color”}
Dimmer l01_color_temperature “Color temperature” {channel=“yeelight:Wonder:0x000000000xxxxxxx:Color_Temperature”}

I want to add a on and off switch and the Color section is showing a switch and not a color picker. Can you help?


(Markus Gevers) #7

Hi, any solution for this here?


(Johan Potgieter) #8

Yeah, in my items I added this:

Switch l01_switch “Switch” {channel=“yeelight:Wonder:0x00000xxxxxxxxxx:Brightness”}

and within my things I added this:

Switch item=l01_switch

I have 1 lightstrip and one RGB Bulb. This is my full setup for them.
Items:

String LightDetails “Yeelight Settings” <“rgb”>
Switch l01_switch “Switch” {channel=“yeelight:Wonder:0x000000xxxxxxxxxxxx:Brightness”}
Dimmer l01_brightness “Bright” {channel=“yeelight:Wonder:0x000000xxxxxxxxxxxx:Brightness”}
Color l01_color “Color” {channel=“yeelight:Wonder:0x000000xxxxxxxxxxxx:Color”}
Dimmer l01_color_temperature “Color temperature” {channel=“yeelight:Wonder:0x000000xxxxxxxxxxxx:Color_Temperature”}
Switch l02_switch “Switch” {channel=“yeelight:Stripe:0x0000000003619807:Brightness”}
Dimmer l02_brightness “Bright” {channel=“yeelight:Stripe:0x0000000003619807:Brightness”}
Color l02_color “Color” {channel=“yeelight:Stripe:0x0000000003619807:Color”}
Dimmer l02_color_temperature “Color temperature” {channel=“yeelight:Stripe:0x0000000003619807:Color_Temperature”}

Things:

  Frame label="Yeelight" {
  	Text item=LightDetails {
  		Frame label="TV Room" {
  			Switch item=l01_switch
  			Slider item=l01_brightness
  			Colorpicker item=l01_color
  			Slider item=l01_color_temperature
  		}
  		Frame label="TV Strip" {
  			Switch item=l02_switch
  			Slider item=l02_brightness
  			Colorpicker item=l02_color
  			Slider item=l02_color_temperature
  		}
  	}
  }

Hope it helps.


(Dr Kuebel) #9

Hi,

I do not find the mi IO Binding…
Ist it not in the stdandard?

running RasPi3 openHAB 2.2.0 Build #1112


(Johan Potgieter) #10

The binding is called “Yeelight Binding”. You also need to setup the light in the ios or andriod app. You HAVE to enable developer mode. After that you will find the item in your inbox.


(marcel) #11

It is not yet standard indeed. So you can get the mi io binding only from the market.(search on xiaomi)


(Tim) #12

planning also to buy that. do I need anything else on hardware (like e.g. a bridge) or is just the yeelight sufficient?


(Dr Kuebel) #13

Thanks… now it´s here :wink:


(Dr Kuebel) #14

The binding is running as expected…

But how do I get the Token from my Yeelight?

I use the iOS APP Yeelight 3.0.0.7.
I set the Bulp ind LAN-Mode but there is no token shown.

In the MiHome APP 4.3.0
I could not set the bulp in Dev mode


(marcel) #15

I don’t know the yeelight app.
For the Mi-Home app, you don’t need developer mode.

search the forum for the xiaomi vacuum, in the first topic you find some more explaination on how to get the token


(Dr Kuebel) #16

With iOS Phones I managed to get the token with this Help from an other Forum
how to get the token with Ios devices (german)


(Thorsten Loers) #17

I am freakin out …
First of all - thanks to everybody who is putting work and knowledge in here. Found a lot, but not what I am searching for right now.

I am running openhabian2.2 on a raspberrypi3, that is connected via LAN to my network.
I copied the binding zip-file to the addons-folder, and it shows.
I tried to add a new thing, but there is no way to specify some IP or token.
Maybe thats why it still shows “OFFLINE” while the bulb is running (Color LED Bulb).
In the YEELIGHT App, I set the LAN mode (is it the same as debug mode?). But I can’t get it running.
Has anybody made a tutorial? It is very exhausting to search through all the threads without finding a solution.
I tried to find on youtube and here, but no chance.
So help would be very much appreciated.
PS: I am not very experienced yet. Just get started, so what is obvious to you is not necessarily obvious to me. :slight_smile:
Thanks!


(Nico Filips) #18

So I’ve bought 3 of these:


Is there a way to get a OH binding yet?
Thank you


(Igor) #19

You can try this:


(Nico Filips) #20

Thank you!