Yet another openhab app access issue

Tags: #<Tag:0x00007fc20ff0cca0>

Hi

I read all posts about openhab app issues on the community but I couldn’t solve my access issue (OH 2.2).

My issue is related to the remote acces (app access).
All the Items are in the BasicUI on the myopenhab website so there is no cloud update issue

Here the settings
URL = https://myopenhab.org:443
ID = my email
pw = my pw (double checked…) and it’s a strong pw
No SSL

ERROR message :

URL: https://myopenhab.org/rest
Username : xxxxxx@xxx.xx
Exception stack :
org.openhab.habdroid.util.HttpClient$HttpException : Unauthorized

=> So it’s a clear access issue (email+pw has been double checked…for sure)

I’m searching for your help. Thks

What about your OpenHAB UUID & secret on the cloud server? They need to be correct too.

Thks for your question

=> UUID & secret : copied from the file to the webside

Remove the port.

Why? Are you using IFTTT? That is the only reason to expose items to the cloud.

1 Like

Sihui

thks your your reply.
with or w/o port doesn’t change the issue

Ok to be clear, if I’m connected to the myopenhab webside with my email/pw I can have all my basicUI.
In my opinion, the data collect to the could works well.

I’ve changed UUID & secret on open the 443 port to the server without any changes…

443 is the default port for https, so you don’t have to specify it explicitly.

Are you sure there’s no space at the end?
What’s the app version?

Hi mueller-ma

Yes PW has been verified a dozen times …
OH 2.2 version

The latest stable version, almost a year old, is 2.4. The latest testing is 2.5 Milestone 5.
In the years since 2.2 was released there may have been cloud server changes required either by vendor APIs, mobile app requirements, or load reduction requirements that broke 2.2 I doubt anybody has tested such an old version to verify compatibility.
@digitaldan may have additional insight, but I think the general recommendation here is to update to a newer version if you need help from here. I doubt any active member here is still running a version that old.

Hello Bruce

Good hint and thks for your frankness !
Indeed, my version sounds a bit old fashion but it’s stable and that’s fine for me.

Ok, I’ll update it.

If it can be useful, I had the same error message few days ago as I had to reset the smartphone and reconfigure the app. The issue was solved as soon as I configured also the local access (I had’nt performed it because I am abroad and I had no need to access the local server).
Bye

Thks Bruno

I’ll try to restart my smartphone but I’ll update OH anyway to stick to the latest version.

Hi all

Latest openhab2 version 2.5 in now installed
image
443 port is open and forwarded to my PI
image
Openhab cloud is installed and well setup


I’m online on the myopenhab web page
image
Using my app on the local IP adress (192.168.xx.xx) I can get the acces to my sitemap.
image
BUT using my app on myopenhab.org site with the right id and password I’m still not authorized ton enter !!
image

What’s wrong ?
Do I have to install a SSL certificat ?

Can you login on myopenhab.org in the browser?

Yes I can enter and I’m ON LINE.
Here the screenshot :
image

Are you 100% sure you entered the correct password in the app? No whitespace at the beginning or at the end?

No, user name and password is fine.

Yes shure !
100 000 times checked…
I’ve changed the password because it wasn’t fully save.
But even with this password it still not working.

Is there any issue with the andoid app ?

Strange. I’m clueless what the issue could be.

(post withdrawn by author, will be automatically deleted in 96 hours unless flagged)