Your openHAB environment is running in simple mode. Paper UI can't edit items when this mode is activated!

i am editing my configuration files with Visual Studio Code. I just installed everything so as of now OpenHAB and VS Code are latest. Whenever I click on the OpenHAB button on the left side of VS Code and click on an item, I get:

Your openHAB environment is running in simple mode. Paper UI can’t edit items when this mode is activated!

Looking at the settings in OpenHAB, Simple Mode is off.




Simple mode within PaperUI is different than running PaperUI in simple.

Using Visual Studio make the change within your addons.cfg

package = expert

is the line you want.

Thanks. I edited the addons.cfg, but no change. Rebooted the computer and restarted Code also but stills says it. Note even though it seems to work, May be related but I do get this on Code each startup:

[Error - 6:13:07 PM] Server initialization failed.
Message: Internal error.
Code: -32603
java.util.concurrent.CompletionException: java.lang.IllegalArgumentException: URI has an authority component
at java.util.concurrent.CompletableFuture.encodeThrowable(
at java.util.concurrent.CompletableFuture.completeThrowable(
at java.util.concurrent.CompletableFuture.uniApply(
at java.util.concurrent.CompletableFuture$UniApply.tryFire(
at java.util.concurrent.CompletableFuture.postComplete(
at java.util.concurrent.CompletableFuture.completeExceptionally(
at java.util.concurrent.Executors$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.lang.IllegalArgumentException: URI has an authority component
at sun.nio.fs.UnixUriUtils.fromUri(
at sun.nio.fs.UnixFileSystemProvider.getPath(
at java.nio.file.Paths.get(
at org.eclipse.smarthome.model.lsp.internal.MappingUriExtensions.toPathAsInXtext212(
at org.eclipse.smarthome.model.lsp.internal.MappingUriExtensions.mapToClientPath(
at org.eclipse.smarthome.model.lsp.internal.MappingUriExtensions.toUriString(
at org.eclipse.xtext.ide.server.LanguageServerImpl.lambda$publishDiagnostics$26(
at org.eclipse.xtext.xbase.lib.ObjectExtensions.operator_doubleArrow(
at org.eclipse.xtext.ide.server.LanguageServerImpl.publishDiagnostics(
at org.eclipse.xtext.ide.server.LanguageServerImpl.lambda$null$9(
at org.eclipse.xtext.ide.server.ProjectManager.lambda$null$3(
at org.eclipse.xtext.xbase.lib.internal.FunctionDelegate.apply(
at java.util.AbstractCollection.toArray(
at java.util.ArrayList.addAll(
at org.eclipse.xtext.ide.server.ProjectManager.doBuild(
at org.eclipse.xtext.ide.server.ProjectManager.doInitialBuild(
at org.eclipse.xtext.ide.server.BuildManager.doInitialBuild(
at org.eclipse.xtext.ide.server.WorkspaceManager.refreshWorkspaceConfig(
at org.eclipse.xtext.ide.server.WorkspaceManager.initialize(
at org.eclipse.xtext.ide.server.LanguageServerImpl.lambda$initialize$10(
… 5 more

Log into paper UI -> configuration and find “simple mode”. Switch it off and press “Save”. Simple mode is on by default if you have select “simple” or so initially.

Below is what mine shows now. Seems like it’s off:

I do have the Items option on my web gui which I know is gone when in simple mode.


All items that have been created before that was put to off are not changeable afaik.

1 Like

That was my experience too

Do you realize how much impact fundamental changes to the config UI have ?
Let alone those gazillions of people that did encounter these or similar problems but never put up a thread for it.

And no, that’s no argument to shrink functionality to a single way of doing things.
It’s an argument to be very careful, to progress slowly and in well-documented and well-announced steps only, with A LOT of overlap in timing and functionality.

We mustn’t frustrate any existing OH user - that’s way more important than to attract new ones.


In this case it will be a change to the core though. (At the moment simple mode is implemented within OH itself, not within Paper UI.) The simple mode is not helpful and frustrates as soon as you are not the first day beginner anymore. Should be removed and the UIs itself should offer to create an item for a channel.

That would be a fundamental change that doesn’t allow a grace or overlap time, but for the end user it feels the same anyway. The textual people will not notice this as they are defining their own items anyway and the UI users don’t notice it because the UI is doing the same that the core did before.

Thanks folks. All I can say, contrary to what is here, that for me Simple mode was always as my screen shot showed. I did try out Simple mode, however because I’m virtual, reverted back to before I implemented anything beyond the base install. So technically I never had Simple turned on. Now if it’s on by default, why mine shows as it does, not sure.



In my case I was able to fix this problem by activating simple mode in the UI, then ‘save’.
Then I disabled it again and once more ‘save’.
Now VSCode is working as expected.


super super!
Had the same problem and was desperately searching for a solution.
Now your hint; activate+save & deactivate+save solved the problem. Thanks!

1 Like

Did that and helped. Seeing also when I click on an item it opens that item in OpenHAB. Not sure if I like that in theory as since I’m editing everything thru config files those items are grayed out so can’t actually do anything but still better. I was also getting constant internal errors yesterday after doing this but not seeing it today. Maybe a reboot of OpenHAB helped as I haven’t close Code since the change.



Your soultion help me too! Many thanks!

Thanks! This worked for me as well!

Hi All, i too have this error. But Simple mode has always been off in PaperUI.

Any suggestions? VS Studio reports its running in simple mode.

Have you tried this?

Hi All, still experience the URI error on opening a file with VSCode+OH extension
Even after the trick in paper UI with simple mode, did also a reboot, no luck.
Do I need to do more? ? Yes, just found out what and now sharing :slight_smile:

  • Environment newest version of VSCode on Windows 10 -> RPI3+OH
Version: 1.37.0 (user setup)
Commit: <removed>
Date: 2019-08-08T02:33:50.993Z
Electron: 4.2.7
Chrome: 69.0.3497.128
Node.js: 10.11.0
V8: 6.9.427.31-electron.0
OS: Windows_NT x64 10.0.17763
  • Content of file “setting.json” is still default:
    "workbench.iconTheme": "openhab"

After some T&E I was able to avoid the URI ERROR by disabling “communication with Language Server of openHAB instance” with following command.

"openhab.remoteLspEnabled": false

Settings in OH English with region NL, Windows 10 (English(Netherlands), not sure what is relevant.
Hope this addition is helpfull if you still encounter URI ERROR.

First steps with openHAB also got this problem.
Just switch the simple mode off - on and off again. restart VC and you good to go

Just switch it off and leave it off :wink: