Z-stick acting up

Since the last few weeks my old Z-stick S2 is behaving very weird. Suddenly it stops communicating with any of my devices even though it reports them as still being online. No matter what I do in OH nothing solves this state, the only thing that helps is pulling the stick out and putting it back in again. This happens almost once a day, I’m starting to get kinda tired of it by now.


  1. Could this have anything whatsoever with upgrading to OH3 to do? It worked good on the milestones leading up to version 3, this problem started somewhere around the RCs. Or is this a pure coincidence?

  2. If I were to buy myself a new controller, what is the chance of that solving anything? I mean, it could be simply my old S2 is broken somehow. But changing controller will be a great job, excluding and including all my devices. And I guess this means a period of me having two Z-wave networks in my house…

  3. What controller would you recommend? The alternatives I’ve looked at are Z-stick gen5, UZB or Razberry.

my guess is no but… Not sure if this is a production system but downgrading to an older version might answer your question. How recently did you begin using OH3? You seem unsure of exactly when things started acting up.
Just guessing, this seems like hardware going bad. Down grading versions to see if that cures the problem might give you peace of mind that it is not software related. Maybe set up a test system with an older version if you have the resources.
Anyhow, for recommendations for a new stick we need your locale oh I see Sweden in your profile so you need euro stick, I’m in US

1 Like

Downgrading isn’t really an option. I upgraded to version 3 some months ago (I think it was milestone 3) and by now I’ve converted all my rules to the new rule engine. This is the production system controlling everything in my house.

It struck me though that what I haven’t done yet (and what I’m sure Chris would tell me to do) is putting the binding in debug log mode and see if it gives me any more information. It will be loads of logs having it like that but I have some GBs free.

But just to be sure I’m correct: Changing controller IS an issue of excluding and including each and every device, right? There are no shortcuts?

Some time ago I made a backup of my Razberry via z-way.
Maybe Aeon has a similar piece of software?

That is exactly what the binding documentation says to do first. I must be unusual. I read documentation before diving in to a complex system.

And it’s what I normally do when searching for an error that I can easily reproduce, so I won’t need to have the debug mode running for days and days. It’s been in debug mode for about an hour now though and only produced about 5MB of log, so I guess it’s feasible for a couple of days.

1 Like

Ah. Random intermittent problems are indeed troublesome.

No shit… Actually, I have now ran the binding in debug log mode for four days and not a single hickup. Why do intermittent errors ALWAYS disappear when you look at them? I’m turning debug off now, I can bet my ass on that Murphy will make the Z-stick bad again within hours…

That reminds me of when I first cut over from HA to OH 2 years ago. I had issues with one device. Restarting the binding did not help. I enabled DEBUG and restarted the binding and things magically worked. After disabling debugging they have kept working for 2 years including reboots & a hardware change.

1 Like

Ok. It’s time to revive this thread again. I actually catched it on debug log now!

The password reset function on opensmarthouse.org doesn’t seem to work at all (I get no mail) and I can’t seem to upload a log and share a link to it without being logged in (?), so I simply put my log in a pastebin for now, here it is.

What happened was roughly this:
Somewhere around 18:20 I realized something was wrong. Immediately started up my Zniffer on my laptop. At 18:24 I tried turning a device (node 15) off just to try, nothing happened. Also I could see on the Zniffer that nothing was sent from the controller and also that stuff were sent from other devices (sensors) that never seems to have reached the controller. Like the radio in the controller was dead. Around 18:28 I pulled the Z-stick and put it back again. This actually seem to have crashed entire OH, but after a minute or two everything worked again.

So, can anyone based on this information tell me roughly what went wrong and why? Is it my controller simply being broken?

edit: I realize when looking closer that the last message received was 16:52:28 so I think we can assume that somewhere around that time something was broken. I don’t know if there is any indication on exactly what though…

Kinda off topic for the thread, but I found out why. The SPF record for opensmarthouse.org is wrong. It’s set to “v=spf1 +ip4: +a +mx -all” but the mail trying to reach my mail server was from My SPF settings are kinda tight so I just got a

Jan 25 18:43:19 localhost policyd-spf[28066]: 550 5.7.23 Message rejected due to: SPF fail - not authorized. Please see http://www.openspf.net/Why?s=mfrom;id=webmaster@opensmarthouse.org;ip=;r=<UNKNOWN>

Something for @chris to take a look at?

I would say yes, you have convinced me well past the point I would have ordered a new one. The sniffer not picking up anything was the clintcher

Please open an issue here.

I know there were server issues a while back perhaps mail servers were changed too.

1 Like

Ok, I’m getting convinced I should by a new controller. Now I have to establish how much work is involved in the shift, hope you can help me with a plan.

I’m clear on that I’ll need to exclude all my devices from the old controller and include them to the new. This is a process that will take me a few days and in the meantime things need to still be working, so I’ll need a transition period with two controllers and thus two separate Z-wave networks. Is it possible having this on one server? And exclude a device at the time from one of the controllers and then include it to the other?

I would expect so. Any securely included devices? They could be a challenge

I have found some cheap devices need a factory reset even after being excluded before they would properly include into a network.

.Also be aware there are now 700 Series Z-Wave Plus 2 devices on the market. The devices are supposed to be backward compatible but the binding does not support the 700 series controller.

I’ve read up, found another thread on the very subject. Shouldn’t be a problem running dual controllers. The only hurdle should be inclusion, there is no way of putting only one of the controllers in inclusion mode. So I guess I’ll have to rely on either pulling the old stick out when including devices with the new, or pulling the new one out and including using the button on the stick. I’ve now ordered a Z-stick gen 5+, so I’ll be on the latest :slight_smile:

About securely included devices… I have a Danalock V3. However my wife thinks it’s too ugly and slow so she is refusing to use it and every time she locks the door using key instead it gets out of sync so I’m thinking of getting rid of it anyway. Anyone interested in buying? Anyway, that’s my only device requiring security :stuck_out_tongue:

I saw that. :frowning: Perhaps temporarily shield one controller with tinfoil while including? I would disrupt that network though.

Hmmm… That actually might work… Definitely easier than pulling it out every time. And I guess the worst thing that could happen is that the device gets included with the “wrong” controller and I have to exclude it again.

1 Like

Thinking about it more the security key is in the binding.You should just be able to securely include the lock after excluding and factory resetting it.Secure inclusion requires a factory reset first.

Yep. I think I did four or five factory resets before succeeding in including it in the first place. The door is about one meter from my OH server but it was too far away, so I had to dismount the lock from the door to get it securely included. Weird stuff…