Z-Stick no longer lets me include or exclude devices

Pressing “View Network Map” under the “Z-Wave Serial Controller” thing doesn’t show anything.

Ahh, right. Well, never mind - it was a mass search and replace in the items file anyway.

I tried that before, but I’ll try it again now that OH’s view of the network has been cleaned up a bit.

No joy. I tried including both of the devices that are missing from OH, and nothing turned up.

I see a total Z-Wave factory reset in my future…

Another possible late tip. Use the API explorer to PUT the missing properties into the Zstick (node1-I’m assuming by now).


1 Like

OK Main UI → Developer Tools → API explorer, and then?

things → PUT → /things/{thingUID}/config ?

I assume you have tried to factory reset these devices? The maybe in some limbo state with your previous configurations.


I actually haven’t. But since the Z-Stick refuses to include or exclude anything (the orange LED) I assumed the problem must be at that end, and not with the devices (it doesn’t know what I’m trying to add)

Sounds about right. When I had this issue I copied using the API from a PI3 and pasted in the Pi4.


So I’d create the properties from the screenshot above to set the node ID, and maybe the other properties?

The nodeid and manufacturer are clear enough, but deviceid and homeid? Are they constant? I could check in Z-Wave PC Controller.

That aside, I don’t see how the problem could be with the OH configuration, so long as the Z-Stick continues to appear as secondary and refuses to include or exclude devices. I’m not sure I see an alternative to factory-resetting everything at this point.

I could try excluding something with “Exclude devices” on the controller thing page. See if anything happens.

I’m coming late to the party and it is late here, so do not want to screw you up. However, the Home ID needs to match the Zstick UID in order for it to appear in the network map.

If you factory reset, start with manually creating the Zstick as bridge, then discover the devices while it is plugged in.

1 Like

I could give it a go.

Presumably I’d need to factory-reset all 27 devices first, since I’m unable to exclude them by conventional means?

Could try, but likely will not work. I think the problem devices still think they are paired with something else, so will not respond.

OTOH the devices that you paired and are shown online, should be able to be removed with “exclude devices” I believe the exclude is active for 30 seconds.

I’d try lining up the UID first, to see if you can avoid work.


1 Like

I wonder if it’s a coincidence that I stopped being able to include new devices in the Z-Stick when the number included reached the number included in the Zipabox. Just a thought.

I’ll try it with one that isn’t too critical, just in case I can’t get it back for a while.

Yep, it’s worth another throw of the dice.

I should probably call it a night soon, it’s quarter past three. :sleeping:

Yeah, I’m done too


1 Like

No, it isn’t. There is no SIS in your Z-Wave network that could provide additional node IDs to your secondary controller.

One last idea from my side:
Contact Aeotec support. Maybe there is a way to convert a secondary controller to a primary controller (backup controller, patch backup file, restore backup file)?

1 Like

Although the node IDs are quite different (much lower). But that sounds reasonable.

I will do exactly that. :+1:

I tried “Exclude devices” on the Z-Wave Serial Controller page, and it doesn’t seem to do anything. You get the ominous and presumably misleading dialog “Exclude devices?” and then nothing except “Thing configuration updated” at the bottom, which I’m not sure what it’s referring to.