Z-Wave 2 Binding in OpenHAB 2 - strange behavior of Fibaro Multisensor FGMS001


I’ve been using OpenHAB 1.X for almost 2 years, and, since my HDD with all the configuration died, I’ve made a decision to move to OpenHAB 2. After installation, Paper UI found all my Z-Wave nodes, but Fibaro Multisensor is acting strange. When motion is detected, it changes both sensor_binary and alarm_general to ON. It stays that way until it times out after configured time (30 seconds, if I can recall correctly). Wasn’t alarm_general actually a tamper alarm? If it is, what should I do to make it work properly? Should I delete XML node definition (as it was case with OpenHAB 1.X), to make it initialize again? The other strange thing is, I can’t make motion sensor display state in my sitemap (declared the old way as .sitemap file). I’ve tried with both, Switch and Contact item (with label and [%s] string parameter), copied channel string from Paper UI as binding definition, and declared Text item in sitemap, but it only displays dash, whether a movement was detected or not. I was hoping @chris could help me with this, but anyone’s help is more then welcome.

Thank you in advance,

According to the defined channel types (see http://www.cd-jackson.com/index.php/zwave/zwave-device-database/openhab-2-channel-types), the channel “motion_alarm” is a SWITCH and the binding therefore reports ON/OFF. Keep an eye on the assigned value, as (according to the link above) OFF means alarm. I am discussing this regarding another Fibaro device with chris at the moment. I think this was unintentionally exchanged in the link above.

You should provide a DEBUG zwave log and have a look what the device reports when motion is detected.

Hello Stefan,

I have looked at the link above, but the Paper UI doesn’t report alarm_motion on my FGMS001, only alarm_general and sensor_binary (it does report other sensors too, but they are working properly). But even if it’s expected behavior (OFF as alarm), as far as I understand it, it should not trigger both alarm_general and sensor_binary when motion is detected, because, in OpenHAB 1.X tamper alarm was working and it was triggered only when you move/shake the unit. Thank you for your help.

Best regards,

I too found this sensor to behave in a different way in recent builds of the binding.
In my case, after changing the reporting configuration to Binary sensor CC instead of Basic CC, I found that the motion sensor information is now displayed by the Alarm channel instead of the Binary sensor one, which seems to be now useless…

This is probably following the changes to use the notification class…


regarding Z-Wave log, do I have to run OpenHAB with start_debug.bat or just run it the regular way, and where can I find that log (I’m using Windows installation of the OpenHAB)? Also, does anyone have an idea why sitemap doesn’t show anything if I use Text widget to display motion sensor state (sensor_binary, which is declared as Switch item). I’ve used [%s] to allow it to show string (tried putting it both, in an item definition and in the sitemap), but in the Paper UI state is displayed as ON/OFF, so I suppose it is a switch, rather then Contact item (it doesn’t show anything if I declare it as Contact item either).

Best regards,

As you have used OH1 for two years, I thought you were a little more familiar with logging. :wink:

You have to put the Log Level to DEBUG in the appropriate configuration file of OH2, see the documentation:


I would also advice you to make a separate log file for zwave. Browse the forum here to get the correct settings for this.

Speaking of the documentation: Do you know docs.openhab.org? You should read all what has been written there.

Since I never came in touch with the Windows version, I do knot know where the log file is located. As the installation goes to c:\openhab, maybe it’s a subfolder?

Regarding the sitemap: Does your sitemap shows ANYTHING or just not the motion item? Have you tried the demo package of OH2, just to make sure that your installation is working in general?

Either way, you can post the items and sitemap definition here, then we can have a look.


I’m not very familiar with logging because everything was working on the first try in OH1, so I haven’t had used logs. I’ll make a separate z-wave log and post it.

Regarding sitemap, it does work, it shows dimmer items, and they are working correctly. What I’m trying to do, and where the problem is, is displaying state of a motion sensor (sensor_binary) as text widget, so it would show ON/OFF (or even better, map it, and then display text "Detected/Not detected), but it displays only blank string.

Here are item and sitemap combinations I’ve tried:

Switch Sensors_Multisensor_Lobby_Motion “Detektovan pokret [%s]” {channel=“zwave:device:4a6237e0:node7:sensor_binary”}

Text item=Sensors_Multisensor_Lobby_Motion

Contact Sensors_Multisensor_Lobby_Motion “Detektovan pokret [%s]” {channel=“zwave:device:4a6237e0:node7:sensor_binary”}

Text item=Sensors_Multisensor_Lobby_Motion

Switch Sensors_Multisensor_Lobby_Motion {channel=“zwave:device:4a6237e0:node7:sensor_binary”}

Text item=Sensors_Multisensor_Lobby_Motion label=“Detektovan pokret” icon=“motion”

Contact Sensors_Multisensor_Lobby_Motion {channel=“zwave:device:4a6237e0:node7:sensor_binary”}

Text item=Sensors_Multisensor_Lobby_Motion label=“Detektovan pokret” icon=“motion”

In the Paper UI zwave:device:4a6237e0:node7:sensor_binary shows ON/OFF when the motion is detected/not detected, so I guess sensor_binary is working as expected, just not translating state to text. I know there were a lots of changes in OH2, so I was wondering if this capability (displaying switch/contact as text) has been removed from OH2. Since my HDD with OH1 installation died, I don’t have old configuration files, but in OH1 I had text widget that was displaying state of the motion sensor as mapped string.

Best regards,


Since my Fibaro FGMS001 still reports every motion on both, sensor_binary and alarm_general I was wondering if @chris could help me. I’ve made separate z-wave log, and I’ve triggered motion sensor twice before saving a log. FGMS001 is Node 7. Since I can’t attach a .log file here, I can send it to an e-mail, via private message, or post it to some cloud storage. Isn’t alarm_general meant to fire only when it detects tampering (like moving or shaking sensor)? I’ve tried with OH2 b4 and two nightlies (every time I did a fresh install), but every time it behaves the same. I can’t find any other channel, besides alarm_general, that could be a tamper alarm channel. Hope someone could help me with this.

Thank you in advance.

Dear all,

I am recently becomming familiar with openhab 2 and zwave 2 binding and i am seeing the same issue.
I have a 1st generation motion sensor from fibaro configured and it also fires the tamper and alarm general when detecting motion.
I checked the config of this device but there is nothing i can find to change this.
I tried configuring the sensor binary as switch or as contact but as the things discovered tell me its a switch i tried configuringnas switch.
In the paper ui the switch is not displayed and it does trigger all 3 on motion.
@ chris i think we should maybe look at this as i to never saw this.
What i do see is that the sensor binary is displaying triggered vs untriggered in the paper ui.
When checking habmin i do see switches for the alarm but not in the ui.
Could we please investigate what goes wrong ?
I also have some new gen 5 versions of these so i will try to add and configure one of those to see if there is any difference.

Kindest regards Wolf

Which version of the oh2 binding are you running? Make sure it’s a recent version as notifications have been implemented now.

Dear chris,

i installed Openhab 2.0 this weekend and started right away with 2.0 binding.
So the one it downloaded last sunday is the one i am using so it should be very recent as we are talking days apart.
i installed the binding via text based config.
I assume that Openhab 2.0 always downloads the most recent one ?
I see version 2.1.0 Snapshot when i check the Paper UI.

kindest regards Wolf

ps: I also noticed that the battery item is not correctly displayed when checking habmin.
alltough in the paperui i do see it correctly linked.
as said i work with Text files for configuration.–> this is what i have configured for the motion sensor now.

Switch Z_MotionSensor_Bureau_Motion “Bureau Motion Sensor” (Bureau,gMotionAlarms) { channel=“zwave:device:controller:node2:sensor_binary” }
Switch Z_MotionSensor_Bureau_Tamper “Bureau Motion Sensor Tamper” (Bureau,TamperAlarms) { channel=“zwave:device:controller:node2:alarm_tamper” }
Switch Z_MotionSensor_Bureau_M_Alarm “Bureau Motion Sensor Motion Alarm” (Bureau,gMotionAlarms) { channel=“zwave:device:controller:node2:alarm_motion” }
Number Z_MotionSensor_Bureau_Temp “Bureau Motion Sensor Temp [%.2f °C]” (Bureau,Temperatures) { channel=“zwave:device:controller:node2:sensor_temperature” }
Number Z_MotionSensor_Bureau_Lux “Bureau Motion Sensor Lux[%.0f Lux]” (Bureau) { channel=“zwave:device:controller:node2:sensor_luminance” }
Number Z_MotionSensor_Bureau_Battery “Bureau Motion Sensor Battery [%d %%]” (Bureau,BatteryLevels) { channel=“zwave:device:controller:node2:battery-level” }

Hey chirs,

i did test with my gen5 motions sensors and there all is fine.
The first generation works different and does indeed trigger the tamper when motion is detected.
Do you have any idea on how to fix this ?

kindest regards

Firstly, please check what version of the binding is running - this is important. The best place to check is using the list command in the karat console. If you are running an old binding this could explain the problem and the installation date doesn’t really mean too much.

After this I would need to see a debug log to go any further.


Dear chris,

as requested , i am using | ZWave Binding
As said the sensor is working but it triggers all of them at the same time while my other sensors don’t who are GEN5.
I did not have this in the 1.9 binding on openhab 1.8.3
I believe there is a misconfiguration on the tamper , the rest is fine.

kindest regards

OH1 is totally different so really isn’t relevant. OH2 uses the newer command classes that weren’t supported in OH1.

What version of the device are you using? Can you attach the XML please?

As demanded :wink:
node2.xml (15.9 KB)

kindest regards


This is an older version of the device which is still using the old command classes. Can you post the OH1 item configs please.

as i said this is een older device , one of the first every made as i bought that directly when it came out.

Contact Z_MotionSensor_Bureau_Motion “Bureau Motion Sensor” (Bureau,gMotionAlarms) { zwave=“2:command=SENSOR_BINARY,respond_to_basic=true” }
Contact Z_MotionSensor_Bureau_Tamper “Bureau Motion Sensor Tamper” (Bureau,TamperAlarms) { zwave=“2:command=sensor_alarm,alarm_type=0” }
Number Z_MotionSensor_Bureau_Temp “Bureau Motion Sensor Temp [%.2f °C]” (Bureau,Temperatures) { zwave=“2:command=sensor_multilevel,sensor_type=1” }
Number Z_MotionSensor_Bureau_Lux “Bureau Motion Sensor Lux[%.0f Lux]” (Bureau) { zwave=“2:command=sensor_multilevel,sensor_type=3” }
Number Z_MotionSensor_Bureau_Battery “Bureau Motion Sensor Battery [%d %%]” (Bureau,BatteryLevels) { zwave=“2:command=BATTERY” }

kindest regards


I’ve had the same problem (since I was the one opening this thread :slight_smile: ), but I’ve solved it by removing all association groups from the Fibaro Motion Sensor Thing, and then associating 3. Controller updates only, with OpenHAB Controller. After I did this, tamper alarm is no longer reported when there is a motion detected.

Best regards,