Z-Wave Aeotec USB stick on RPi4 - port question

New install on a RPi4 downloaded from Ubuntu OpenHAB Appliance.

I have the Z-Wave Binding installed.
Under Configuration > Things > Z-Wave Serial Controller it needs a Serial Port.

I’m not sure what to enter and how to find which port it is on the RPi4.

Currently under Things it displays:

Z-Wave Serial Controller OFFLINE - BRIDGE_OFFLINE
Z-Wave Serial Controller


Not sure why you would want that. The official recommended image is openHABian which is based off the much more standard Raspbian / RaspiOS image.

Since it is an Appliance, I assume there is some UI enumerating devices? Yuo would better ask that on that appliance support foum.

Ah ok, I’ll install openHABian then.

I stumbled across the Ubuntu appliance… I have no idea what I’m doing :wink:

This is part of the official documentation. Be sure to read about the openHAB concepts too

Remember:The stick has some issues with the USB Ports of the PI 4, it requires an USB 2 hub between the stick and the PI. Any cheap one will work.

1 Like

Ugh, and I just bought a Pi4 for this.
Mmmmm, maybe I’ll just try it on a Pi3 first, I have 4 running…

I understand they fixed this in the newer Aeotec sticks. The older ones would not work properly in USB3 ports without the hub trick.

Have a look here. If your stick is one of the older ones, the prob is unrelated to whatever operating system. Go get a powered USB Hub. I’d expect the controller not to be shown offline anymore.
If you don’t define a special name/alias for the port, openHAB will find the right one for you normally.

EDIT: To everyone knowing about Aeoctec Gen 5 struggling on a raspi4 port: just do a search for “aeotec v1.” and Alex’s (aka user Celaneo1) post will show up.

1 Like

Thank you everyone, I’m all sorted now.
I installed openHABian on an RPi3 and it picked up the Z stick immediately and I was able to get my lights setup.
I checked the Aeotec website and my new Z stick is an older model, that sucks.
Moving on… learning more about openHAB.

1 Like

If you have a powered USB2 hub you can still use the stick with the Pi4.

Noted, but I have a spare Pi3 which does not require an additional powered USB hub :wink:
Now I can use the Pi4 for something else, just have not decided what yet.

1 Like

You do not need a powered hub. I run the stick non a passive hub with a PI4 without issues.

1 Like

Nobody has mentioned that the RPi 4 has two USB 2.0 ports next to the blue USB 3.0 ports. Might not work for you, but my old stick worked right away as soon as I switched it to the black USB 2.0 ports on the RPi 4.

1 Like

I just modded my older stick with a resistor like this guide and it works great without the extra hub needed Aeotec Z-Stick Gen5 Raspberry Pi4 Mod - olausson.de


Thanks for this! I would have done this, but I already spent the $5 on amazon and got the dumb hub. For what it’s worth, moving the stick to the 2.0 ports only worked breifly.

As I just explained in another thread, the resistor mod is the proper solution that actually fixes the problem: