Z-Wave Binding invert_state=false and invert_percent=true

I installed the one from the PaperUI: ZWave 2.0.0.b3

Ok, then please update to a more recent version if you want this feature.

Can you give me a hint how to do that?

Download the latest runtime off cloudbees - you will need to upgrade the full runtime.

Ok. I downloaded the .deb file (offline bundle) and installed it on my RPi.
Sincerly I do not see any bindings anymore. I guess the log message “Failed installing ‘openhab-package-standard’: No matching features for openhab-package-standard/0.0.0” will be somehow related to this. :frowning:

Take a look in the docs how to install openHAB2 on a RPi:
http://docs.openhab.org/installation/apt.html
If you want to do a manual install, just download the zip file and extract it to the recommended folder.

Everything working great so far. Due to a SDCARD crash I had to reinstall again today. Seems like some components are not recognized anymore?!

Upgraded to the latest nightly with following effect:

2016-08-05 11:06:21.071 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:21.072 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:somfy_zrtsivnode_00_000’. Skip it.
2016-08-05 11:06:21.697 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:barrier_state
2016-08-05 11:06:21.698 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:aeon_zw062_00_000’. Skip it.
2016-08-05 11:06:21.821 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:sensor_velocity
2016-08-05 11:06:21.823 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:zwaveme_zweather_00_000’. Skip it.
2016-08-05 11:06:21.887 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:21.888 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:qubino_zmnhcd_00_000’. Skip it.
2016-08-05 11:06:21.986 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:sensor_dewpoint
2016-08-05 11:06:21.988 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:popp_pope005206_00_000’. Skip it.
2016-08-05 11:06:22.420 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:22.422 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:zwaveme_zme05459_00_000’. Skip it.
2016-08-05 11:06:22.898 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:22.899 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:qubino_zmnhod_00_000’. Skip it.
2016-08-05 11:06:22.981 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:22.983 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:fibaro_fgrm222_00_000’. Skip it.
2016-08-05 11:06:24.126 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:24.131 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:fakro_zws12_00_000’. Skip it.
2016-08-05 11:06:24.274 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot find channel type: zwave:blinds_control
2016-08-05 11:06:24.276 [WARN ] [io.rest.core.thing.ThingTypeResource] - Cannot create DTO for thingType ‘zwave:fibaro_fgr221_00_000’. Skip it.

Result: Rollershutters are not working anymore. :frowning:

I am seeing this too on latest builds. @chris, is there some issue in ESH that needs to be reported or is this a problem in the binding?

I don’t think this is related to the invert function - some of these devices aren’t even associated with ZWave rollershutters…

I do not even own some of the devices listed.
The devices “zwaveme_zme05459” are the ones I am using.

I’m not sure - there’s not a lot to go on with the log, but I’m not aware of anything that would cause this. There haven’t been any updates to the binding for a few days (I think none since we changed to the new repository).

Ok - so this is probably an error during the creation of the thing list. I’ll have to take a look tonight, but maybe there’s a problem with the database since it seems the reasons for not creating the DTO are config descriptions.

I’m also seeing this. Latest build.

@kai - somehow I think we lost some of the database folder when I moved the repositories over. I have a feeling that I probably only copied over the source folder when I moved the repositories, and we ended up with the database from the first version of the zwave repo that you made… I fixed the database files after it was moved, but I missed the channels file, so we’re missing some channel definitions…

I’ve closed this issue -:

After migrating from OH 1.9 to 2.0 Release, I cannot make invert_percent to work. There is a field in Habmin, called “Invert percentage value”, but when I set it to Yes and save, even if I have the confirmation it is saved, everytime I refresh the page it revers back to No. How should I set this parameter? In channel definition? What is the syntax.

This drives me crazy, please help.
[EDIT] OK, found it in PaperUI, there the switch works. Maybe an issue with HABmin.

The following options are available for the blinds_control channel - I guess that’s what you’re using if you see the option in HABmin.

            <parameter name="config_invert_control" type="boolean">
                <label>Invert control</label>
                <description>Invert the blinds control</description>
                <default>false</default>
                <options>
                    <option value="true">Yes</option>
                    <option value="false">No</option>
                </options>
                <limitToOptions>true</limitToOptions>
            </parameter>
            <parameter name="config_invert_percent" type="boolean">
                <label>Invert percentage value</label>
                <description>Invert the blinds percentage value</description>
                <default>false</default>
                <options>
                    <option value="true">Yes</option>
                    <option value="false">No</option>
                </options>
                <limitToOptions>true</limitToOptions>
            </parameter>

Same issue here with 3 new FGRM222 devices:
Invert percentage value reverts always to “No” in HABmin while setting the parameter to “Yes” in PaperUI works …

Hello … i have the same Problem.
I dont know if it helps but when i type LIST in the console it says i have HABMIN:

182 | Active | 80 | 2.1.0.201703251201 | HABmin User Interface

I’m interested in the options for the blinds_control channel, how do I go about configuring them in the items file?

How would I go about modifying the below line so it configures config_invert_control as True?

Rollershutter zwave_device_41d35a9b_node49_blinds_control “Roller controller” (zwave,fibaro) { channel=“zwave:device:41d35a9b:node49:blinds_control” }

Thank you in advance.

You can’t do that in your items file, you have to do that in your things file:

2 Likes