Z-Wave Binding..."Issues" with Aeotec Z-Stick Gen 5 [Z-Wave] #1415

Tags: #<Tag:0x00007fc8fc4fcaf0> #<Tag:0x00007fc8fc4fc938> #<Tag:0x00007fc8fc4fc7a8>

This topic should discuss the GitHub-issue here:

Hi community =),

I’ve maid some tests with the Aeotec Z-Stick Gen5 and discovered some issues. Here are the main problems.

Current Bugs

  1. Issue with the usb-port on raspberrypi (not resolveable as this is problem from the aeotec z-stick -> https://www.raspberrypi.org/forums/viewtopic.php?t=245031
  2. Devices get automatically added on search to the z-wave controller (You don’t need to add as thing, they get automatically added as soon as discovered to the controller, which is not very convenient, especially on the following problem ->
  3. Not able to delete z-wave devices from controller (option set as failed and delete from controller don’t have effect)
  4. Learning mode does not work
  5. Secure inclusion doesn’t work on the first inclusion…you have to reset the device first to make it work on the second try…(tested with Aeotec dimmer/switch which have a dedicated button for secure inclusion)

To summarize: All advanced options don’t seem to work on the aeotec z-stick gen5 with openhab 2.5.7 in docker (privileged) and pi. The controlling works perfect

Steps to Reproduce (for Bugs)

  1. Install openhab in docker on pi with hypriot os and traefik reverse proxy
  2. stick in usb-hub and aeotec z-stick (hub to resolve connection issue, see above)
  3. setup the z-stick as controller
  4. put a z-wave device in inclusion mode
  5. start discovering with the inbox on paper-ui
  6. see the issues

Sadly I have no Idea how to resolve this issues, but I can help testing, as much as possible! If you need logs or something else, I’ll be here =)

For now I get around all issues, by plugging the z-stick to a windows pc, and delete the failed nodes with the silab software…which is very complicated…

Your Environment

Raspberrypi 4 B+
hypriot os 1.12.3
docker: 19.0.3
openhab-docker 2.5.7

The problem is the stick in a USB3 port the workaround is to usea USB2 hub between the USB3 port & the stick.

This is supposed to work but many of us end up using other tools to accomplish this.

Issue 1 is an issue with the Aeotec stick. Nothing in the OS or openHAB can resolve this.

I see devices fine showing up in the Inbox. I use the recommended HABmin to manage Z-Wave but the Paper UI should work too.

@Celaeno1 did some succesfull investigations on topic 1): there is some info in the (newer) aeotec docs.

1 Like

Confirmed working with usb 3.0 hub also :slight_smile:
It seems to be an electrical problem inside the stick…

Yes they show up properly and you can include them BUT:

  1. I had the problem that as soon as you set the device in learning mode, and the OpenHab in search mode, the thing (z-wave-devices) gets added to the sticks z-wave network…you don’t have to approve it…in combination with not being able to remove the device of the stick wothout plugging it off, it’s extremely inconvenient to add new devices -> if you’re to slow, you end with a ‘dead device’ which keeps showing up as ‘discovered’.

All other “advanced” settings regarding z-wave (suc, learning mode, remove device) don’t seem to work with the Z-Stick gen5…maybe someone has a Z-Stick gen5 lying around and can test it too :slight_smile:

The Network Exclude function does not work for many of us so we either endure zombie nod3es ot use another tool.
I think this binding is incredible, especially considering it was made by reverse engineering i look forward to an improved binding based on the standard after SiLabs freely releases it.

Completely agree :slight_smile: I love the z-wave binding! Especially the reaction-times on controlling and rules are amazing!

I use the silab developers pc controller…it works very well :slight_smile:

I just wanted to share my experience about the Z-Stick gen5 to help improve and contribute to the opensource community :-). Maybe someone comes up with a solution :-). If I can be of any help, let me know :slight_smile:

Do you know when that will be? Are there any plans of silabs?

I have not heard much since their rpress announcements last December.

Oh okay thanks :-). Yes I think Corona slowed down everything a bit…

The beer or the virus?

:joy: Nice one! :joy:

This is normal - there is no way to “approve” devices at that stage - the controller will always allow them to join. This is simply the way Zwave works.

I’m not sure I understand this. Too slow at doing what exactly? If the device joins it should work - if you don’t want it then you can exclude it again.

I experienced with Aeotec devices that were set to inclusion mode, that they join to the z-wave network as soon as you click ‘discover’ on the paperui…when meanwhile the device times out (exclusion mode over on aeotec) it seems added to the controller, but can not be provisionised sometimes (which seems strange…maybe this is only an issue with Aeotec which has nothing to do with the binding)

At the moment I was only able to forget a device with silab pc software…mark as failed (when device plugged off) and forget from controller does not work in OpenHab. I’m not deadly sure if I have tried exclusion mode to…

This is correct - it’s nothing to do with Aeotec - this is the way ZWave works. Once the controller is put into learn mode (which happens when you click discover) it will add devices. This is done automatically by the controller - the only thing the binding can control is putting the controller into learn mode.

2 Likes

Ahhhhhh okay I think I get it now! So ‘discover’ means device learning mode in OpenHab okay… Thanks for the explanation :slight_smile:. It was a not clear to me as in other bindings you have to actively add the thing…But this makes sense to me so I also would not consider it as a bug…but I have an Idea…Maybe you can put a banner in between when discovering devices on paperui that you have to click (like when you have to add the controller first) which explains, that you start the learning mode by clicking there…I think that would help a lot of people which are new to OpenHab :slight_smile:. But I totally understand if this is too much effort…I don’t consider it very important…just for usability it’s nice to know :slight_smile:

1 Like

It’s not necessarily too much effort, but there isn’t really any way to do this. The UI is for all bindings - so I can’t add text like this just for ZWave.

This is a pretty common approach though - when you click on discover, the binding tries to discover the devices - this is true of many bindings. Not all bindings support discovery, but this is how it works for those that do.

1 Like

In some bindings you have to define a bridge before using them…if you haven’t done, you will be redirected to some banner that says “include bridge” in paperui…maybe this is a way to go? -> with this option it would also be possible to start secure and non-secure inclusion from paperui…

When you add the z-wave binding, and haven’t defines controller yet, paperui prompts you to do so you know what I mean?

I’ve edited my first post with a point 5. As a possible bug if someone want to take a look at it :slight_smile:

  1. You always need a reset device before secure inclusion
    2, NEVER use buttons on the controller for inclusion, especially secure inclusion. The security key is in the openHAB binding, not the controller.

I meant the buttons on the aeotec dimmer NOT the controller :slight_smile:

Okay so it’s not a bug…

1 Like

Again though, this is not a zwave issue - the UI is for all bindings. If the workflow is not right in the UI, then you an create an issue in the appropriate repo on github.

1 Like