Z-WAVE Binding not working with razberry

Tags: #<Tag:0x00007efed2cb85e0> #<Tag:0x00007efed2cb8450>

Im trying to get my razberry transmitter running for days now and im still unable to solve the problem eighter determine what exactly goes wrong.

Used transmitter => smaller razberry released before razberry2

I did a setup with the z-way image months ago and everything is working fine (SD 4GB) so transmitter and rest of hardware is OK.

A few days ago i wanted to try this awesome openhab project and did setup the image from github on a pi3 (SD 32GB).

I did following steps:
1.) Used Etcher to flash the SD with the Image from GitHub
2.) Put SD inside pi3, connectet to internet and power up, waited for installation to finish
3.) openhabian-config -> serial -> checked all 3 items
4.) Checked files for applied config values as described in some threads (everthing seems to be ok)
5.) Reboot
6.) Installed z-wave binding extension from paper-ui
7.) Added Thing z-wave binding
8.) Entered /dev/ttyAMA0 at the Serial Port field and applied

After that i get this:
Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyAMA0 does not exist

9.) Tried with the second port suggested from config gui and so entered /dev/ttyS0 at the Serial Port field and applied

After that i get this :
Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyS0 does not exist

So i tried to play around with a second pi a pi2 with a fresh openhab github image flashed on another SD.
At openhabian-config serial I checked only the 1st and 3rd item (the 2nd seems to be just for the pi3).

Again tried both ports without success. I think i have flashed and did the setup now 5 times and im realy fustrated now.

Can anybody help. What i can do for better diagnostics or debug informations. I do not know why openhab is unable to talk with this transmitter.

If i mount the 4GB SD with the z-way image. Everything is still working fine. But i want to get openhabian running on the my pi. I would be very grateful for any help on that.

Hi. I have done almost the same setup. but in addition you could try this :
create a file : /etc/udev/rules.d/09-tty.rules

KERNEL=="ttyAMA0", SYMLINK+="ttyUSB20"

doing a ls -la /dev/ttyAMA0 gives me user root, and group uucp.

crw-rw---- 1 root uucp 204, 64 Apr  3 20:51 /dev/ttyAMA0

I have added the group “uucp” to the user “openhab” which I use for running openhab.

In /boot/config.txt add the line :

dtoverlay=pi3-disable-bt

Adding the Zwave thing in paperui/habmin with: /dev/ttyUSB20

Also remove references to ttyAMA0 in /boot/cmdline.txt

Hope any of this may help you !

Br
Torstein

Thx for your suggestions torstein. Awesome to get a reply after a few minutes i opened this thread.

Here we go. I created this rule file, I changed that line in /boot/config.txt from “dtoverlay=pi3-miniuart-bt” to “dtoverlay=pi3-disable-bt”. I aslo checked references in /boot/cmdline.txt but there are not such refs, did a reboot and changed to /dev/ttyUSB20 at paper ui.

But still not working :frowning:

Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyUSB20 does not exist

after a while i got uninitialized. But same as before.

The one and only thing we do not compare is that uucp group thing because i get the following

crw–w---- 1 root tty 204, 64 Apr 3 21:54 /dev/ttyAMA0

After a few minutes more and trial and error more and more szenarios i got it.
I had to remove the folowing from /boot/cmdline.txt console=serial0,115200 as described in another thread.

It seems this is the one and only broken thing why i was not able to get the razberry running. maybe this should be done by openhabian-config -> serial ?!?

On paper ui i still have /dev/ttyAMA0 entered and it is working now :joy:.

Hi

Try adding the group “tty” to the user you re running openhab2 with …
Remember that you need to re-login (or reboot) after giving the user additional groups…

br
Torstein

Thx torstein for your reply. From the github image the user openhab is running openhab2 i think and this user is added to group tty after you execute openhabian-config -> serial. So for my setup this was done already.

You can see the solution above. It was a entry in the boot/cmdline.txt like you suggested before but the serial0 reference.

THX

Great !! :smiley:

Great, thanks for the solution. I had to remove “console=tty1” in the /boot/cmdline.txt file. Made a summary here: How I got the Razberry 2 to work on a Raspberry 3 b+