Z-Wave configuration error with Schwaiger ZHS 14 Outdoor Siren

Hi Z-Wave gurus

I’ve got a Schwaiger ZHS14 Outdoor Siren and would like to use it with Openhab. When I include it in the network, the Z-Wave binding correctly detects it, but has a configuration error.


{config_4_2=The value 15 does not match allowed parameter options. Allowed options are: [ParameterOption [value="0", label="Disable report"]]}

It sound like the configuration parameters in the binding don’t align with what the siren expects. I.e. it gets the value 15 (default for parameter 4) as value for parameter 3.
Here is the list of parameters according to the manual:

Parameter Size Description
1 1 Tamper mode
2 1 Temperature offset
3 1 Temperature report threshold
4 2 Temperature report after N wake-ups
5 1 Alarm mode
6 1 Minutes until auto off

Is there anything I can do in terms of forcing the initialization or changing the config?

Many thanks,

  1. Find your device in the OpenSmartHouse Z-Wave Device Database (there might be more than one Version of your device, so you must take the Version of your device into account).
  2. Check the definitions of the Z-Wave configuration parameters.
  3. Fix the definitions of the the Z-Wave configuration parameters and/or the Version.
  4. Request a review of your changes.
  5. Wait for new snapshot.
  6. Install snapshot.

Details: Blog Posts

Thanks for your help. It looks indeed as if the parameters in the database is incorrect. The associated pdf manual is the same as I have, but the database doesn’t match them.

Building on the above directions,

  1. use the device Type:ID (i.e 0004:0002) ? found under the thing properties to search the DB. Then use the mfg (0154) ? (those numbers are my guesses as to this device, but could be wrong)
  2. The problem you have was introduced in the core between OH3.2 and OH3.3 (rigorous checking) and caused the DB to need updating. What has to happen is the “limit to options” flag on the parameter tab needs to be set to false (from true). If you do not have DB access I can make that change for you, if I know the exact device.
  3. As to steps 5 & 6 – What version of OH are you on? The updated binding only work on OH4, unless another patch release of 3.4 is issued. The other option is to modify your jar with the updated XML
  1. Yes, device is 0004:0002, here are the entry from my discovered things:
  • versionMax 1.4
  • modelId 005107
  • zwave_listening false
  • zwave_version 1.1
  • manufacturerId 0154
  • manufacturerRef 0004:0002
  • dbReference 367
  • zwave_deviceid 2
  • versionMin 1.1
  • vendor Popp & Co
  1. That sounds like the issue. Also, parameter 6 is missing from the db.

  2. I’m currently on the latest OH3 version (3.3.0 release build). I haven’t yet upgraded to OH4. Can I extract the xml file from the 4.1-SNAPSHOT and inject it into the corresponding jar in 3.3.0? What jar would that be?

That should be possible. Also after you edit the device and request review you can download “OH2 XML” from the gear box thingy and use that.

As to locations, if you are on an UI installed binding the jar check out these posts on a similar situation. MCO Home IR Thermostat IR2900 Unknown Device - Off-Topic - openHAB Community

Thanks for your help. I’ll try that as soon as I have edit permission to the db.

btw: do I have to exclude and re-include the device after the new jar version, or will OH automatically retry to configure the device based on the latest xml definitions?

btw: do I have to exclude and re-include the device after the new jar version, or will OH automatically retry to configure the device based on the latest xml definitions?

You will have to delete the thing and scan for it again. Do not exclude. Not needed.

Thanks for your help. All changed and the siren is working fine now.