Z-Wave DB - Honeywell / Jasco ZW4103 Unknown Device

My System: Raspberry Pi 3, Rasbian, OpenHAB 2.5.11, Z-Stick Gen 5, JRE: OpenJDK 1.8.0_152

I just tried to setup a Honeywell / Jasco ZW4103 and it is coming up as an unknown device. Searching I found the following post that seems to suggest this is in the DB.

The link in the post points to the old DB website. When I search the DB I don’t find anything. I took the ID out of the old URL and putting it on the end of the new website URL which seemed to get the page being discussed (link below). This seems to be the GE version of this plug. (maybe this is the wrong DB page)


Question is should I create a new entry in the DB or is there a better way of making this entry?

Attached is the xml file

network_ef848ee0__node_62.xml (10.1 KB)


Neither one, your device is already in the database:


Also the github page looks okay to me:

Make sure you only have one zwave binding installed (karaf), if you can’t solve this create a debug log and feed it through the zwave log viewer.

1 Like

Thanks sihui for the response -

Looks like one binding is installed

openhab> list | grep ZWave
241 │ Active │ 80 │ 2.5.11 │ openHAB Add-ons :: Bundles :: ZWave Binding

Based on

My understanding is that Manufacture ID was used to match the Z-Wave device. Maybe I am reading it wrong but the Honeywell ID is 0x39 and the DB has 0063 for the entry you posted. Even if this is a hexadecimal to decimal conversion they don’t match 0x39 => 57.

Seems that you are suggesting that the xml fields <deviceId> and <deviceType> need to be in the DB field Type. As well as <applicationVersion> maps to the DB field Firmware version. These are in sync DB and xml File.

I excluded and reincluded the device with ALL on in the logs. The log has the following entry

2020-12-18 19:08:26.451 [TRACE] [nhab.binding.zwave.discovery.ZWaveDiscoveryService] - NODE 63: Checking zwave:ge_28169_05_000
2020-12-18 19:08:26.451 [TRACE] [nhab.binding.zwave.discovery.ZWaveDiscoveryService] - NODE 63: Checking zwave:ge_28169_05_000

2020-12-18 19:08:26.852 [WARN ] [nhab.binding.zwave.discovery.ZWaveDiscoveryService] - NODE 63: Device discovery could not resolve to a thingType! 0039:5052:3038::5.25

Here is the Zwave Log view filtered on Node 63.

I just looked and it is indeed not in the database. Here is the Z-Wave Alliance page for that item.


If you wish to do that here is the guide. Otherwise one of us should be able to do that. If you make an account there, be sure to submit a ticket to get database edit access.

Thanks Bruce -

I have an account already but haven’t made an entry yet. Just tried to created one with the following

Label: ZW4103
Description: Z-Wave Plug-in Smart Switch
XML: pasted in the XML in the node xml file in the first post

When submitting I get a dialog in the upper right corner of the page with “Error”. No further explanation provided on what the error might be. Thoughts?

I have seen that error too but it creates the entry. The website still has some “gremlins” to be worked out.

The entry was created and is here.

Thanks Bruce and Sihui -

Solution was to create a new DB entry

Good to know about the creation of DB entries even if it throws an Error. Once clicking your link I saw the validation error on the Manufacturing in the Label -> I guessed that might have been the issue and retried with just the device name -> potentially it was already created and errored out for that reason the second time.

DB entry updated, xml exported, and installed on my OpenHAB instance. Everything Works. I’ve submitted it for review in the DB.

You are right. One should never give support in this forum when in a rush, sorry.

1 Like

Unfortunately I do that all to often too. Age gives both wisdom & impatience :frowning:

1 Like

I am having the same unknown device issue with my ZW4103. I am running OH 2.5.11 release build. The device is not listed under supported things in the z-wave binding. I see the database entry on OpenSmartHouse and that it has an approval date followed by an OH-3.0.0 tag. Does this mean I need to upgrade to OH3 to pick up the supported thing or can I somehow upgrade the binding?


The easiest way would be to manually install a snapshot version of the binding. This script should make it easier. The manual instructions are in the README file.
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Thanks, I’ll give it a go.

1 Like