Z-wave device Error after update openhabian to Version 2.5.4_01

Tags: #<Tag:0x00007f6173963d50> #<Tag:0x00007f6173963b48>

Hi all,

after update via “openhabian-config” ( 03 - Install or upgrade to the latest stable release of openHAB 2 )
i get the following error:

2020-04-23 15:00:32.968 [ERROR] [ng.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000
java.lang.IllegalArgumentException: ID segment ’ switch_dimmer’ contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.
at org.eclipse.smarthome.core.common.AbstractUID.validateSegment(AbstractUID.java:97) ~[bundleFile:?]
at org.eclipse.smarthome.core.common.AbstractUID.(AbstractUID.java:75) ~[bundleFile:?]
at org.eclipse.smarthome.core.common.AbstractUID.(AbstractUID.java:49) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.UID.(UID.java:48) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.type.ChannelTypeUID.(ChannelTypeUID.java:40) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.xml.internal.ChannelXmlResult.toChannelDefinition(ChannelXmlResult.java:135) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toChannelDefinitions(ThingTypeXmlResult.java:98) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.getBuilder(ThingTypeXmlResult.java:148) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toThingType(ThingTypeXmlResult.java:156) ~[bundleFile:?]
at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlProvider.addingFinished(ThingTypeXmlProvider.java:148) [bundleFile:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.addingFinished(XmlDocumentBundleTracker.java:265) [bundleFile:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.parseDocuments(XmlDocumentBundleTracker.java:424) [bundleFile:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.processBundle(XmlDocumentBundleTracker.java:398) [bundleFile:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.access$6(XmlDocumentBundleTracker.java:393) [bundleFile:?]
at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker$2.run(XmlDocumentBundleTracker.java:363) [bundleFile:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_222]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_222]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_222]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:1.8.0_222]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_222]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_222]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]

The only zwave device from aeotec that i use is the Z-Stick Gen5.

I restart three - four times - no change in the behavior.
Even i clear the cache, clear the tmp no impact to the error

Can anyone help me getting out of this error or expalin what it mean?

Thanks
Stef

  • Platform information:

    • Hardware: CPUArchitecture/RAM/storage Tinkerboard
    • OS: what OS is used and which version TinkerOs
    • Java Runtime Environment: which java platform is used and what version
      openjdk version “1.8.0_222”
      OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
      OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

    openHAB version: 2.5.4_1

Please complete the initial request, Since you mentioned update from what version?

sorry i send it a edit in the meantime you post that i fill out…

sorry for the delay and my first “send”

Cheers S

1 Like

code fences please. & FROM what version of openHAB?

How to use code fences - Tutorials & Examples - openHAB Community

1 Like

possible solution:

… corrected that entry in Chris’ ZWave device database

I see that entry was last updated this morning. That likely means we need to wait for the next database export. It usually occurs weekly unless @chris chooses to do it more often.

You would then need to manually install a snapshot binding after the build process picks up the changes.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Yes, but that was a different change. The original problem should be solved with updating to a current snapshot zwave binding.

1 Like

hi all,
first of all thank you for the amount of post.
please let me please repeate my first question: what kind of device is aeon zw141???
remember the only device i have is the z-wave usb-stick from aeon…
so what is hapoend that there is a switch and some colour settings are wrong.
please correct me if i’m wrong but i thing there goes more wwromg than a not updated datebase for z-wave devices because in an old database a z-wave usb-stick hasen’t a switch colour or anything else regardibg this
cheers
stef

I’m also seeing this upon upgrade to 2.54 - it’s totally broken my entire zwave environment.

Very unlikely. Symptoms may be similar but likely different root causes. Please start a new thread to avoid adding confusion to this one.

Instad of opening new and an other new and again a new (and so on) topic everything regarding one error should underneath on top - so the story goes and get one, because
(by the way…
Cheers
Stef

Here you can find all the information about the device.

Please use a recent version from the past week as this issue was fixed a week or so back. The database exporter was updated to remove any whitespace that someone inadvertently added, so if this happens again, it shouldn’t manifest as an error in the binding.

Agreed - so long as that is really the case :wink:

Thank you for pointing my to the database by Jackson: https://www.cd-jackson.com/inde
Now I´m totaly confused seeing in the database:


that zw141 is a shutter…
Remember I allready pointed out that the only aoen-device I ever had and have is the aeon-z-stick
So can anybody give me an explanaition why my openhabsystem try to contact a ZW141???
Regards and thanks
Stef

It isn’t is it? Why do you think it’s trying to contact this device? (sorry - now I’m confused). The only error you’ve reported (I think) is to do with the binding loading?

1 Like

Hi,
did i understand your answer correct, that the reported error is a error of loading the binding during start?
And it doesn´t have an impact to the running system.
If my summary is correct now I understand - Thank you for teaching me :slight_smile:
Regards
Stef

Yes, from the log it seems thatthe error is thrown during the startup of the binding. If the binding doesn’t start, then it won’t work well :wink:

1 Like

Hi all,
I have the same problem described by Stefan.
I have about 30 zwave devices (I don’t have ZW141).
If I remove Zwave binding openHab start correctly but when I add Zwave I got the error:

2020-04-29 21:43:16.833 [ERROR] [ng.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000
java.lang.IllegalArgumentException: ID segment ’ switch_dimmer’ contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.

I’m sorry but I don’t understand how I cam fix this problem ?

Thanks

The issue has been fixed in the latest zwave snapshot release, discussed here. Basically just uninstall zwave binding, restart OH and download snapshot to addons folder.

Maybe disussed - but not
solved in my eyes!!

      Attaching a USB device via a

Hub … no words!