Z-wave: new device devolo MT:2656

Hello
I would like to integrate a metering plug with the z-wave binding.
The manufacturer of the plug is devolo and the model# on the housing is MT:2656.
See also here: https://www.devolo.ch/article/devolo-home-control-schalt-und-messsteckdose/

From the functionality the device should be similar to the existing metering plug with the name MT02646 in the database.

Now where do I see the manufacturer ID and device ID from the decie in OH to add the plug in the database?

Maybe you can help me?
Thank you.
Kind regards
Sebastian

Look at the top of the XML file created for the device in /userdata/zwave (location with depend on installation type).

  <deviceId>0x334</deviceId>
  <deviceType>0x602</deviceType>

image

Hello, there is no xml file in the folder \openHAB-share\openhab2-userdata\zwave.
Do I have to create the file for the device in HABmin? Or how does it work?

The file will be create when the device initializes. It will need to be included first. Are you sure you have the right directory (are there other XMLs in there)?

I think it is the right folder location, but it is empty.
I have a openhabian v2.3.0 installation runnning.

Just did a new initialisation:

2018-07-21 20:18:15.440 [hingStatusInfoChangedEvent] - 'zwave:device:0f6c30d7:node6' changed from UNINITIALIZED to INITIALIZING
2018-07-21 20:18:15.444 [hingStatusInfoChangedEvent] - 'zwave:device:0f6c30d7:node6' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
2018-07-21 20:18:15.447 [hingStatusInfoChangedEvent] - 'zwave:device:0f6c30d7:node6' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
2018-07-21 20:18:15.456 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:0f6c30d7:node6' has been updated.
2018-07-21 20:18:15.482 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:0f6c30d7:node6' has been updated.
==> /var/log/openhab2/openhab.log <==
2018-07-21 20:18:17.366 [WARN ] [ve.internal.protocol.ZWaveController] - TODO: Implement processing of Request Message = -- (0xA8)

Any idea? Thank you.

If you have other zwave devices, you must not be in the right directory. For an apt-get (like openHABian is), it would be /var/lib/openhab2/zwave. It’s a mains powered device, so initialization should be quick (slower for a battery powered device). I expect the file to be there, you just need to find it! :wink:

I’m not familiar with openHABian, but that share sure looks like it would be the right place.

No, I don’t have other z-wave devices. It is my first try wiht this binding.
It looks like this:
grafik

I think it looks good. Is there any other way to read out the manufacturer ID and device ID of new devices?`
Thank you.

You’ll want the XML to upload to the database, so type/id is only a piece of it. Is your device different than this one?

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1

Once your device initializes, it may be recognized. It looks like you’re in the right directory. I take it the zwave directory is empty? Is the file browser your using hiding certain file types? But that’s assuming the device is initialized. You did include it, right? What does the device look like in Habmin? If it is not initialized, I’d suggest turning on debug for the zwave binding (log:set DEBUG org.openhab.binding.zwave) in Karaf, restart OH, and see if the log has anything helpful in it. Just remember to set it to INFO when you’re done.

I think the device is the same, exept a swiss plug. Not Schuko.
The folder is still empty, also no hidden file.

Turned on the debug logging now. Looks good but there are some errors which I don’t know where they come from:

2018-07-21 22:08:38.093 [DEBUG] [ocol.ZWaveController$ZWaveSendThread] - NODE 255: Response processed after 31ms/4611ms.
2018-07-21 22:08:39.501 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/plain, type=class java.util.Collections$EmptySet, genericType=class java.util.Collections$EmptySet.
2018-07-21 22:08:40.382 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/plain, type=class java.util.Collections$UnmodifiableCollection, genericType=class java.util.Collections$UnmodifiableCollection.

I saw some other have similar problems Error entry by HABMIN: MessageBodyWriter not found for media type=text/plain

But what is the solution? I aready reinstalled the binding.

You’re issue right now appears to be that the device is not initializing. Once initialized, you’ll have an xml file. If the device is identified, you’re all set. If not, it may be as simple as adding the type/id to the existing device. The logs will be the only way to determine why it is not initializing. You can view the log better with the log viewer, but if you post it somewhere I’ll take a look.

That error shouldn’t affect anything. It’s already been resolved in a snapshot build.

Is the initialisation done by descovery or do I need to save the node tho complete the initailisation?

There are so many nodes discovered and I don’t know why.
But for example node 9 should be ok I think?
Log see here:


Thank you for your help.

I’ve not looked at the log in any detail, but node 9 is not initialising as the device is not responding to the manufacturer data request -:

image

The binding keeps requesting this data, but it never gets the information. The device is receiving the request from the binding as there is an ACK, but it’s not sending the data that is needed.

edit: other nodes look to be doing the same thing - at least nodes 10, 11 and 12. This is pretty strange - are all these nodes exactly the same? It could be that the controller is faulty (not receiving properly) - it does seem a little unlikely, but no more so than every device not responding to a fundamental request like this.

No problem… hopefully we’ll get somewhere! :slight_smile:

Initialization is done during inclusion, but there is a partial initialization that is done when the binding (or OH) restarts.

Are you resetting the device and then including it again? This will leave nodes in the controller, that you can remove through Habmin> Configuration> Things> select Thing> Tools> Advanced> Remove device from the controller

You may need to set it as failed first though.

image

Do you only have the one device? There are 12 node IDs, so it looks like you have included it 11 times. I looks like a node is working it’s way through initialization, a new discovery is started, and a new node pops up. Try cleaning up the old nodes, then shut down OH, delete the openhab.log file, power cycle the device, power cycle the Pi, and then restart OH. Don’t do anything… just wait about 10 minutes. Then send another log. I doubt it will have much more info, but it should be a lot easier to read through. And restarting the Pi should power cycle the controller, which could help.

Hello, sorry for the delayed answer.
I did a reset of the controller Sigma Designs - Controller USB Z-Wave Plus with the zipgateway and raspberry pi.
Also the devices (3 in sum) seems to work with the controller and the zipgateway software.
But I would not say that the controller is for sure 100 % OK. I can be an issue.

So I did the test with the new boot and added the log.
The controller is connected directly over the USB and the local interface of the raspberry.
Maybe you see what is wrong, or what should I try next?

Thank you? BR
Sebastian

Using the zipgateway is likely the source of the issue that @chris pointed out. Is it possible to connect the controller directly to the device running OH? Even just to test? If not, you may want to test one of the other serial over IP solutions to see if they cause the same problem.

Yes, the controller is directly connected to the raspberry running OH. I don’t know any other way to it is done.

I think the problem is the controller or the openhabian installation/user access rights.

Because:

  1. after installing the binding there is no configruation file under:

services/zwave.cfg.

like it is described in the Binding Configuraiton

  1. the controller is shown as a ‘modem’ (dev/ttyACM see also:
    Thing Configuration) as it is described in the port Descrition.

I tried to fix this using the “Fix Permissions” option in the openHABian Configuration tool. But there are no errors and it says that ‘openhabian’ is already member of “dialout”. I also tried to fix it with the command described here: Help needed: Access to USB Z-wave stick and openhab on system startup

Can I use the zipgateway installation as an ‘controller’? How can I configure the the IP adress in the binding configuration? I did not find any informarmation about this.

No - the binding will not work in this way. It needs to directly communicate with the stick.

I’m confused then. I thought zipgateway provided serial over IP for your stick. What is it?

2.x bindings do not create these. Just 1.x do.

I’m pretty sure my old Aeon zstick used ttyACM0.

ZIP Gateway is a Sigma IP to ZWave implementation that handles all the low level communication with the stick. It doesn’t handle anything to do with higher level device communication, but it sorts out network management, encapsulation etc.

1 Like

I installed an other instance of openHAB running on my windows PC. The Z-wave stick is shown as a ‘serial USB device’ with COM-Port Number.
So I did the same and added the new device (node).
But the result is still the same: The device is shown as an ‘unkown device’. Also there is no file written unter:

\openhab\userdata\zwave

So the question is again: How do I get the needed information to add the ‘new’ Z-Wave device to the database?
Thank you.