Z-wave secure inclusion... from the binding?

The z-wave docs, here say:

Secure inclusion must be started from the binding.

But I can’t figure out exactly how that is done. In Habmin, I see the “Installed Bindings” and clicking on this shows me the binding details with no options for any sort of inclusion, secure or otherwise.

The Z-wave controller likewise has no options for inclusion.
This is all related to securely including my 914TRL Touchpad Electronic Deadbolt.
Assorted technical specifications:

openhab> bundle:list|grep -i zwave                                                                                                                                       
237 │ Active   │  80 │ 2.4.0                  │ ZWave Binding

Running openhabian on a raspberry pi 3:

[08:58:46] openhabian@openHABianPi:/usr/share/openhab2/addons$ lsb_release -a
No LSB modules are available.
Distributor ID:	Raspbian
Description:	Raspbian GNU/Linux 9.8 (stretch)
Release:	9.8
Codename:	stretch

I have looked over the various z-wave posts about security, such as this and this, but I think since I am running 2.4, I have the necessary version of the binding. Especially since the docs state that secure inclusion is included.

This is my current Thing that is not securely included:

I would be happy to submit a PR for the docs but I’m not sure how to do it myself :frowning:

In HABmin on the Things tab click on the plus sign with the circle and choose “Zwave Binding”, this starts the inclusion process through the binding:


It is the exactly the same as every other binding :slight_smile: .

In HABmin, it’s as @sihui said. In PaperUI, there is the inbox, and you can search for new devices from there.

Well, it’s exactly the same as every other binding for secure devices. For normal devices, you have to do the inclusion by bringing the stick to the device, setting the stick and the device into inclusion mode and then inserting the stick back into the OpenHab server. Right?

But now I have a problem. I deleted the deadbolt Thing from Habmin, then pulled the stick out and walked it over to the deadbolt and put them into exclusion mode, and everything blinked ok (I think). But when I insert the stick back into the OpenHab server and hit the plus sign with the circle, the deadbolt shows up as a thing again.
Am I going to have to factory reset the stick or the deadbolt?

Just to confirm, the steps to securely include a brand new device right out of the box:

  1. Put the device into inclusion mode
  2. Open the Habmin UI and hit the plus sign with the circle.
  3. Profit?

I should not take the stick out, put it into inclusion mode, put the device into inclusion mode and then put the stick back in. Right?

Thanks again to the both of you for your quick replies. I’ve almost got all this set up.

So a plain delete from openhab will just delete the local thing but it will still be associated with the stick, and hence get picked up again in the inbox. In order to remove it from the controller, you need to choose advanced settings > remove device from controller, then delete from openhab. You might need to hard reset the device to get it back to inclusion mode.

From the devices I have, to secure include, you push the action button twice instead of once during inclusion, best to check your device docs.

I never remove my stick from my openhab server, always add via discovery.

For secure devices you have to include the device through the binding, for non secure devices you may remove the stick and start the inclusion process through the stick.
Please note there are zwave sticks without any buttons and batteries to even be able to start an inclusion process while removed from the server.

Yes. Secure devices need to be factory resetted after an unsuccessful inclusion process.

Please add: device must be close to the controller during inclusion. The inclusion process must be finished in the first 15 seconds after inclusion process has started. You don’t have much time to push the buttons.

Most sticks don’t allow this - I only know of one stick that has a battery - so for 90% or more, you MUST do this through the UI.

Most sticks don’t allow this - I only know of one stick that has a battery - so for 90% or more, you MUST do this through the UI.

My ZOOZ stick doesn’t have any buttons. My solution was to plug my RPi into a USB battery pack so that it was temporarily portable and could be held next to the lock for inclusion.

If at all possible, you are better off doing the inclusion with everything in its normal place. Sometimes this isn’t possible, I know, but if you can do this it will likely work better. Locks should not require the stick to be close to the lock during inclusion - this was recommended a long time ago, so old devices might still require this, but it has not been recommended by ZWA to use low power inclusion for a long time.

Ah, that’s good to know. I read at least a couple of posts suggesting it was necessary to be right up close to the Schlage Connect and to change the batteries. I did both at the same time after my first failed attempts, so perhaps it was only the fresh batteries that mattered. My lock is about four years old though, so it might have needed both.

This can a difficult issue to conclude on. Secure inclusion can be troublesome - a lot of stuff needs to happen in a short time (about 15 seconds) or it will fail and there are a lot of things that can influence this (eg other activity on the network). I know people often try different things to get this working, and IMHO it’s easy to incorrectly draw a conclusion as to what made it work.

Maybe 4 years is old enough to require this though - I’ve not checked back to find when this changed.

1 Like

@sihui and @chris, many thanks for getting me in the right direction. Since I only have 6 z-wave devices plus the controller, I decided to just take the nuclear option and factory reset all of them. Once I did that, this is what I did:

  1. Hook my raspberry pi 3 running openhabian up to a nice battery pack and take it for a walk around the house. I kept the controller plugged into the USB this entire time.
  2. As I encountered each device, I set them in inclusion mode, then hit the + button in the PaperUI inbox and selected the Z-Wave Binding. Generally the new device would show up pretty quickly. The door sensor and smart plug were nice and quick.

The door locks and the Home Energy Monitor showed up as unknown devices for a few seconds, but after that they updated to show the full device information. I had a little trouble with one of the door locks showing as unable to communicate after the inclusion process, but I moved a z-wave plug and gave it a better line of sight and I have greens for all the devices.

I think I got really thrown off because the instructions for all the devices say to unplug the controller and bring it close to the device. I didn’t realize that the + button in PaperUI would trigger the inclusion process.

Anyway, thanks for your help!

1 Like

Were you able to get secure inclusions on all your Z-Wave Plus devices? Both the door sensor and the smart plug?

Yep. I think the key is really to keep the controller plugged into the host during the inclusion process. This is critical for the security devices. It was fine to unplug it for the contact sensor and switch, but it seems the controller needs to be plugged in during inclusion for the secure devices.

Yes, it will NEVER work if you don’t do this. This is completely, 100% mandatory for secure inclusion.