Z-wave stick bridge offline

I am running openhabian 2.4.0-1 on my Raspberry Pi 3 B+.
When I add the Aeotec z-stick gen5 to my things it won’t connect.
I have a fresh install of openhabian, this is my first attempt at adding something.

This is what I get in the log viewer:

2019-03-13 21:06:49.432 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyAMA0'
2019-03-13 21:06:49.441 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2019-03-13 21:06:49.445 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2019-03-13 21:06:49.448 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

What have I already tried?

  • Added EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0" to /etc/default/openhab2

  • Run openhabian-config, go to 30 System Settings, 35 Serial Port, make sure that option 3 “Add common serial ports to openHAB JVM” is checked. Then go to 10 “Apply the latest improvements to the basic openHABian setup” and 14 “Fix Permissions” .

  • [21:14:49] openhabian@openHABianPi:~$ sudo chmod 777 /dev/ttyAMA0

1 Like

You need to set the correct port in the things config.

I have set /dev/ttyAMA0 as the serial port.
Or could it be an other port? There is no dropdown menu, this is what I found from other people that run the zwave stick on openhabian.

You need to find your port via

dmesg -T | grep tty

That command returns:

openhabian@openHABianPi:~$ dmesg -T | grep tty
Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  dwc_otg.lpm_enable=0 console ttyS0,115200 console=tty1 root=/dev/sda1 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
console [tty1] enabled
3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
cdc_acm 1-1.2:1.0: ttyACM0: USB ACM device

Seems like it is the correct port ttyAMA0? What else could be the problem?

Nope: your zwave stick is on ttyACM0

Did you get this sorted? I am running openhabian and this is my dmesg output:

[16:22:16] openhabian@openHABianPi:~$ 
[16:22:16] openhabian@openHABianPi:~$ dmesg -T | grep tty
[Sat Mar 30 16:05:41 2019] Kernel command line: bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x1fa00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=PARTUUID=567cab14-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[Sat Mar 30 16:05:41 2019] console [tty1] enabled
[Sat Mar 30 16:05:41 2019] 20201000.serial: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2
[Sat Mar 30 16:05:42 2019] console [ttyAMA0] enabled
[Sat Mar 30 16:05:53 2019] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
[16:22:18] openhabian@openHABianPi:~$ 

But in Paper UI, in the " ZWave Plus USB Dongle" thing, I only have /dev/ttyS0 available for the serial port. I’m not sure if it matters, but I have these:

[16:24:42] openhabian@openHABianPi:~$ ll /dev/ttyA*
crw-rw---- 1 root dialout 166,  0 Mar 30 16:24 /dev/ttyACM0
crw--w---- 1 root tty     204, 64 Mar 30 16:06 /dev/ttyAMA0
[16:24:51] openhabian@openHABianPi:~$ 

And I verified the openhabian user is in the dialout group.

Much to read, much to try:

It did work for me after a full restart.
It was a pain to get it working, but now everything works smoothly. Didn’t run into any problems since then. Very stable and no issues!

Hi all,

My Gen5 stick is just not going online on my fresh Openhab installation on a RPi 4.

In openhabian-config when I try enable the serial port I see the follwing:

2020-07-04_10:50:25_SAST [openHABian] Updating Linux package information …
2020-07-04_10:50:25_SAST [openHABian] Configuring serial console for serial port peripherals… ATTENTION: This function is not yet implemented.
Removing ‘dtoverlay=miniuart-bt’ from /boot/config.txt
OK (Reboot needed)

I’ve done a hard reset onthe device, rebooted several times etc but nothing. It worked on my previous setup. Any ideas?

Make sure you have an active usb hub.

Hi Sihui,

Thank you for the prompt reply.

In openhabian-config there is an option to enable the serial ports which after doing generates that message.

Do you mean that I would need a separate powered USB hub? Sorry I’m just not really up to speed with the Pi4 yet.

There are several reports an active powered usb hub is required for an RPi4.

Yes, this is indeed the case, I had to get one of these to make it to work with my RPi4.
Belkin USB powered hub
From what I came to learn is that the Aeotec controller is not as compliant with USB standards as it should be and draws more power than it should at startup. The RPi4 doesn’t like this and disables the controller A powered hub alleviates the problem.

1 Like

If you buy the new version of z-stick, it would be interesting to know if it works without a hub as Aeotec says.