Z-wave stopped? z-stick issues?

I’m gradually going from bad to worse following my recent upgrade to 2.5…

Now I have no z-wave control. The Aeotec z-stick on my Pi seems to alternate colors incredibly slowly, it actually looks like it’s a solid color but they do change. Either way, its not working…

Log attached for today. Done a few power cycles and tried to turn some lights on and off but nothing happens.

Any recommendations? What am I doing wrong here? Anyone seen similar behaviour?

openhab.log (136.0 KB)

I know not all of your issues are z-wave. One piece of troubleshooting advice from years ago is to fix the first errors,
The first errors point to problems in 2 of your rules files.I do not think it is too likely those errors are causing your other problems but we do know they have problems.

I know Bruce, I used to code for a living… But 20 years in the marketing team does that to you… I’m slowly getting rid of the errors. Honest.

So. The super slow LED cycling on the z-stick seems to be reflected in the z-wave transmission. I’m seeing lights eventually turn off after long gaps.

When I restart the Pi the LED cycles fine for a while then freezes and goes slow.

Perhaps the zwave log viewer can help you isolate what is happening.


I had some issues this weekend as well.
At some point I decided to stop OpenHAB, and used zensys tools to try and send some basic ON and OFFs. That didn’t work either.
So that basically ruled out OpenHAB as the cause or origin of the issue.

In the end I unplugged the USB stick, and put it back in, and then everything started to work as it should again.

Not sure if the same applies to you, but in principle the functioning of the Z-wave USB stick is probably not affected directly by OpenHAB.

Zensys tools are new to me… I do have a few dead nodes so may try getting rid of those. I have tried unplugging, cycling power etc. I’ll try a few more things tomorrow.

Thanks for the ideas folks. Appreciate your help.

Still trying to work this out… absolutely no joy the events are showing up correctly in the event log but there is no z-wave transmissions… looking at the debug logs does not help that much - it just reports whole stream of message retries.

openhab.log (457.4 KB)

When I reboot the Pi the z-stick cycles power fine until it reports the UIs have loaded and I can click on Paper etc. at which point the z-stick stops changing colors and stops.

Also, looking at HABmin all the z-wave things are shown as “Node initialisinig”.

Hmmm… home automation is not too popular in this household this Christmas…

Still having issues. It’s amazing how dependent we have become on OpenHAB over the last 3 years. Having something fail over Christmas has been a bit of an eye opener…

So today OpenHAB appears to be semi-working, although some things appear to be offline (need investigating) or poorly connected… Any thoughts why I have a whole load of red links now.

Also, any thoughts why I was getting the log entries above?

I’m now back to excessive power measurement updates… settings look fine, so still trying to work that out.

After a week of things appearing to work the z-stick looks like it’s frozen again, colours don’t cycle, or they cycle so slow they appear to be stuck. OpenHAB mobile app turns reports that things turn on and off, and logs seem to show that… but none of the lights actually do anything, so it does appear to be something with the z-stick or network.

Last hour of log is attached if there is anything obvious. Any pointers appreciated as always.

openhab.log (815.3 KB)

I had what seems like a similar issue… my symptoms were:

  • Z-Wave devices sporadically work
  • Z-Wave devices are in PING/REQUEST_NIF for hours after restarting the binding
  • Z-Stick G5 color stops changing and stick stops responding
  • Z-Stick seems to start working after some period of time and nodes work for a bit until the stick “freezes” again

Environment: Windows Server 2016, Aeon Z-Stick G5, about 60 z-wave nodes

I removed the binding, all the things, node files, etc… multiple times and re-added but with no success. The z-wave network stopped working after some amount of time.

I downloaded Zensys tools and went through each node. I found 1 node that, when anything was done with it, would “freeze” the z-stick. This was a node that was previously excluded but still showed up on the z-stick. Anytime I tried to remove the node or send a NOP, the stick would completely stop responding and stop changing colors. Zensys was able to successfully control all the other nodes though with basic command sets.

I was not able to remove this node via Zensys or by doing an exclude again at the node, etc…

I backed up the z-stick and restored to a new one and the same thing happened, so it seemed like something was wrong with the config on the stick.

I ended up completely resetting the new stick and excluding/including all my nodes again, then deleting/re-adding all the things and re-mapping the items. This finally fixed it.

The “corrupted” node was excluded months ago and OH seemed to be functioning fine. Issues didn’t start until I upgraded to the 2.5 release. Not sure about causation, but there is correlation. Restoring OH to 2.4 ended up still having the same issues though.

Lesson learned: Make regular backups of the z-stick. This was outside of the scope of my backup strategy… that will be changing.

I definitely lost some WAF points with this outage, especially with it being over our vacation time (at home), but she did see how much we have come to depend on the automation.

Zombie nodes can cause issues on any Z-Wave network when devices try to route through the non-existent node.
You can usually mark the node as failed and delete it with Zensys tools though. I think you need to mark it as failed before you can delete it though.

I messed around for at least an hour with different combinations of mark as failed, etc… with no success. I was able to successfully mark another node as failed and remove it, but not this particular one. Stick would freeze anytime I would mess with it in Zensys

This same thing is happening to me now. The stick is freezing up at random, and only power cycling the pie gets it talking again. This started after upgrading to the latest OpenHab, and was problem-free before. I don’t think that’s a coincidence.

Please can you say from what version, and TO what version you have changed from/to. I don’t think there have been any changes to the binding over the past few versions, but maybe you were using something older?

1 Like

2.4 to 2.5.

I put my zstick on my PC and poked around in zensys tools. There were two dead nodes still on the stick that do not exist in reality. After several attempts at hitting NOC and remove failed, I finally got rid of them. Then verified all remaining nodes were real devices in OpenHab.

I put the stick back on pi and rebooted. So far, so good. It will take a little more than 12 hours for me to call it fixed. I understand this issue caused other people to have similar problems so I’m hoping this clears it up for me too.

These dead nodes didn’t bother anything for a year in 2.4, but immediately wreaked havoc in 2.5. I assume something in 2.5 changed that made it more susceptible to this. Not suggesting that’s a problem though, as clearly those dead nodes were an actual problem.

I don’t think so. There weren’t a lot of changes between 2.4 and 2.5 and generally all the protocol stuff is handled in the controller and not the binding.

Something made it uncooperative. That z-stick configuration has worked without fail for over a year as-is. Then a few hours after installing 2.5, it was failing every few hours requiring a reboot to restore, fail a few hours, later, reboot, and so on. I’m not annoyed by it, since there was indeed a problem on the z-stick. It appears to be a z-stick problem, not an openhab problem. It’s just odd that the problem didn’t show itself until 2.5 was installed.

Odd maybe, but that doesn’t mean that it’s related by any means. I know it’s really easy to jump to conclusions, and maybe it is related, but it’s also quite likely to not be related given the thousands of others who upgraded without such problems.

I’m just saying - keep an open mind :wink:

For one thing. your Z-Wave network was restarted.