Z-Wave Thermofloor Heatit Z-Push Button 8 not recognised by Openhab

When I include the z-push button 8 in our zwave network, the device is not recognised bij Openhab. In the zwave debug-log I can see that it is connecting and communicating.

The device can be found in the Opensmarthouse-database as ‘ThermoFloor Heatit Z Push Button 8 Wall Mounted Switch’. So I presume that OpenHab should recognize it.

In the xml that Openhab created the manufacture ID is 019B, the type is 0300:A305. These look the same as the entry in the opensmarthouse-database.

When I look in the logs I can see that openhab is validating against a lot of known devices. But I can’t find that Openhab is validating against the ‘Unique Reference’ of ‘heatit4512581’ in the log. That is the reference that is mentioned in de database by this device.

any help to get the device recognized is appreciated,…

Michelnetwork_ed4be667__node_2.xml (9.6 KB)

What version of openHAB? That entry was last updated for version 2.5.0 and higher.

openHAB 2.5.10-1 via openhabian

The device was not approved in the database - I’ve done this and it should be in the binding in a few days.

1 Like

You write that it should be in the binding in a few days. How can I make use of it? Do I have to use the snapshot-build of openhab to get the new binding, or is uninstall/reinstall of the zwave binding sufficient?

At the moment I’ve switched over to the snapshot build an update every few days. But until now the device is not recognised.

What am I doing wrong?

thx in advance

OK, I found one way of solving it. I put the latest snapshot-version of the binding in the addon-directory. Now the device is recognised. Thx for the good work.

How long do I have to update the binding myself by putting snapshot-versions in addon?

Until there is a new release.

I have the same device.
I just downloaded the latest snapshot but it still show as “Uknown Device” (https://ci.openhab.org/job/openHAB2.5.x-ZWave/88/)
Is this wrong snapshot?
openHAB version: 2.5.10 Release Build

331 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: ZWave Binding

Please provide the EXACT information that is shown so we can work out if you have the same device or not.

1 Like

Hi Chris.
I’m unsure how to provide you this information.
I have uploaded screenshot of habmin and paperui.
But I assume this will not give you the information you need?

My guess is that the device is simply not initialised - you need to wake it up so it can be initialised, and discovery completed.

1 Like

Ok I will wait and see if it will be completed.
I have also tried to reboot but currently it’s the same problem.
I also checked \var\lib\openhab2\zwave\ and I can’t see that the xml is generated for that device (yet).

It will not complete initialisation by itself. You need to wake the device up.

I have tried to follow the instructions here: https://www.heatit.com/wp-content/uploads/2019/07/Manual_Heatit_Z-Push_Button_8_FW_1.26_Ver2019-A_ENG.pdf
On page 3 I have tried both “How to communicate with the device” and “Node Information Frame”

Ok, unfortunately I can’t really say much more. Is the device waking up? My guess is that it isn’t based on the screenshots above. Maybe its too far away from the controller, or maybe the button press is incorrect.

Have you checked the debug logs to see what is happening?

I the log I can see that controller communicate with the device.
When I try to wake up the device I see this in the log:

12:33:59.288 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'zwave:device:a9e40710:node49' has been updated.

This is the correct node.
Habmin also show correct timestamp

Is that caused by the wakeup, or something else? Have you enabled debug logging? If not, please read the binding docs and do this - otherwise we can just guess, and that’s not very reliable :slight_smile:

Really, we need to understand this as it’s important. If the binding doesn’t receive the wakeup message, then it won’t be able to initialise the device.

zWave.log (175.4 KB) Hi again.
I have uploaded the debug log for zwave

So the log shows that you are receiving the WAKEUP message, but the device then doesn’t respond when the binding sends it a request -:

Perhaps a defective device?