Z-Wave Zooz ZEN24 Lightswitch - Online, but can't see status on/off in Openhab

Tags: #<Tag:0x00007f433673dcc0>

Thank You apella12! I will give this a whirl! :slight_smile: I dunno what the ‘Simplicity studio PC Controller’ is, but will look into it. :slight_smile: Thanks again! --ABP

Thank you 5iver!! …and whoops with HABpanel VS Habmin! My bad! :grimacing: :slight_smile:

I did not update the binding, so I’ll try that first!

I don’t have time tonight to try these things, so I’ll reply back with the results after running that command in the Karaf console.

Thanks so much!

–ABP

If you know that it is not updated, then there’s no need… it will provide the version of the binding that you are using. Although, using the console is an important part of using OH, so good to learn.

Definitely follow the advice of @5iver first. I thought you had put the new Zwave snapshot .jar in your addons and were still having problems. He has a script that can remove the old and get the new.

Bob

Continuing the discussion from Z-Wave Zooz ZEN24 Lightswitch - Online, but can't see status on/off in Openhab:

Hey folks, just jumping into the pool here. I am having the same issue and was hoping you could clarify for me.

Is this a manual method (found some search results about jar files) or can it be done with a cli command? I am not sure I am tracking the actual update procedure you are going to use.

Side note: I seriously appreciate and am excited about the support being thrown your way on this. It is nice to see a community so eagerly willing to help!

After a change to the device database, it needs to be exported and included in a build of the zwave binding. You can watch for builds here (BTW, it looks like this change is in the latest)…

You can then wait for an OH 2.5.x release… there will probably be at least one more… or install the binding manually. There is a script for this, but there are also steps to do this yourself in the readme…

@5iver, that did the trick. I am running the zen24 v4 and they are up and running now.

Seriously, thanks for the help!

1 Like

Excellent! Out of curiosity though, did you install it manually or use the script? I’ve seen some people report the script failing, but haven’t had time to look into whether there is an issue with it.

@5iver, I used the script.

I was having a little trouble navigating the folders and find the jar location via samba. It was a good bit easier using the script. Your readme broke it down very nicely.

1 Like

As the one who uploaded the new XML for v 4.0 to the DB, I’d like to understand how to generate/install a build.

Otherwise I was just waiting for another maintenance build.

Thanks Scott

Will that binding be compatible with the rest of my system on 2.5.0?

My upgrade saga is in another thread…

Yes.

I certainly appreciate the upload. The link @5iver posted ran it down pretty well in the readme. I did use the script though, not the manual way.

I think I only had trouble pinning down the destination of the script and the running of it with my lack of linux cli. Google propped that up for me. If I can help let me know, but the expert (@5iver) did an amazing job on it.

1 Like

I’m really happy Sticker got this working :slight_smile: He’s doing a lot better than me!

I opened the read.me and followed all the steps, but I’m unable to execute the script.

I downloaded and put the the script (zzManualInstaller.sh) into the add ons folder (/usr/share/openhab2/addons). I then logged into openhabian using SSH and issued the “sudo -E -u openhab bash zzManualInstaller.sh” command. The only response I get is “No such file or directory”.

I’m not sure where else, or how to find, a different /usr/share/openhab2/addons folder if a second one exists. I downloaded the file (zzManualInstaller.sh) and put it in the add ons folder via windows explorer over the network. I can also see the zzManualInstaller.sh file in the add ons folder via Visual Studio Code.

I’ve been working on this the past 3 days trying to figure out what I’m doing wrong and have been trying different things and I’m mentally exhausted now, lol. If anyone has any ideas and would like to help I would be very grateful! :slight_smile:

–ABP

Don’t do that :slightly_smiling_face:! When you have trouble, just ask. Check the permissions on the file and make sure that the openhab account has permissions to read and execute the script.

1 Like

:smiley: OK, thanks! I’ll try not to do that anymore! :slight_smile:

I checked the permissions on the zzManualInstaller.sh file and it was read only for openhabian, so I changed the permissions to ‘read, write,& execute’ for openhabian user and tried again, but got the same “No such file or directory”.

I also tried tried “chmod u+x zzManualInstaller.sh” in order to change the permissions, but also receive the “No such file or directory” message.

I did a sudo reboot after changing the permissions on the zzManualInstaller.sh file and did everything a second time, but still a no go.

Thanks 5iver for helping! Much appreciated. :sunglasses:

–ABP

OH does not run under the openhabian account, but the openhab account.

1 Like

OK, thanks. This might be where my problem is! You’re right, previously I used SSH and logged into openhabian.

After your reply I logged into “the console” following the directions here:https://www.openhab.org/docs/administration/console.html

Weird thing is I had to log into openhabian first, then use the command “openhab-cli console” which then got me logged me into openhab (SSH showed openhab and not openhabian). I tried the following commands again in (what I’m assuming) is the openhab account and not the openhabian account:

‘chmod u+x zzManualInstaller.sh’ and received this message : Command Not Found: chmod

I then tried ‘sudo -E -u openhab bash zzManualInstaller.sh’ and received this message: sudo: undefined option -E

If I have to log directly into openhab (which I assum is the OH account and not the openhabian accoount), I’m not sure how to do that as I tried using ‘ssh -p 8101 openhab@localhost’ via the instruction in the link above and I was able to get the UN but not the PW. The default PW did not work and I tried the others I’ve been using for OH stuff.

Thanks 5iver and everyone.

-ABP

The default password for the openhab account is habopen. You can’t do this through openhab-cli. You need to ssh into the system with the openhab account, or openhabian and su to the openhab account.