Z-Wave Zooz ZEN24 Lightswitch - Online, but can't see status on/off in Openhab

Tags: #<Tag:0x00007fe734e37bf0>

Greetings! Please let me introduce myself - My username is ABP and I’ve been reading up on OpenHAB for the past year (off and on) and finally have made the leap to really get going with the OH setup/ecosystem. I just started and got Philips Hue bulbs set up with zero issues last week (I can turn them on, dim them, etc all through OpenHab’s ‘control’ panel/webpage. This week I’ve added the Z-Wave Stick (Aeotec Z-Stick Gen5 Z-Wave Hub Z-Wave Plus USB) and a Zooz ZEN24 Light switch to Openhab successfully. Both show up as “online” (green) in Paper UI>Configuration>Things.

However, the Zooz Zen24 Light switch shows up as an “unknown” device in paper UI>Configuration>Things (even though it’s showing me all is good with a green ‘online’) with the following description: (also, OpenHab/Z-Wave named it “Z-Wave Node 005”)

> This device has not been fully discovered by the binding. There are a few possible reasons for this -:
> The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like “Z-Wave node 1 (0082:6015:020D::2.0)”). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.

> The device initialization is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

…and under ‘show properties’ (still in Paper UI>Configuration>Things) it shows me that Openhab/Z-Wave knows what that the thing is because it shows me this (and a lot of other stuff):

> |zwave_class_basic |BASIC_TYPE_ROUTING_SLAVE|
> |zwave_class_generic IGENERIC_TYPE_SWITCH_MULTILEVEL|
> |zwave_class_specific |SPECIFIC_TYPE_POWER_SWITCH_MULTILEVEL|

When I go to Paper UI>Configuration>Things and click on “Z-Wave Node 005” it has no “channels” whatsoever. So I can’t link its channel(s) to a state (I created an ‘item’ for the light switch, but I can’t link the two together). I’m thinking this is the spot that I’m not understanding. I basically want to get the light switch onto OpenHab’s ‘control’ page to turn the switch on/off and see any other status it can provide (dimmer, voltage, etc). Or as noted above “The device initialization is not complete”.

I have OpenHab installed on a Raspberry Pi 3 Model B Plus Rev 1.3. The version of OH I have is openHAB 2.5.9-1 (I updated OH a week or two ago in anticipation of getting started). I also use ‘Visual Studio Code’ to edit configuration files, but I’m pretty new to VSC. :slight_smile:

I guess the main question in this is "I want to get the light switch onto OpenHab’s ‘control’ page to turn the switch on/off and see any other status it can provide (dimmer, voltage, etc). If anyone can help it would be greatly appreciated. :slight_smile: I’ve been trying to figure this out for the past couple days on my own and have scoured and googled the internet and come across a lot of great information, but I’m googled out (lol).

I’m still new to this and trying to get the basics (editing config files, seeing the things I add get onto the ‘control’ page, etc) before I jump ahead to hab panel and stuff.

Thanks for reading and possibly helping!

–ABP

Welcome.

I believe @5iver has that model of switch.
The Zooz & thesmartesthouse people have been very helpful in getting their devices supported in OH.

Thank You Bruce_Osborne :slight_smile:

I should also add that OpenHab Log Viewer (frontail) has zero errors (it shows everything is good).

– ABP

Your device is not initialized. It’s mains powered, so it should have happened very quickly. How many other devices do you have and are they functioning? How far from the other devices is the switch? Does the switch control the lights when used manually? I suggest to first try restarting OH. If that does not help, try excluding the device, deleting the Thing, and then including it again. It is usually helpful to unable debugging for the Z-Wave binding (look at the bottom of the documentation page fior the binding for details).

When you get to configuring the device, it is best to use Habmin, which was purpose built for Z-Wave. Paper UI can potentially mess things up for Z-Wave devices.

1 Like

Thanks 5iver!

To answer your questions :slight_smile:

How many other devices do you have and are they functioning?

I have zero other z-wave devices. This single dimmer switch is the only z-wave device I have (aside from the Aeotec Gen5 USB Z-Stick Controller) and yes it’s functioning (I just can’t control it though Openhab). I can physically control it by hitting the button ‘up’ to turn the light on, hitting the button ‘down’ to turn the light off, ‘hold the button up/down’ to dim the light up/down, etc.

How far from the other devices is the switch?

The Z-stick and dimmer switch “live” 20ft apart.

Does the switch control the lights when used manually?

If you mean, when I push up on the physical button on the dimmer switch that is attached & installed into the wall and the light turns on - Yes. :slight_smile:

I suggest to first try restarting OH.

I tried this after reading your reply and unfortunately it did not solve the issue.

If that does not help, try excluding the device, deleting the Thing, and then including it again.

This gave me hope, but unfortunately this didn’t solve the issue either. However, it did change the name from node 5 to node 6. All other parameters were identical (called it an unknown device, but it still had the information like it knew it was a switch). I also did all this though HABmin (since reading your reply).

It is usually helpful to unable debugging for the Z-Wave binding (look at the bottom of the documentation page fior the binding for details).

I’m guessing unable = enable? So that’s what I did. :slight_smile: If unable meant to de-able please let know and I’ll go change that. One thing here - I logged onto the console and did everything per the documentation page and the debug command was accepted, so I think I did that part right, but I haven’t seen a log of any kind relating to z-wave and I don’t know where to look. The doc also said to delete the XML file for the node (in /userdata/zwave), so I looked and looked and concluded that I have no idea where that exists.

Another thing that might be helpful is when I’m using HABmin and select TOOLS>Z-WAVE NETWORK VIEWER, I see both the Z-Stick (named ‘1’) and the dimmer switch (named ‘6’) and there are no other z-wave devices detected (as I would assume since I only have two z-wave devices).

Whew! I’ve really struggled with this most of today and have learned that I don’t know nearly as much as I thought (or was hoping) I did, lol. I thought I had taught myself enough to get started, but I guess not, but I’ll keep trying. :slight_smile:

Thanks so much for helping 5iver!

–ABP

1 Like

I’d like to also add…

After unpairing the dimmer switch from the z-stick, I tried to ‘search’ for z-wave devices using Habmin and openhab could never find anything. So, I grabbed the z-stick, put it next to the dimmer switch, put the z-stick in pairing mode, hit the dimmer switch button up 3-times, and got a successful pairing. Then I put the z-stick back into the raspberry pi and Habmin then found the dimmer switch. I’m assuming this is the correct way of doing things, so I’m adding this bit of information in case this is the wrong way to do it.

Thanks again!

–ABP

Typo! I meant enable. Just remeber to set it to WARN (or INFO) after you are done troubleshooting. Without any devices, you won’t see much being logged, except during startup and inclusion/exclusion, or when using the device.

Don’t give up yet. It is possible that you are doing everything right but there could be an issue with the hardware or device configuration int he database. We’ll get it figured out!

Did you put the device into inclusion mode?

@Bruce_Osborne, can this be done hot, or does OH need to be shutdown when unplugging/plugging in a USB Z-Wave controller? I know back in the day, OH needed to be shutdown, and I recall a PR for this, but don’t recall if it worked or was possible reverted.

Either way, this is a legitimate way to add devices. However, it is much better to perform the inclusion of devices through OH, which gets the initialization and identification out of the way. The way you did it, the device should get identified eventually, but it can take a while. In my experience, it can take a day, or may pop in after a restart of OH. You can also just restart the binding in the Karaf console…

bundle:restart org.openhab.binding.zwave

Assuming the device is working properly and it has been included properly, let’s make sure it is setup right in the database. What do you see in Habmin> Configuration> Things> select the Thing for the device> Attributes? I’m interested in the Type:ID and firmware. You can post a screenshot right into your post.

1 Like

I always platy it safe and power off the openHAB system before unplugging the stick.

You should at least shut down and restart the binding.

Personally I don’t recommend pairing in this way - it’s better to use the binding than removing the stick. While this might work, and you might get the device to pair, you then move the stick elsewhere, and it may not be able to communicate with the device.

It seems to be your problem I think - the device is not communicating with the stick anymore, the binding therefore knows nothing about the device, it will not configure it and it can’t determine what the device type is.

1 Like

It could possibly be a defective device. Zooz support is excellent and can send a tested replacement if needed.

It could be, but I think it’s unlikely. It joins the network, so it is working enough to do that, and therefore should be fine. To me it looks like communications - I might have missed it in the above information, but I didn’t see how far the device and controller are apart?

Here…

Thanks. Depending on what’s in the way (walls, concrete, metal etc), and device mounting at each end, it could be a problem - I would suggest to try moving them closer to at least rule this out.

If the device is mounted to a steel electrical box instead of a plastic one then it may only project the signal through the wall plate.

I just remembered that some people have steel wall plates. Since the box & plate are grounded that couls basically become a Faraday cage and block the signal.

Did you put the device into inclusion mode?

Aw! I don’t think I did when using OH (I did put the switch in pairing mode when using the z-stick and putting it right next to the Zooz switch). After reading this I went through a lot of what I did yesterday with a couple tweaks:

I unpaired the switch from the Z-stick successfully (put the stick right next to the switch) and then deleted the Node 6 “thing” via HABmin. I then rebooted the Raspberry pi (Openhab). While OH was rebooting I did a factory reset on the Zooz switch for good measure per the instructions in the zooz switch documentation. (Unfortunately there doesn’t seem to be a way to know if a factory reset is successful and a brief google search shows people having issues with doing a factory reset on these (as in not understanding the directions or if the reset was successful, so I simply moved forward not knowing if the reset worked or didn’t work - physical switch still turned the lights off/on, so I was happy). Once OH was back up and running, I used HABmin and searched for z-wave things and put the zooz switch into inclusion mode. HABmin found it and I added it as a ‘thing’. OH named it Node 7 this time with all the same parameters as it did when it named it Node 5 and node 6.

> @Bruce_Osborne, can this be done hot, or does OH need to be shutdown when unplugging/plugging in a USB Z-Wave controller? I know back in the day, OH needed to be shutdown, and I recall a PR for this, but don't recall if it worked or was possible reverted.

After reading yours and Bruce_Osborne’s replies, I will shutdown the Raspberry Pi before unplugging anything. Thanks :slight_smile:

Either way, this is a legitimate way to add devices. However, it is much better to perform the inclusion of devices through OH, which gets the initialization and identification out of the way. The way you did it, the device should get identified eventually, but it can take a while. In my experience, it can take a day, or may pop in after a restart of OH. You can also just restart the binding in the Karaf console..

```
bundle:restart org.openhab.binding.zwave

I don’t know what the Karaf console is, so I’ll read up on it. :slight_smile: I did try the bundle:restart command noted above through SSH when logged into the Raspberry Pi, but when entering that command I got a message saying command not found. So, I wasn’t able to restart the binding unless a reboot does that too? Which I did do a reboot.

Assuming the device is working properly and it has been included properly, let’s make sure it is setup right in the database. What do you see in Habmin> Configuration> Things> select the Thing for the device> Attributes? I’m interested in the Type:ID and firmware. You can post a screenshot right into your post.
[/quote]

Here you go :slight_smile: Thanks so much for helping :slight_smile:

This seems to be a newer versions than is in the database.

@5iver Really we should not restrict the upper version on devices to allow for some “out of the box” support for new versions rather than them not worked at all, as we have here.

Thanks to everyone who replied in regards to distance may be the problem. :slight_smile: To answer the questions:

The two z-wave devices are 20ft apart and go through one floor and the one wall (the wall in which the zooz switch is installed). The Raspberry Pi (and Z-Wave Stick) are in the basement where the internet enters the house. I’ve built a shelf to keep them up high (about 12" from the basement ceiling).

I’ll try to get the two z-wave devices closer together so the RF doesn’t need to go through the floor to see if that fixes the problem or to rule the distance part out as Chris Jackson said. :slight_smile:

The electrical box is blue plastic, but the zooz switch and cables are scrunched together in there really tight. There’s not much room in there. (The Zooz switch is 2x-3x bigger than the original switch).

Thanks again for everyone’s help!

–ABP

I’m not quite following, my apologies. :slight_smile:

Does this mean the problem is “on Zooz’s end”? and they need to update a database of some sort before my zooz switch will update appropriately?

should I keep on troubleshooting?

Thanks again!
–ABP

Let’s start with the short answer :slight_smile:

No.

That’s ok - I was a little verbose and my comment was aimed more at @5iver who (I think?) probably created the database entry for these.

The point is your device is a newer version (version 4). The database only has versions up to 3.x - if we’d made the 3.x version work with all newer versions, then it would have worked now (even if some new features possibly may not work).

So, until the new version is added to the database, your device won’t work - I would say based on the properties, it is probably working ok, but it’s just not in the database.

The easy way to get there when sshed into the Pi is

openhab-cli console
The password is habopen
To exit type logout.