Zigbee: Aqara Temp/Humidity sensors not updating with BV 2010/10 Stick

Hi there,

I’ve got a Zigbee stick BV 2010/10 which Openhab (3.1.0) recognized without problems.
I’ve tried using two Xiaomi Aqara Temperature/Humidity sensors.

While they were recognized, somehow I don’t get any updates. Both are shown as ONLINE, one of them sent initial data, but then stopped. The other one didn’t update it’s values so far.

I’ve read that there could be problems, but couldn’t find any solutions.

Can anyone maybe give me a hint what I could try?

Can anyone help with this? I’m stuck…
Should I get a different stick?

Hi, what is your setup? Zigbee Binding?
I am working with zigbee2mqtt and handle around 30 aqara devices without any issues.

Stick: https://www.amazon.de/gp/product/B0887J2M2X/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

I had this working on the Bitronvideo ( have changed coordinator to the Itead prerelease stick now)
I belive I had to set “child aging timeout” to a high value.
Now I have it set to two weeks.

These sensors can take quite a long time before they change parent in the mesh, so if the parent goes down they will be offline.
Not sure how this is seen in UI.

Some Ikea bulbs have a bug; sometimes they crash and wil not route in the mesh while they seems to be online for the children.
A power cycle wil fix this. I belive I have seen this on a Ledvance bulb too.
The combination of this bug and the longish time before the sensor canges parent can be quite confusing :slight_smile:

As for the coordinator (stick):
A " ember" stick with a newly firmware is needed for the newer zigbee v3 devices. The Bitronvideo has a firmware that is too old.
But the Aqara temp/humidity sensor should work on the Bitronvideo.

Popp and Elelabs has sticks with a ember chip.
I belive Popp has the newest firmware availible.

Tried, out of curiosity, with zigbee2mqtt but keep getting:

Zigbee2MQTT:error 2021-08-24 21:56:32: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2021-08-24 21:56:32: Failed to start zigbee
Zigbee2MQTT:error 2021-08-24 21:56:32: Check https://www.zigbee2mqtt.io/information/FAQ.html#help-zigbee2mqtt-fails-to-start for possible solutions
Zigbee2MQTT:error 2021-08-24 21:56:32: Exiting...
Zigbee2MQTT:error 2021-08-24 21:56:33: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/opt/zigbee2mqtt/lib/zigbee.js:67:27)
    at Controller.start (/opt/zigbee2mqtt/lib/controller.js:106:27)
    at start (/opt/zigbee2mqtt/index.js:94:5)
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.21.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the zigbee2mqtt@1.21.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2021-08-24T20_56_33_578Z-debug.log

I’ve got this stick now as well, could you maybe share your config? Somehow dmesg doesn’t show anything if I plug it in. Is there a module required?

As example my first rows

homeassistant: false
permit_join: true
base_topic: mqtteg
server: mqtt://192.168.1.xx
port: /dev/ttyACM0
\n\nadvanced:\n network_key: GENERATE
last_seen: ISO_8601_local
friendly_name: Example

Thank you
Looks like I got a faulty stick, it doesn’t show up and the LED is not on

Received a new stick, the other one was faulty :/.
It’s working now with Zigbee2Mqtt.

Any idea how long the battery on the Xiaomi Aqara Temperature/Humidity lasts? It’s only a CR2030 or so

I generally get a year or more out of them - I’ve never timed it, but they last a long time.

1 Like

They do not send updates anywhere near as often as the Sonoff brand version. See this on the difference in their resolution. So they probably trade some resolution to increase battery life, to be fair the steps you see are only 0.5 degrees different so it is accurate enough. The sonoff uses a battery that holds around 2-3 times the power.

Red = Aqara

1 Like

I think the Xiaomi Aqara Temperature/Humidity only sends when something changes. EG temperature or humidity etc.

I was having problems with my Xiaomi Aqara this morning and it wasn’t pairing or communicating.
Turned out to be a flat battery!

I also have the sonoff temperature sensor. I haven’t had it long but it seems to work fine.

Typically this is true of all zigbee devices. They should be configured so that only changes are reported - if there’s no change after some time (eg 1 or 2 hours) then they will normally be configured to send an update anyway so the system knows they are alive.

In the case of the zigbee binding, the binding defines this configuration - I don’t know about other bindings though.

Thanks for the replies! Yeah it seems they only send if necessary, that’s nice.
I might try the Sonoff ones as well, thank you

Quick follow-up: can anyone recommend any Zigbee Routers (cheap) to extend the range of these Aqara devices?

I believe the Ikea tradfri gear works with Aqara, but many devices are reported to strictly follow the zigbee standard and will drop Aqara from the mesh.

Consider looking at the Sonoff SNZB-02 for similar sensors instead of the Aqara, or you can use the Aqara gateway and binding if your happy sending data to their cloud.

1 Like


I’m unsure… aren’t 433mhz sensors the better choice since the range is sufficient, they mostly have AA batteries, etc?
I’m using an RFXTRX433 for other things, but I’m unsure

No routing for 433 MHz sensors, no bi-directional communication (for sensors), but if the signal strength is sufficient, there is no reason not to use them. A cheaper RX only alternative to a RFXtrx433 is a RTL-SDR (Tutorial - rtl_433 brings 433MHz sensors to openHAB - #31 by Kim_Andersen).

If the signal strength is sufficient (which is remarkably better than with Zigbee), then there is no need for routing. I’m looking specifically for good Temp/Humidity sensors to use in every room in my house. so two-way is not needed.

I already have the RFXtrx433, but the rtl-SDR looks nice!