Zigbee binding slow response

Hi there,

I’m struggeling getting my Tradfri devices to work with an cc2531. After testing with an docker imange on synology, I now installed openhab (2.5.0-1) on a Raspberry 4. On this setup I finally managed to find my things and channels via the zigbee binding. happy
I’ve linked an Tradfri Remote and a Tradfri Switch to a Tradfri Bulb (GU10 400lm). When I press the switch or the toggle on the remote, OpenHab reacts instantly and moves the dimmer bar. But the bulb doesn’t react. Sometimes it takes 10 seconds, sometimes even a couple of minutes before the bulb starts dimming.
Is there anything I can do to get an instant reaction?
Many thanks in advance!


This has been discussed in a few threads and it appears to only affect a few users. This does not apear to be a Zigbee binding issue, but something else.

Is this a new install or an upgrade?
What other bindings do you have installed?

Hi Bruce,

Its a fresh (but manual) install on a new system. I’ve only installed the zigbee binding…
Since I’m in a testing phase I might also try the preconfigured Image…!?

What OS. platform (Pi?) and instructions?

Since I also wanted to use the Pi (Pi4, 4GB) as an Audio Player I used the newest volumio Image (based on debian jessie), installed Zulu and than OpenHab.

I thought the Pi 4 required Debian 10 Buster. Jesse is Debian 8.

Obviosly it works anyway… :slight_smile: But in the meanwhile I put openhabian based on Buster on a different SD card and ran that. Same behavior… :frowning:

Are there any ideas on what else I can try? Should I move my thread to another category, since it’s not a unique problem with the zigbee binding!?

(If it seemed, that I fixed it, that wasn’t the case. I just meant that the Pi4 obviously also works with an image older than buster…)

Here the same Problems …

openhab 2.5.0 Stable @ Docker

Different Ikea Bulbs on different Gateways and Hardware.

Gateway: Ikea Tradfr @ Tradfri Binding , Deconz Conbee 2 @ Raspberry Zero, Deconz Conbee 2 @ Raspberry 3b+ @ Hue Binding

Sometimes Delay of 10 Seconds :frowning:

None of these sound like they are related to this thread as you’re not using the ZigBee binding are you?

Are you using the ZigBee binding? Looking at your log, it looks like you are using the Tradfri binding? You also mention the “tradfri bridge” so I don’t think this is related.

@chris, you are correct the OP was not referring to the tradfri binding, missed that; I will delete my post as it is irrelevant to this thread

In the mean time I’ve installed a original Hue Bridge (and paired my tradfri bulbs with it). Using the hue-binding I get no lag at all, all bulbs respond immediately. It works as a charm. So it’s either the zigbee binding or the cc2531 stick itself, that causes the problems!?

I am not really able to look at this until people are running the latest version. The current binding has very old libraries and there has been a lot of work done as we’re currently going through formal ZigBee certification on a product (hopefully completing this week).

Until the latest libraries are merged there is little point in me looking into this - sorry. I’m waiting for the following PR to be merged.

Is the current binding mentioned (old binding) the one in the OH 2.5 Stable release?

Yes, the current stable binding is OH 2.5.0, but the same situation is also true for the OH2.5.1-SNAPSHOT.

1 Like

Okay… Just making it clear, as I´m running 2.5 Stable release binding for a few weeks on my Odroid C2 system… This seems alot more stable than ever before. Beside the traadfri motion sensor dont work, but thats an issue I read somewhere you´re looking at. All my others devices are running without any issues.
I havn´t tried restarting the system yet though :slight_smile:

1 Like

That may or may not help a little. Please try and be patient for the updated binding code. That may very well resolve most of your issues.

I’ve literally just received a new Ikea Motion sensor so will try and test that this week.

Just did a restart. Everything came up running again without any issues.
Thats very uncommon for my system. Normally my Trust motion sensor would fail after first restart, as well as the Osram plug. The Hue devices normally survive a restart, but will eventually turn to offline after a coupple of day.

1 Like