Zigbee binding

Never mind, worked it out. Still don’t like colour wheels…

You don’t need color wheels - you can link the color channel with a dimmer item or switch item and it will work correctly.

1 Like

Yes, as Jared said, you can link a color channel to a switch item and link the same color channel to different dimmer item and both will work

1 Like

@chris
Since I updated the Zigbee binding and lib two days ago, I have had a hell with some of my devices like the Philips Hue Dimmer Switch, Osram powerplug and the Trust motion sensor… The Philips Hue motion sensor have also had a hickup, which I believe is due to running out of battery. I changed the batteries yesterday, and it has been running since.
Yesterday I removed the dimmer switch, Osram plug and the Trust sensor. Today they all are gone again (they still show online, but no reaction anymore).
This problem seem very much like the ones I had several months ago.

When I updated the binding two days ago, something went totally wrong. My Ember dongle wouldnt go online. It said problems with the serial port. Removing the dongle and add it again did not do any good either. I had to restart openhab to get it to run again. Then I had to remove the devices and add them again as well, ofcouse.

After this, I did some testing with a Xiaomi door/window sensor, which didnt work (ofcouse)… I dont know if it´s related, but since then I simly can not add the Trust motion sensor again… It discoveres fine, but never finished the discovery fully… I have tried quite a few times now. No luck…

This is what I´m running right now:

openhab> bundle:list -s |grep -i zig
311 x Active   x  80 x 2.5.0.201903170725     x org.openhab.binding.zigbee
312 x Active   x  80 x 1.1.6                  x com.zsmartsystems.zigbee.dongl
313 x Active   x  80 x 2.5.0.201903170725     x org.openhab.binding.zigbee.xbee
314 x Active   x  80 x 1.1.6                  x com.zsmartsystems.zigbee.dongl
315 x Active   x  80 x 2.5.0.201903170725     x org.openhab.binding.zigbee.cc2
316 x Active   x  80 x 1.1.6                  x com.zsmartsystems.zigbee
317 x Active   x  80 x 2.5.0.201903170725     x org.openhab.binding.zigbee.emb
318 x Active   x  80 x 1.1.6                  x com.zsmartsystems.zigbee.dongl
319 x Active   x  80 x 1.1.6                  x com.zsmartsystems.zigbee.dongl
320 x Active   x  80 x 2.5.0.201903170725     x org.openhab.binding.zigbee.tel
openhab>

Here is a debug log… Hope it shows something.
The latest triggering from the Trust sensor is at time
01:10:44 21.03.2019 (24 hour format). So somewhere between 01.10.44 and about 08.00 o´clock this sensor stopped responding. I log a postUpdate with time and date, each time a motion sensor is triggering, which is why I know, when the sensor last triggered. I have no idea when the dimmer switch stopped responding nor the Osram plug.
You should be able to find my tries adding the Trust sensor somewhere between 18.00 and 21.00 this evening.

zigbee.rar.txt (229.0 KB)

Kim - the current version of zmsmartsystem is 1.1.10. You are on 1.1.6. I think you may have an old version of Scott’s script for downloading the files. I know for me the old script wouldn’t detect newer than 1.1.6 and when I specified newer versions it didn’t work correctly. My guess is that because you have the new binding but old zsmart systems you are getting these errors. Def want to update to the real current version before too much debugging can take place.

FYI you can get current release version number from GitHub at https://github.com/zsmartsystems/com.zsmartsystems.zigbee/releases

1 Like

Anyone got this working?
https://community.openhab.org/t/osram-smart-motion-sensor/70629/3

Ahh damit… I wasnt aware of 5iver´s script was version dependable. I thought it always downloaded the latest, and I didn´t pay attention to the version…
It makes alot of sense why I´m having these issue then. I´ll change to 1.1.10 later tonight.

EDIT.
I tried 5ivers script to get the .jars, but couldnt get it to work… (I have reported my problems in the script thread). I then installed a backup of 1.1.10 I had. And now it seems to be working fine again… Had to make a new discovery for my Dimmer switch, Osram plug as well as the Trust sensor. BUt they were discovered pretty fast and now working.

Hey all,

i am using the motion sensor from aqara/ xioami (see here: Picture of Motion Sensor)

It now seems, that the zigbee binding does not report the state of the detected motion, which is also reported here: https://github.com/openhab/org.openhab.binding.zigbee/pull/369#issue-246071915

Has someone a workaround/ solution for this issue? Would be really great! Many thanks

Hi @Baggerfahrer,

Use the Expire binding, and add the timeout to the item like this:

Switch MainCorridorOccupancy “Main Corridor Occupancy” (Occupancy) {channel=“zigbee:device:04000AB3:00158d0002371f19:00158D0002371F19_1_occupancy”, expire=“1m,state=OFF”}

It will go back to off after one minute (or whatever you set it to).

I use the group “Occupancy” for some general rules. It is not needed for the timeout functionality.

Hope this helps :slight_smile:

Pedro

2 Likes

Hi Pedro,

many thanks for this tip. It helped me solve the problem.
But as i use node-red for scenarios and rules, i implemented your tip via a node.
For those who are interested, here is my flow:

as a tip: i investigated that my sensor sends rhytmical updates every 60 seconds, if there is occupancy detected… thats why i set the delay timer to 80 seconds…

[{“id”:“aef0020.ec306”,“type”:“openhab2-in”,“z”:“f44208b7.eac5e8”,“name”:“Xiaomi Bewegungsmelder - Bewegung?”,“controller”:“68637d61.9e722c”,“itemname”:“XiaomiBewegungsmelder1_Occupancy”,“x”:190,“y”:160,“wires”:[[],[“7257b660.8ca0a8”]]},{“id”:“37e840d7.160f28”,“type”:“openhab2-out”,“z”:“f44208b7.eac5e8”,“name”:“Badezimmer-Licht anschalten”,“controller”:“68637d61.9e722c”,“itemname”:“BadezimmerLicht_Color”,“topic”:“ItemCommand”,“payload”:“263,5,100”,“x”:590,“y”:140,“wires”:[[]]},{“id”:“f7fc2a78.f9b808”,“type”:“openhab2-out”,“z”:“f44208b7.eac5e8”,“name”:“Badezimmer-Licht ausschalten”,“controller”:“68637d61.9e722c”,“itemname”:“BadezimmerLicht_Color”,“topic”:“ItemCommand”,“payload”:“0,0,0”,“x”:790,“y”:220,“wires”:[[“1f9f7f4d.5c2609”]]},{“id”:“7257b660.8ca0a8”,“type”:“switch”,“z”:“f44208b7.eac5e8”,“name”:“An?”,“property”:“payload.payload.value”,“propertyType”:“msg”,“rules”:[{“t”:“eq”,“v”:“ON”,“vt”:“str”}],“checkall”:“true”,“repair”:false,“outputs”:1,“x”:290,“y”:220,“wires”:[[“37e840d7.160f28”,“50023ad3.dd0804”]]},{“id”:“50023ad3.dd0804”,“type”:“trigger”,“z”:“f44208b7.eac5e8”,“op1”:"",“op2”:“0”,“op1type”:“nul”,“op2type”:“str”,“duration”:“80”,“extend”:true,“units”:“s”,“reset”:“ON”,“bytopic”:“all”,“name”:“Switch off delay 80 secs”,“x”:530,“y”:220,“wires”:[[“f7fc2a78.f9b808”]]},{“id”:“1f9f7f4d.5c2609”,“type”:“openhab2-out”,“z”:“f44208b7.eac5e8”,“name”:“Xiaomi Bewegungsmelder - Aus”,“controller”:“68637d61.9e722c”,“itemname”:“XiaomiBewegungsmelder1_Occupancy”,“topic”:“ItemCommand”,“payload”:“OFF”,“x”:1070,“y”:220,“wires”:[[]]},{“id”:“68637d61.9e722c”,“type”:“openhab2-controller”,“z”:"",“name”:"",“protocol”:“http”,“host”:“localhost”,“port”:“8080”,“path”:"",“username”:"",“password”:""}]

@chris, can anyone tell for sure if a zigbee device support MESH ?
I´m not convinced this Orsam Ligthfy plug socket is supporting the MESH. I have some strange problems when I move around the house (only a few meters from the coordinator) using the Philips Hue dimmer switch to test reaction… I have quite a few “dead spot” as it seem… So I move the Orsam plug closer to where I can tell for sure, the dimmer switch has a problem. But it doesn´t change anything… I would say, if there was a “dead spot” there, moving the lug only a coupple of meter from it, it should work through the MESH, right?

Btw. Running 1.1.10 and 2.5 binding.

In general, all routers will route (technically it’s possible that a router can be configured not to route, and there are some applications for this, but it’s very unlikely that a standard commercial bulb would not route).

But the Osram is a plug socket… Not a bulb.
Is there anyway to test/tell? When I´m walking around our house with the dimmer switch in my hand, I can only tell something is wrong, when I push one of the buttons and it starts blinking red. I assume this mean, that the command didn´t get through to the coordinator. Other places in our house it gives a green blink when it works. I then moved the Osram plug to see if it makes any differences, which is didnt. Thats why I think there is something odd going on with the MESH…

I have a few Philips light bulbs as well, though they´re not connected to the coordinator. I might give one of them a try to see whats happens. Just need to figure how to clear/reset them and get them added to the Zigbee coordinator. I have never tried adding a bulb before.

It doesn’t matter - all mains powered devices are routers.

I’m not super sure how well this would ever work? A child device would need to reconnect to the network via a different parent if you moved it. I’m not sure how long this all takes, but it will take some time.

You can always check the routing tables, but in your dynamic situation, it’s probably not going to work very well. You should check the sniffer to see what is happening.

I have changed the MESH to 5 minutes in the coordinator setup, though I have if it have any influence on anything.
But you´re right, I cant use the dimmer switch, if things are taking too long to reconnect…
I have now added a Hue bulb (it was easier than expected. Just clear the bulb from the Hue bridge, and the coordinator then found it). Maybe something will change then.

Where can I check this routing table?

If I understand correctly, you changed the child aging? This is unrelated - when you move a device, it will need to find a new parent irrespective.

It’s in the properties isn’t it?

No, the option, Mesh Update Period. Its default to 1 day. I have changed that to 5 minutes.

Hmm… Not sure what you mean then… This is the proberties of the Hue Dimmer Switch:

And this is for the Osram plug socket:

Ok - this is totally unrelated so will make no difference at all.

Okay… Whats the option for then?

Btw… did you see my screenshots of the properties?