Zigbee binding

zigbee
beginners
Tags: #<Tag:0x00007fd317f556f8> #<Tag:0x00007fd317f553b0>

(Chris Jackson) #924

No - it’s an issue with ESH and the binding only.


(horgi007) #925

Hi,

I’m trying to use xiaomi zigbee devices (temp sensor, button) with openhab trough cc2531 stick in a raspberry pi.
Now I see my two xiaomi devices (temp sens WSDCGQ01LM and button WXKG01LM) in the inbox and I can add to Things but both of them offline.

Do you have any experience on this?
Have you successful setup the system?

Thanks in advance,

Regards


(Chris Jackson) #926

I have used the temperature sensor and it works ok. I’ve got some other devices, but not tested them.

Note that these devices are nor ZigBee devices, so you can expect problems. For starters they probably don’t work through other routers, and may not work if there are network updates…


(Scott Rushworth) #927

For anyone out there using an OH snapshot build >= 1230, could you please test deleting a Zigbee device and rediscovering? There are two of us that have seen an issue, but need some help sorting out the cause and a better understanding of how many people are affected. Thank you!


(Ole Kristian Lona) #928

Has anyone had any luck with the latest snapshot and CC2531? I only get exceptions:

16:01:18.045 [ERROR] [home.core.thing.internal.ThingManager] - Exception occurred while initializing handler of thing 'zigbee:coordinator_cc2531:2431b159': null
java.lang.NullPointerException: null
        at org.openhab.binding.zigbee.cc2531.handler.CC2531Handler.initialize(CC2531Handler.java:53) [213:org.openhab.binding.zigbee.cc2531:2.3.0.201804042202]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
        at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [103:org.eclipse.smarthome.core:0.10.0.201803311938]
        at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [103:org.eclipse.smarthome.core:0.10.0.201803311938]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]

Any pointers, or is there anywhere where I can download a “semi-stable” version of the binding? I am still working to get a remote control to work. This time, I bought a Philips Hue remote. In 2.2.0, it is discovered, but does not offer any channels. So I upgraded to 2.3.0-SNAPSHOT, but then ZigBee doesn’t seem to work at all, at least not with my CC2531 controller…


(Scott Rushworth) #929

I would not expect the latest snapshot binding to work on OH 2.2 due to breaking changes in ESH included in build 1230. To use the latest version of the binding, you’ll probably need to upgrade OH.

Did you install it by dropping the jar into addons? There are now 4 jars needed for a manual install. There’s the Zigbee binding and the dongle binding from here…
https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastSuccessfulBuild/

And then another set of them from here…
https://bintray.com/zsmartsystems/com.zsmartsystems/zigbee/_latestVersion

By far the easiest way would be to upgrade to a snapshot build and install the binding (just one… the rest will be installed as dependencies) through PaperUI.

openhab> list |grep -i zig
244 │ Active   │  80 │ 1.0.8                  │ com.zsmartsystems.zigbee.dongle.ember
245 │ Active   │  80 │ 1.0.8                  │ com.zsmartsystems.zigbee
246 │ Active   │  80 │ 2.3.0.201804032001     │ ZigBee Binding
247 │ Active   │  80 │ 2.3.0.201804032001     │ ZigBee Ember Binding

(Ole Kristian Lona) #930

Oh, sorry, was I that unclear? I upgraded the entire OpenHab installation to 2.3.0 snapshot.


(Scott Rushworth) #931

No… I just misread your post. :slightly_smiling_face: When I read…

… I took that to mean you had only downloaded the snapshot version of the binding. Anyhow, it is working for me with an Ember controller.

Actually, this might cause an issue for your controller, but I think it would be in the current build…


(horgi007) #932

same error here with cc2531 when I update to OH 2.3 snapshot


(Chris Jackson) #933

There looks to be a bug in the configuration - I’ll fix that today.


(Ole Kristian Lona) #934

Perfect, thanks a lot! I started thinking about poking around in the code, but as I have never done any Java-development, and don’t know the coding structure of Eclipse / OpenHAB / Bindings, I have a feeling I would need a few weeks to understand where to look :slight_smile:


(Chris Jackson) #935

I’ve updated the config description which I hope will resolve this. Please give it a try and if there are still problems I’ll take a look over the weekend when I can test it properly.


(Ole Kristian Lona) #936

Thanks a lot, Chris! I had to find out how to compile these bindings in order to test, but I succeeded, and it now works beautifully! As soon as I get home, I can retry adding my Hue Remote.

Have a great weekend!


(Chris Jackson) #937

You should just be able to install this through paperUI as I did a rebuild this morning.


(Ole Kristian Lona) #938

Hehe, some times the solution is so simple :slight_smile: Well, at least I learnt how to compile it. It may come in handy if I struggle with a binding at some point, or something. :+1:


(Ole Kristian Lona) #939

Actually, I just removed the bindings from the addons-folder, and tried adding them from PaperUI, but that gives me the following error:

15:01:24.397 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-zigbee’: Error restarting bundles:
Could not resolve module: org.openhab.binding.zigbee.cc2531 [238]
Another singleton bundle selected: osgi.identity; type=“osgi.bundle”; version:Version=“2.3.0.201804061139”; osgi.identity=“org.openhab.binding.zigbee.cc2531”; singleton:=“true”

-So there may be something not quite right with the rebuild you performed? Obviously, I’ll just re-add the binding manually, so I’m sorted for now.


(Chris Jackson) #940

It looks like you probably have more than one binding running. Possibly karaf has cached your previous version if you were installing it manually (this is quite common).


(Ole Kristian Lona) #941

Ok, thanks again. I will continue fiddling with this, and hopefully not bother you again until something “important” happens!


(Chris Jackson) #942

It’s no bother :slight_smile:


(horgi007) #943

Hi,

After updating to openHAB 2.3.0 Build #1251 my system works or at least everything online.

Now I see my xiaomi device (temp sens WSDCGQ01LM) as ONLINE but I can find any channels.

I do not know whats next, where can I find channels, could you help me?

Thanks