Zigbee binding

zigbee
beginners
Tags: #<Tag:0x00007f0148aa5bb8> #<Tag:0x00007f0148aa5820>

(layttan) #1807

Hello, I have a zigbee fan controller from Hampton Bay (King of Fans) and the light successfully shows up as a level control channel (although doesn’t seem to update openhab when controlled from the remote, but that’s for another day). However the fan control doesn’t show up. I turned on debug and can see that discovery shows FAN_CONTROL in the inputClusterList but channel doesn’t show up, nor do debug/trace when the fan turns on/off.

I did a little digging and it looks like this cluster isn’t included in the binding, is this why the fan events for the cluster aren’t logged ? If this is the case, is there any documentation/guidance on how to add a cluster to the binding that I could follow to implement it ? From what I could tell from the smart things implementation of this device, it does use the expected cluster value and attribute range from the spec, even if it bends the way it uses the attribute values as it has four instead of three speed settings


(Chris Jackson) #1808

Please provide the network XML file for your system (from the userdata/zigbee folder) and I will have a look.


(layttan) #1809

I’ve put it here so you can get it, I can’t upload yet

https://drive.google.com/open?id=1wrY0BoXVNy44LiGUK7g1pvD-tncRZq0Z


(Chris Jackson) #1810

Thanks. So this device uses a cluster that is not currently supported by the binding, or the libraries the binding uses. I have implemented this cluster in a development version of the library and will look to add support in the near(ish!) future.

Please open an issue to remind me…


(Jared Frank) #1811

btw - chris should I open an issue about my active power / total active power channel issue causing that channel to not work?


(Chris Jackson) #1812

Yes, please feel free. I don’t really understand why it worked previously given nothing seems to have changed (other than now it doesn’t work! :wink: ) but please collate the information on what cluster/attribute is supported by the device and I can take a look at it.


(Jared Frank) #1813

Issue submitted. Thank you! Let me know if you need any further info/testing of a fix.


(Pedro Garcia) #1814

Hi @Longfield,

What Xiaomi Aqara sensors are you using?

  • The weather sensor (square one) should join correcty (several reports around saying it gets disconnected after a while, but in my case it is stable).
  • The motion sensor seems to work OK also
  • The tempearture and humidity sensor (round one) has a xml file definition already in the binding, so it should be recognized.

But these devices are hard to join: they are “too sleepy” and they do not answer to discovery messages unless you keep them awake by pressing the button in the device every second till discovery finishes (in my case, even for several minutes…)

So these are a cheap option, but not the most “user friendly” one. This is the device’s fault, anyway, not the binding’s, as they do not seem to be precisely 100% ZigBee compliant.

Pedro


(Arno) #1815

Thanks @chris!
I have updated a week ago, and thus far it has improved my experience with the Elelabs Raspi shield greatly. I was experiencing devices dropping from the network over time, and never coming back. I helped myself with a cron job to restart OH.
With the new libraries, everything is stable. No drops in the last 8 days!


(Chris Jackson) #1816

Thanks @AFromD, that’s really useful feedback.


(Kim Andersen) #1817

For @chris as well.

Using Elelabs Zigbee shield here also.
I did have the same successfull experience as AFromD. Unfortunatly it didnt stay like that. The last coupple of days things has been very bad, eve the Philips Hue sensor, and the Osram plug doesn´t respond. Everything is online, it says. But it does not respond anymore. I have been to busy to get back on this, and havn´t done much to try fix it. Yesterday I tried remove the Trust sensor and add it again. It work for something like 5 minutes, then it stopped responding again.

I cant say if this is cause by a lot of rebooting and retstarting lately. I think it may have.


(Chris Jackson) #1818

Please provide the logs and sniffer logs and I will take a look.

Thanks.


(Kim Andersen) #1819

I will as soon as I get some time.


(Chris Jackson) #1820

Can I suggest (if I haven’t already :wink: ) that you keep the sniffer running. Otherwise, inevitably, you have problems and don’t have logs to allow the issue to be solved. It’s really frustrating when you keep reporting all these problems, but don’t provide the logs that may help me to solve them.


(Kim Andersen) #1821

I know, and you did mention it :wink:
But since I updated openhab 2.3 to 2.4 I have had a hell getting things to work, specially around Grafana charts, which quite often crashed openhab every time I was rendering two charts.
As a try to finde the cause I had to remove a few things, that included the sniffer as well as the debug logging for Zigbee. (I had to somehow try minimize all kinds of unnecessary memory using).

Status is, I believe I´ve got the fatal problem under controle now. It´s still not fixed, just controled but openhab (Java) no longer crash. The cause has been tracked to the Rpi 3B I´m using is not suitable for the way I´m using it and was pushing it way above its limits by rendering just a few Grafana charts.
Now I´ve to get the sniffer and debug logging back on track, as well as other things I´d stop. Then I can provide usefull zigbee informations again. Hopefully tomorrow.


(layttan) #1822

Thanks Chris, sounds like it is going to be more involved than Id hoped to help with. I’ve open this issue as requested


(Chris Jackson) #1823

Thanks. It’s not super involved, but it’s also not a 5 minute job as the cluster needs adding first. I will look at this over the coming couple of weeks, but I wouldn’t expect this for may 3 to 5 weeks I guess as I’m off on holiday next week.


(Kim Andersen) #1824

Had some spare time this morning to get the debug and sniffer up running again.

Here is some debug log and sniffer logging…
At time 11.34 I removed the Trust motion sensor and re-added it again. It got added fine. But I receive no respond from it.
Seems like my Philips Hue sensor, as well as Dimmer switch do trigger allright. I´m not quite sure about the Osram plug. I have a feeling its defective. I cant hear any relay triggering anymore.

So problems seems to be Trust sensor only, right now…

Sniffer and debug logs.rar.txt (594.1 KB)

PS sorry I had to include two debug logs… But they´re beeing filled very fast. The logs should cover the re-adding of the Trust sensor, as well as some minutes after (aprox 20 minutes).


(Chris Jackson) #1825

Can you explain what this means exactly? It gets added, and it gets configured? Or there’s never any response and it’s not configured at all? Or it’s added, configured, but no state updates? Or something else?


(Chris Jackson) #1826

Another question - with the Trust, exactly what channels do you see?