ZigBee Eurotronic Spirit Thermostat

Tags: #<Tag:0x00007f18675fa9e8>

Hi,
i use OH2 stable 2.5.0 Installed on Linux 11/27/19. The Telegesis USB Dongle (ZigBee) sees the Eurotronic Spirit Thermostat (ZigBee), but defines it as an Unknown device. Help me please. What needs to be done specifically to solve my problem?

Please provide the debug log showing what is happening during the join process and I will have a look.

log_oh2.txt (670.8 KB)

Hi, Chris.

Thanks. Unfortunately there’s not a lot in this log and no sign of any devices joining. Did you reset the device to also enable joining on the device side?

Hi,.
I also have a Eurotronic ZigBee Thermostat.
When I connect it (CC2531 Cordinator) it shows up as a Generic ZigBee Device.
It also shows up under “Thing” but I can’t change any Channels. No Channel list is showing up!
I hve read that I have to change / create a ZigBee.items list. I already created one in the thing Config Folder but unfortunately it didn’t work.

Thank you very much,

Joshua

BTW: Newest OpenHab running on Raspberry Pi Zero.
The CC2531 detects my devices and they do pair!

I use two of these thermostats, cc2531, zigbee binding and Openhab 2.5 M3.

I paired these according to the manual and added them as things. At the beginning they were only sowing up as generic devices. After some hours of waiting (and probably trying them out) the devices got updated, changed from generic to eurotronic (…) and showed several channels. Sometimes it took two updates to show the full channel list.

In general they do work, but from time to time there are some things I don’t understand :smiley:

1 Like

Chris, which command should I catch in the log?

Did you reset the device to also enable joining on the device side? Yes.

In the attachment, several consecutive pictures of removing SPIRIT and reconnect

I think that Satan is on your side, he does not allow the rest to use the OpenHab

@mrfrh So would u just suggest me to wait a few hours?
Thanks I will try that.

This is a very common tale. Need to try.

Yes, this did the trick for me.

Good day ! Can I hope for help?

Sorry - I was ill yesterday.

Please provide a debug log showing the joining of the device. Start the join mode, then reset the device to allow it to join, and then provide the full log for the next minute or so.

In general, this is unlikely to help.

Not really - not for ZigBee. Maybe you read comments about “waiting a few hours” on ZWave - this is common for ZWave, but ZigBee sleepy devices work totally differently to ZWave devices, and in general I would expect the devices to fully discover when they join. There is the possibility for them to be discovered later, but it is less likely.

Chris, thanks for the answers. What command should I look in the logs so as not to send empty data again? (You can some example)

It’s not super easy to say - I want to see the responses from the device, so if you start the join mode, and reset the device, then hopefully we get this. If there is no activity, then the problem is not within the binding as the binding can only work with the commands that it receives from the device.

log_oh2_1.txt (999.0 KB) log_oh2_2.txt (128.7 KB)

Chris, I resubmit the logs

Ok thanks!
Should I maybe create a new Thread (we do have a similar problem) or should I upload my log files here?
But first I will reflash my SD Card.
OpenHAB randomly crashes after being idle for a few hours…

Thank you,
Joshua

If it’s related to the Spirit Thermostat, then attaching them here should be fine. Thanks.

Hi,

Good News! I got it working now!!!
I had some problems using the stock OpenHAB Raspberry PI Image. So I installed Raspbian first and then manually OpenHAB!
It works now!
Thank you anyways!

1 Like

Chris, please see the logs