ZigBee Eurotronic Spirit Thermostat

Tags: #<Tag:0x00007fc1f4ad3668>

Thanks.

I’m not 100% sure about this, but I think I know what the issue is. Can you confirm (if possible) the MAC address of the thermostat? Is it 00158D0001FFAD43? Also, can you confirm what nodes are in your network - what are the nodes with the NWK address 9782 and 35757?

Hi there,

I think I have a similar Problem: I also tried to add a “Eurotronic Spirit Zigbee” without success. In device discovery the device is found and after a few seconds it is listed as “Eurotronic SPZB0001” with subtitle “Zigbee Device”. I can add it as Thing and it is shown as “online” in PaperUI Things list.
The Problem is, that the thing does not contain any channels (this was already mentioned above).
What can be the problem? I did some logging while doing device discovery (attached).
Can somebody give me a hint what could be the problem here?
zigbee_debug_log.txt (200.6 KB)

Btw: In my uploaded log the mac of the eurotronic device is 00158D0001FF8F6A. I guess “00158D” is the manufacturer code from Eurotronic.

Im running OH 2.4 stable.

This is VERY old - I’d really recommend using a newer version. For sure the issue I discussed above will not be related if you are using 2.4. I don’t even think 2.4 has support for thermostats as that was added at the beginning of this year.

1 Like

Now I doubt that I can confirm the MAC address.
I deleted the devices from the openhab, then disconnected them and searched for new devices.
The system detected the devices again, although they are turned off (power off) with the same Mac addresses (00158D0001FFAD43, 00158D0001FFADC1)
I don’t know anything about the addresses of NWK 9782 and 35757. All my ZigBee equipment consists of Telegesis USB (ZigBee dongle) + 2 Eurotronic Spirit Zigbee, there are no other devices.

Chris, what will be the diagnosis?

Ok, that’s still useful information as it means that the devices I’m seeing are likely one of these, and probably it is linked to the issue I suspected.

I will take a look at this over the next week or so - it won’t be in 2.5 as I don’t want to change the version of the ZigBee library that is currently being used, so it will be updated (hopefully) after the 2.5 release.

OK, my fault. Sorry. I didn’t even think about the possibility that the thermostat might not yet be supported in my version! Then this is propably just a problem of my old version.
I’m just a little bit a sissy with releases not marked as ‘stable’ in my productive environment. :wink:
I’ll give it a try and update to the current milestone version.

Thx!

2.5 will be released in a week or so, and there are no changes planned to the binding, so the same SNAPSHOT binding will shortly become STABLE, but it’s still the same software :slight_smile:

OK. Convinced! :slightly_smiling_face:

If this might help:
The MAC addr (called EUI64) in Zigbee (more precisely IEEE802.15.4) includes the manufacturer code as three most significant bytes.

00158D: Jennic Ltd.: Company belongs to NXP. These ICs are used in eurotronic thermostat.
000D6F: Ember Corporation: This should be your stick.
7CB03E: OSRAM GmbH: Just an example from my log files. My “OSRAM SMART+ Plug”.

So I would be pretty sure that your 00158D0001FFAD43 and 00158D0001FFADC1 are the addresses of your thermostats. As I wrote above, my eurotronic thermostats do have the same manufacturer code: 00158D0001FF8F6A

Thanks for the help !
We will wait for magic from Chris.

Sorry to be picky, but since you started it :wink: IEEE802.15.4 is the MAC layer protocol, and is not directly related to the EUI / IEEE address.

:grin: I thougt it when i sent it, but didn’t want to go to deep into it.
Correct would be: The EUI64 is defined by IEEE. It is used in IEEE802.15.4 (also in others) which defines physical layer and link layer (MAC) which then again is used in zigbee.

1 Like

I updated to 2.5.0.M5 and this did the trick for me.
It took a while for the discovery to get completed, but now the thermostat thing shows some channels. :smiley: :smiley:

1 Like

I still have some questions :thinking:
The thermostat now is discovered and the thing shows some channels. But I miss some of them, for example the “remaining battery level”. I think it should be provided by the thermostat.

How are the “available channels” of a zigbee thing detected? Can they be edited afterwards?

If this is too far away from the threads original intension, please let me know, I will create another thread.

The binding looks at the services the device supports, and if it knows how to handle the services, then it creates a channel.

Not really. If there is no support for a channel, then you can’t just edit something to create this. It will require a binding update.

Unfortunately I don’t have this device, so it’s difficult for me to test. I can look at purchasing one for testing if there’s enough interest and maybe a few people want to donate a few £$€ to cover this.

1 Like

Ok. :thinking:
Is there a list of services which are supported so far?

Would this help?
This is the manual which is mainly in german (Havn’t found an international version yet) but page 14 and the following list the supported clusters and Attributes.


Regarding to this document, the “Battery Percentage Remaining” Attribute (AttributeId 0x0021) in the cluster “Power configuration” (ClusterId 0x0001) should be reported by the device.
I can also see it in the XML in ./userdata/zigbee but no channel for that.

Isn’t this a often used standard attribute? Is it not supported so far? Or have i missunderstood somtehing?

Sure - please check the documentation.

It helps, I’ll take a look, but the issue is that it’s still often difficult to answer some of the questions about discovery and exact behaviour.

Yes, this appears to be correct. Now we need to find out why this isn’t being detected. I can take a look at logs if you can generate them during the discovery, otherwise I will need to purchase one of these to find out what is happening.

OK, I will generate a log file during discovery.

News:
Just for Information: I updated from 2.5.0.M5 to 2.5.0.M6

Things are getting worse for me :cry:

  1. I wanted to generate logs while joining, so I removed the thermostat via PaperUI.
  2. After that I waited some minutes and even restarted OH.
  3. Then I wanted to join the thermostat again. But now the device is shown by name after a few seconds but there are no channels listed at all.

I removed it again and repeated these steps. After removing the device I resetted it by pressing three buttons for 10 seconds (written in manual). Same result after searching.

Now I took the batteries out of the thermostat and searched for devices again. And even then it is “found” and added to inbox. :woozy_face:
I think this is similar to what @heizzman wrote above.

This is a log of searching and finding the “ghost” device:
zigbee_debug_log2.txt (75.2 KB)