ZW096 Won't Complete Initialization

Hey everybody,
I’m running into a bit of a problem with a new Aeotec Smart Switch 6 - ZW096. This switch has firmware version 1.4 on it and does not want to include completely. I’m running 2.3.0-snapshot build #1284 and zwave binding It’s stuck at initializing static values. In the below debug log node 7 is our problem node.

I tried this switch on 2.2.0 yesterday and got the same result. No node xml file created after waiting several hours and stuck at initializing static values. At this point I’m thinking its the switch but before raising an issue with Aeotec I wanted to see if @chris wanted to give it a look and see if there might be something to be done in the binding since it gets most of the way through the inclusion process.

I would suggest to try 2.3 for starters, although to be honest I’m not sure it will help. What might help is using the development branch -:

I would suggest to try this before going too much further - the downside is that you will need to delete and re-add the things (not exclude and include the devices to the controller - just delete and add).

Still no luck with the dev binding The messaging in this version is spot on though: “NODE 7: No data from device, but it was ACK’d. Possibly not supported? (Try 8)” :slight_smile: Is there anything I can do to help? My next thought is to see if I can get an older firmware and downgrade from 1.04 to 1.03. Below is the grep’d node7 log from this test.

Please can you provide a log that isn’t grep’d - it removes all the data that the log processor uses. I also suspect that this is a little short, but at least I need the unfiltered log…

This is the full log that the grep’d snippet was taken from. The initial startup is right at the top as I cleared the logs before this test.

It looks like it has now completed initialisation.

The error that you saw is caused by a non-response to the ZWave Plus command class - the device should respond to this. I have a feeling that I’ve seen this before - I forget if it was on an Aeon device or another.

I’ll have a chat with Aeotec and see what they say - it will probably take a couple of days (I have a good contact their) but I think in the meantime the device should work fine for now if initialisation is complete.

Awesome! I hadn’t checked in a while but the status in Habmin is now empty (as in no longer says initializing). Thanks so much for the help. As a side note, there still isn’t a node7.xml created but from what I understand that’s somewhat minor, correct?

Well, if you need a 1.04 ZW096 to experiment with just hit me up :slightly_smiling_face:

Strange that the device didn’t generate an XML file. What this will mean is that the device initialises slowly if you restart the binding.

I should have this device here, although it might have different firmware (Aeon send me most of their devices before they hit the streets :slight_smile: ). I will try and dig it out, but I think that the log is quite clear - let’s see what they say.


Correction. There is a node7.xml its just called network_d25fe8c2__node_7.xml now.

Ah - yes, this is a change with the new binding - it’s done this way to allow support for multiple controllers…

Just a quick update. Aeotec tested the device with the same firmware as yours and it worked ok with their test software. I’ve tested the similar device (same device, different firmware as I’m in the UK) with the binding, and it also works fine.

Aeotec are going to do some more tests - probably next week…

Oh no, now I’m worried it has something to do with my setup :worried: Do you still think it’s a firmware issue or could it be something on my end? I was about to ask for help in the dev binding thread for a different device, but now I’m thinking the issues might be related. Along with that switch I bought a Nodon soft remote and it will include ok but takes a very very long time to finish discovery, even after being woken up multiple times. I’ve only been able to get it to add successfully once or twice but I’ve had to exclude and reinclude it because it seems to stop sending its scene commands after a few hours. I’ve also seen entries in the debug logs about timeouts and retrying communications (don’t have the logs in front of me right now so can’t quote exactly). This is strange because the other 5 devices I have never give me any problems.

I don’t see how it can be related to anything in your setup. The binding is sending the correct information, the device is ack’ing this request, but then not responding. The data the binding sends is also correct (ie the same as the log that Aeotec engineer sent me). So, my only thought at the moment is there might be a problem with your device.

I don’t think this is the issue here either. In the log I looked at, the device ack’d really quickly (30mS or so I think) and this happened every time. So I think the device is receiving ok, and the controller receives the ack ok.

If you want to post a full debug log, I can take a look to see if there’s an issue…

Attached is the log that shows one of the failed inclusions. I currently have it added to my network via the Zensys tool. It ran fine for the first 24 hours (no messages in Habmin), and it still works as I’m typing this, but Habmin says “Node Initializing INIT_NEIGHBORS”. This message, or something similar, is usually the precursor to the remote no longer working.

I’m not sure what this log is trying to show. It’s very short and doesn’t really have much information in it. It shows an inclusion, with no devices added (the inclusion failed), then just shows a bunch of data received from different devices (nothing transmitted from the binding).

Previously we’ve not been looking at failed inclusions, so I’m not sure where this fits in and it seems totally unrelated?

Sorry about that. I’m struggling to reproduce this issue in a consistent way. I was hoping that log had something useful in it because that’s what has happened 4 out of the 8 times I’ve tried to add the remote. I’m not really sure what to give you so I might need a little guidance on next steps. There are two issues - 1. inclusion frequently fails with this device via the binding 2. when inclusion does succeed or when the device is included outside the binding, it takes hours to complete discovery and it eventually stops working after about 24 hours. If either of those issues are not related to what this thread was originally about, I can start a new one, I’m making an assumption that the issues with the remote might be similar to the issues with the switch. I’ve turned down those chatty devices (been working on a graphing project) so that the logs will be clearer. How should I proceed in troubleshooting? Would deleting node 19’s xml file (the remote added via Zensys and sitting at “INIT_NEIGHBORS”) and restarting give you something useful?

Inclusion really has nothing to do with the binding - it is solely handled by the stick. If this is failing then I’m not sure there’s anything that can be done other than to try again. All the binding does is to send the command to the controller to put it into inclusion mode - after that it waits for the success, or failure, notification.

The failure of the device to respond to the message we discussed originally will prevent it from initialising correctly. This is probably the error that you have, although if you have logs with a different error then I’m happy tor take a look. I would strongly suggest to look at the log yourself using the online viewer on my website first though.

Ok, inclusion being unrelated is good to know, one less thing for me to focus on. Your log viewer is great by the way, I’ve been using it but since I don’t have much experience with broken devices it’s hard to know what “broken” actually looks like. There wouldn’t happen to be any documentation I could reference on what some of those binding log entries mean? I want to do as much self-help as I can.

I guess the next steps would be to confirm that the remote fails to reply (init_neighbors issue) and then contact Nodon support?

Sorry - my bad. I missed the fact that we had moved off the ZW096 and on to the Nodon…

Probably this device needs to be woken up - I’m not sure how that is done, but INIT_NEIGHBORS is the first thing that happens during the initialisation process, so this probably indicates that the device isn’t being seen. Presumably the device has a button you can press to wake it up?