Zwave 45712 dimmer mis-recognized

Hey @chris ,
I have a Jasco In-Wall Smart Dimmer 45712 that I’ve added to my OH and it is reported as a ZW3101 Lamp Module. The Type / ID is 4450:3030. Anything you can do about this? I created an account and requested update access to the device database. I was going to update this one, but realized if it’s there as another device then someone else had the same and I may mess them up. Plus there was this little note :slight_smile: , “NOTE: If you find that there is already a device in the database with the same Type and ID as the one you want to add, don’t just change them or add duplicates. Please flag this to me on the openHAB forum and we’ll try and work out how best to handle it - for example, the device might be a newer (or older!) version of a similar device with different firmware.”

I guess there’s a couple of options when this happens -:

  1. We ignore it. If the database entry looks the same (ie has all the same command classes / channels, and config parameters as the database, then it’s just a naming thing. This does happen from time to time where the manufacturer packages the same device into different products, so could be the same here.
  2. We “delete” the existing device and create a new one and wait for someone to complain that their lamp module is gone. Not so nice, but we can then discuss between the parties how to handle it. Sometimes (not too often thankfully) manufacturers use the same device types for completely different devices (this is actually against the standards, but it does happen!). If the devices are totally different, then we can potentially handle this by using firmware version. If the firmware versions are also the same, then there’s not a lot we can do to differentiate the devices.

So… Please first take a look at the database for the lamp module to see if it looks the same, and we can decide from there where to take it…

Looks like this was done multiple times:

This just shows the one conflict as already noted. The others you’ve found are different manufacturers so there is no conflict.

I’m not exactly sure what I’m looking for so I’ve attached the xml for the device. This is similar to 4944:3033.
node9.xml (6.3 KB)

It’s got the same channels, but you also need to check the parameters - this information is only in the manual. So you need to check that the parameters that are defined for your device are the same as those in the database.

The manual that came with it doesn’t provide any of that information. I did find this site, http://www.ezzwave.com/advanced-operation, which says it’s the same as the GE 12724. The site also has parameter information for it, but maybe not all parameters.

I guess then it’s probably fine to just leave it as it is…

@chris

I realize this is a little old now, but after looking into the fan issue I found my old post here. I looked back at the link I previously mentioned and it does have configuration parameter information for both and it’s definitely different. Currently I am not able to turn off the LED. Any way I can help you to fix/create the device information other than providing the link above?

According to your link

the plugin smart dimmer supports config parameters 7, 8, 9, 10, 11, 12 and 29. All are configured correctly in the database.

You may be affected by led ghosting:
https://emmytech.com/arcade/led_ghost_busting/

The problem is that this is not a plug-in dimmer. It’s a in wall switch that is picking up the profile of the plug-in dimmer in the DB.

1 Like

Unfortunately then we are back at

If you see a chance to find out the min and max firmware versions of the ZW3101 we could differentiate the two devices, but otherwise we are out of luck.

Another question: if you are turning OFF the device with the physical button, you still have the connected led on or glowing?
That is something we cannot solve at all with database entries I guess :sunglasses:

Or are you talking about the little led indicator at the device? This can be switched off without using any configurations:

Alternatively, the LED default setting can also be changed at the switch.
To disable the LED indicator:

  • Press the “ON” switch 3 times successively
  • Press the “OFF” switch 1 time