Zwave binding failing to install

Tags: #<Tag:0x00007f616bba6340> #<Tag:0x00007f616bba6250>

I understand that in need the Zwave binding to connect to my Aeotec/Aeon heavy duty smart switch ZW078. I am using paper UI.

Two Questions:

  1. I am using the demo config and the progress circle keeps spinning when I try to add the Z wave binding. Do I need to set the serial port of the Zstick first.

  2. How do I set the port and where do I discover which is the port to my z stick?

Thanks
Jim

If you refresh the page or leave & some back you will likely see it is installed. The Paper UI is known to be buggy like that sometimes. It has been removed from openHAB 3.

That depends a great bit on what OS and, to some extent, what type of installation.

Thanks Bruce

I left and came back and my zwave is installed.

I clicked on it and saw the configuration screen. I opened the port and had only one something like AW0, I have a raspi4 b and openhabian. Then I tried to pair my switch.
I needed to reset my switch since it was paired with home automation previously and by the time I put it into pairing mode the config timed out and can’t seem to return to selecting inclusion mode.

Suggestions?
Thanks
Jim

I do not tend to use the Paper UI much. I believe you can go to the Inbox & select “Search for Things” & then pick the binding.

I think I need more patience.

The Zstick is configured and on-line as shown in the config,things UI.

It is still not paired however. I cannot find any way to set to inclusion mode.

I have it set to high power inclusion and I can only execute the following:

Suggestions?
Thanks

Sorry, I tend to use the recommended HABmin interface for that. You might want to install that User interface.

In PaperUI (if you prefer to use that over HABmin or just because it’s there already), you just go to the inbox, hit the blue + button, and pick the ZWave binding. That will actually put your Z-stick in inclusion mode and you should be able to add devices to the network. The default inclusion duration is something like 30 seconds, and even though the UI will say it is still searching, my experience is that after the first device is added the controller will leave inclusion mode.

Assuming I am understanding you correctly, that is the process. If your stick is showing up as a Thing that should be all you need to do.

2 Likes

Gentlemen

Thanks for the feedback.

I tried to install HABmin but could not find anything about the installation in the docs.

I moved on to using PaperUI and followed your instruction and it worked great. I went to the inbox, hit the blue + button, and pick the ZWave binding. (this was strange because it looked like text that explained the Zwave netwok and not anything that would enable pairing. Clicked it anyway and went to inclusion mode and paired the switch.
The switch showed up in the control panel YEA!!!

I also got these additional inbox items:
image

I assume these items are necessary for the demo session correct?

Thanks for the help.

It has been 4 months of trial and error to get this far using 3 different platforms.

Thanks
Jim

Z-Wave bides 5 6 and 7 are zombie nodes still defined on your network and stored in the controller. They could affect network routing and stability unless they are removed. Devices may try to route through these non-existent nodes.

Since, I believe this may be a new and somewhat simple network the best path forward may be to exclude all your devices, reset the controller and start freshly including your devices.

Thanks Bruce

The network at this time consists only of the smart switch.

I am reluctant to exclude all devices but will exclude 5, 6, & 7 since this pairing process was so time-consuming.

What about the openHAB Hue Emulation. It appears to reside in the razpi it self. I am concerned that it is necessary if I want to practice with the demo.

Comments?

Thanks
Jim

If the devices do not exists you cannot easily exclude them. You can try marking the devices as failed & then exclude them but most people have not had good success doing that.

I do not use Hie Emulation and have not looked at the demo in over a year. When I did look at it, that was not on my main production system.

Hi Bruce,

I hope it is ok for you, that I - an openhab newcomer - asks you this right here at this place in the forum, but HABmin has become also my favorite tool to handle my Z-Wave tasks :o)

Yesterday late in the evening I received an update to openhab2 release build 2.5.8. I received an update to openhab2 release build 2.5.8. The first thing I just did, was to see whether HABmin was also updated to this release. In PaperUI - AddOns - USER INTERFACES I found HABmin ui-habmin - 2.5.8 showing up as installed.

But moving to HABmin via http://xxx.xxx.xxx.xxx:8080/start/index I choose HABmin and there I still get “Version: 2.0.0, 2020-08-23T12:14:16” to see.

Because you “tend to use the recommended HABmin interface” too I would like to know, whether you have same effects as me and possibly have answers to these points:

  1. When I choose the buttons [Read the Docs] and / or [Download] I only get relative old information! Do you know better places to inform yourself in detail?
  2. Are you able to make use of editing rules (graphical editor or source code) in the section [Automation] and work on existing rule files or generate and save new [Rules]?
  3. Does the term HABmin appear in your list of paper user interfaces - configuration - services - user interfaces and maybe you can also configure HABmin there?

Thank you in advance for your help and understanding!

Mario Fliegel

HABmin itself has not been in many years.
Both HABmin & Paper UI are not in OH3 but there is a new UI. The Basic UI & HABPanel are still present as secondary UIs.

I only use HABmin for configuring Z-Wave Things. I have not seen the “Read the Docs” button. The Paper UI is currently recommended for other tasks unless you are using text files. That all changes in OH3. Z-Wave is not currently present due to compatibility issues.