Zwave Eurotronic Spirit with external Temperatur don't work

Tags: #<Tag:0x00007f6173abd340> #<Tag:0x00007f6173abd1b0> #<Tag:0x00007f6173abd0c0>

I bought the new Spirit Zwave Plus from Eurotronic because i need a radiator with external temperature reference. The first problem was that the stable zwave binding dont have the radiator in the database. So I installed the SNAPSHOT version of the binding.
Now the binding know the radiator but I cant get the radiator work with external reference or in “Manufacturer Specific” mode.
I tried it like the manual descripton:

Externel Temperature:
Measured Temperature offset: 0x80 (128d)
now I try to send a temperature via the SENSOR_MULTILEVEL but nothing happens

“Manufacturer Specific” mode:
I tried to use the Manufacturer Specific Mode but when I send 0x1F to the radiator I get an

12:24:43.003 [WARN ] [nverter.ZWaveThermostatModeConverter] - NODE 22: Generating message failed for command class = THERMOSTAT_MODE, endpoint = 0
12:24:43.013 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'therm_thermostatMode' received command 31

Can anybody help me?

I’m not completely sure what you’re trying to do, but it’s not possible to send using this class - if this is really required then I’m afraid that the binding can’t do this at the moment.

I want to use the Thermostat with an External Temperatur Sensor. So e.g. an 1-Wire temperature sensor is placed in the room. The openhab is reading the value of the temperature sensor and sends it to the radiator. The openhab also sends the setpoint to the radiator and the radiator do the rest like adjusting the valve opening.
To do this i have to set the Parameter 8 (“Measured Temperature offset”) to 0x80 (128)
then i have to use the SENSOR_MULTILEVEL to send the measured room temperature
0036

Do you understand what i mean?
Thank you for your help!

Yes, understood. As I mentioned above, the binding doesn’t do this unfortunately.

Is there a plan to fix that in future? :frowning:

Not at the moment - it’s never been requested in the past as it’s really not something that is common (clearly, since it’s never been requested in the past 4 years I’ve worked on the binding :wink: ). You can raise it as an issue if you like.

Hi,
I think this feature is not meant to be sent from a gateway controller, but instead from a node device through association.
Did you try that?
for example using a wall Thermostat line the Danfoss wall sensor and try to associate the Danfoss Wall sensor with the Eurotronic Spirit. In this way, the Wall Thermostat will send unsolicited reports to the Spirit directly without going through the Gateway. This is more robust in case the GW shall fail.

It would have been even better if Eurotronic can allow the setting of the Setpoint through association as well. In this case one will have a full solution independent from the GW.

Hope this helps

I agree that this is what it is intended for, but the above askes for it to be sent from OH to allow a non ZWave sensor to be used.

What do you mean? From the Thermostat perspective, it doesn’t care how the command is sent - it doesn’t matter if it is through an association configured in another device, or just a command. The thermostat has no visibility of this…

Thank you for that idea. I have the Devolo “Room Wireless Thermostat” (I think this is the Danfoss Thermostat because the Danfoss logo is also written on the Device) but there is no association group to chose…

Sorry my bad. I am confusing between sender and receiver. Actually I was referring to the Wall Sensor from Danfoss. After checking the specification, it seems that this wall thermostat does not support any associations. It just supports the lifeline group, which is for this scenario totally useless.

Yes right, sorry for that. I will research a bit more if there is any device that can support that. Otherwise I think of any temperature sensor or combo PID sensor would support that type of association. I know of Qubino relays that they support an external temperature sensor, whose values can be passed on change through a dedicated association group.
Extract from their specification for ZMNHID1:

Group 9: sensor multilevel report (trigged by change of temperature) up to 16 nodes

Sorry for possibly stupid question - but I understand you try to set Spirit to take temp reading directly from external sensor without OH2 - right?

I assume this can be done with OH2 by setting rule reading external sensor and setting set point on Spirit - right?

Just asking as I’m not supper happy with responsiveness of Spirit internal temp sensor.

Sorry for the bump. The use for external temperature sensor works only with a direct association. So you have to associate a sensor to the Spirit, than you can use its function. This has nothing to do with openHAB