ZWAVE item does not read ZWAVE switch status

Hello,
I have 2 zwave poweroutlet (with bluitin button on/off)
i have a zwave switch 2 channel
When i send order on/off to switch or to outlet , work fine.
But, if i press button (outlet or switch) openhab status does not change.

What i miss ?

Telling us more information.

Exactly what brand and model power outlets you have
What version of openHAB
Any debug logs as documented in the binding document for when things do not go as planned.

The pic is from PaperUI (use for config not control), do you have a sitemap created for BasicUI and checked the status update there?

1 Like

Hello, No i do not have any sitemap, nothing appear on basicUI when launched.
I will read documentation about that.
Will come back as soon i undertand what i have to do.
Sorry for disturb.
Best regards

Basic UI requires a sitemap.


@Bruce_Osborne
Here is my model :

Fibaro wall plug switch
Neo CoolCam wall plug switch

I use openHab 2.5.1

Best regards.

FGWP101 is a Z-Wave device, not Z-Wave Plus. I think that means you need to associate the controller with device Group 1 to get the status updates. An expert such as @5iver can confirm if that is correct.

I think the NAS-WR01ZE should update the status automatically and that should show in the openhab logs.
The Paper UI is not a good UI to use for accurate status, in my experience. That is why the Basic UI with sitemap is recommended.

Correct, but my understanding is that the binding should force these too. But if status updates are not reported and the device supports them, then associations are usually not set. I don’t know this device, so the configuration parameters should be checked too. Logs are your friend!

I thought that was mainly for Z-Wave Plus devices. You would know better, though.

@sihui may have some.

@Bruce_Osborne
@5iver
@H102

My first fault was to get wrong with wall switch , 2 channel but 3 switchbinary button , i had to use switchbinary1 & switchbinary2 button , not switchbinary wich combine 1 & 2 (getting false result)

default.items

Switch Wallplug_Lum1 “PC LUM1” { channel=“zwave:device:9a3c3177:node4:switch_binary” }
Switch Wallplug_Lum2 “PC LUM2” { channel=“zwave:device:9a3c3177:node6:switch_binary” }
//Switch WallSwitchA_1 “Inter A_1” { channel=“zwave:device:9a3c3177:node9:switch_binary” }
Switch WallSwitchA_2 “Inter A_2” { channel=“zwave:device:9a3c3177:node9:switch_binary2” }
Switch WallSwitchA_1 “Inter A_1” { channel=“zwave:device:9a3c3177:node9:switch_binary1” }

Now, openhab get return of wallswitchs and poweroutlets status (on / off)

I had to put 4 rules to get poweroutlet on/off when pressing wallswitch

Maybe there is a simplest way to get outlet working with wallswitch ?

Here is zwave wallswitch conf

Thanks
Best regards

Yes, I do and physical switch changes are properly updating on BasicUI and Android App.

Okay, this is not an FGWP101 nor an WR01Z.

If you want help we need more detailed information:

  • which device with which firmware do you have? (Check properties page in HABmin):

  • How is your items configuration?
  • How is your sitemap definition?
2 Likes

@sihui
Hi,
I tried to use HABmin, but it seem to be unusable , zwave “analysor” is forbidden access.
Or i do not search at the good place ?

Only BasicUI, PaperUI , Home Builder, Classic UI seems to work fine.

I begin to make items file , but seem to be the same as items builder from Paper UI ?
I work on sitemap , will send data as soon as i finish something.

Capture

Best regards.

Don’t use Habmin to make Items, just stick to your usual method with PaperUI or files.

If you looking to update zwave device properties like associations, you will find that in Habmin Things

Use one method or the other but do not create the same item in both locations.

1 Like

Hello,
Here is my sitemap file :

sitemap wiwire label="Domotique à BAULON" {
    Frame label="Réseau" {
        Switch item=PC_Michelle label="Ordinateur de Michelle"
        Text item=Date2
    }
    Frame label="Cuisine" {
        Switch item=WallSwitchA_1 label="Inter Lampe1"
        Switch item=WallSwitchA_2 label="Inter Lampe2"
    }
    Frame label="Salon" {
        Switch item=Wallplug_Lum1 label="PC Lampe1"
        Switch item=Wallplug_Lum2 label="PC Lampe2"
    }
    Frame label="Demo" {
        Switch item=Lights icon="light"
        Text item=LR_Temperature label="Livingroom [%.1f °C]"
        Group item=Heating
        Text item=LR_Multimedia_Summary label="Multimedia [%s]" icon="video" {
            Selection item=LR_TV_Channel mappings=[0="off", 1="DasErste", 2="BBC One", 3="Cartoon Network"]
            Slider item=LR_TV_Volume
        }
    }
}

Give this screen :

Here is items file:

Switch Wallplug_Lum1 "PC LUM1" <poweroutlet> { channel="zwave:device:9a3c3177:node4:switch_binary" }
Switch Wallplug_Lum2 "PC LUM2" <poweroutlet> { channel="zwave:device:9a3c3177:node6:switch_binary" }
//Switch WallSwitchA_1 "Inter A_1" <wallswitch> { channel="zwave:device:9a3c3177:node9:switch_binary" }
Switch WallSwitchA_2 "Inter A_2" <wallswitch> { channel="zwave:device:9a3c3177:node9:switch_binary2" }
Switch WallSwitchA_1 "Inter A_1" <wallswitch> { channel="zwave:device:9a3c3177:node9:switch_binary1" }
Switch PC_Michelle "PC Michelle" <network> { channel="network:device:192_168_0_92:online" }

Now, with when i press wall1 in the kitchen , lampe1 in the salon goes on, but nothing appear at Basic UI screen, work fine on Paper UI Screen .
When i swith “on” in Basic UI, lampe1 goes on, but nothing appear on Basic UI.

Best regards.

I saw that was a bad idea … :roll_eyes:

More options with PAPER UI ?
autoupdate is for what ?

nothing about that here

Not sure as I use files only but I think you have more flexibility with files. That may change with OH 3.0???

A link to autoupdate info:

1 Like

Finaly found … :innocent:

Should i send a picture by device ?

That is good. The device is here.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/613

1 Like

Yes , using Multi-Channel Linking

Switch Wallplug_Lum1 "PC LUM1" <poweroutlet> { channel="zwave:device:9a3c3177:node4:switch_binary", channel="zwave:device:9a3c3177:node9:switch_binary1" [profile="follow"] , autoupdate="true" }
Switch Wallplug_Lum2 "PC LUM2" <poweroutlet> { channel="zwave:device:9a3c3177:node6:switch_binary", channel="zwave:device:9a3c3177:node9:switch_binary2" [profile="follow"] , autoupdate="true" }

Thanks to @H102 which give me link to autoupdate, near multi-channel linking :smiley:

1 Like