Zwave nodes not recognized after OH4 clean install

I recently went from OH3 to a fresh install of openhabian with OH4 after the previous broke down during an update. I’ve readded the Zwave binding, and added the Zwave bridge item. It auto-discovers all the nodes that were already installed, but quite a few of them aren’t properly recognized. In particular this is the case for 1 out of 2 Fibaro Wall Plugs (in other words one is recognized, one is not), Popp smoke detectors and a Heatit Z-Dim light dimmer.

When a force a restart of the Zwave binding, it seems that it retries interrogation, and the log shows entries for all of the unknown nodes, like:

[WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 37: Device discovery could not resolve to a thingType! Manufacturer data not known.

Which is surprising, since they were known and working perfectly when I was running OH3.

What has gone wrong here, and what can I do to resolve it?

Early ping of @chris as the Zwave binding maintainer. :slight_smile:

1 Like

Check OpenSmartHouse Z-Wave Device Database for changes on your devices between your previous and current openHAB version.

Here’s one of them (the Heatit Z-Dim), and it doesn’t look like it has changed in quite some time: OpenSmartHouse Z-Wave Device Database

Does anyone know what could be wrong here? I tried adding an unknown device and then force reinitialize, but it doesn’t change, and the log says:

[wave.discovery.ZWaveDiscoveryService] - NODE 37: Device discovery could not resolve to a thingType! Manufacturer data not known.

The manufacturerId field is missing from the Thing properties along with many other fields, both before and after reinitialization.

And let me just point out again that this device was succesfully added and working in my previous OH3 install, so it seems very unlikely to be a database issue.

Just a guess:

From the manual:
“This product is a security enabled Z-Wave Plus product with
encryption. The product must be used with a security enabled
Z-Wave primary controller in order to fully utilize the product.”

Check ‘Secure Inclusion Mode’ in the Z-Wave Controller settings.

Building on @anon71759204 comment. If this (or any of your other devices) were added securely in OH3 you needed to copy the 16 byte key from your old installation (OH3) to the new one (OH4).

Just wanted to add I have the same problem. It’s this device:

which worked in 3.4 and has never resolved to a proper definition in 4.0 / 4.0.1. it populates this ID and the correct manufactuer id of 99 (0x63)

I don’t think I have ever used secure inclusion.

Odd that this ever worked. If my decimal to hex converter is working, this has ID:Type of 4f50:3032 and that is not one of the options in the DB. I do not see that it was recently modified either. That pair needs to be added.


Building on @anon71759204 comment. If this (or any of your other devices) were added securely in OH3 you needed to copy the 16 byte key from your old installation (OH3) to the new one (OH4).

I see. It may have been added securely, I don’t quite remember. I’m running openhabian, and the new installation was done on the same card as the old one, so I don’t have access to anything from the old installation. I guess I can try to exclude it from the controller, and then re-include it.

Hah! Really? It was actually one of my earlier zwave devices. I don’t think I ever did any manual modification to the database (if that’s even possible) but it’s been years so I am not sure.

Ok I looked more closely at the 3032 and I’m very confused.

This is what comes up for 3032 originally I searched for the type and selected the device I have - this looks the same but is registered under honeywell.

edit: and that would mean the manufactuer id is mismatching right? I have at least two of these devices (maybe three i have to check) and its not just one that is doing this.

Yes. However, AFAIK you cannot change what the device reports, so adding 4f50:3032 to the GE/Jasco definition is required. If you have an unzip utility that can unpack and allow editing of your jar, you could try that first. The xml files do not need to be recompiled.

edit: Another option for testing would be this: Update ZWave binding with new/updated device xml - Tutorials & Examples - openHAB Community

Thank you Bob. I will look into this tonight (hopefully).

Hi Bob. So I did some reading and It seems like I need to uninstall the zwave binding and then add it manually using a pre-built jar from some build machine. That’s fine - but should I update the device on
the database?

Sorry it took so long - have to work around my newborn :smiley:



Tested it locally with the edited 4.0.1 jar and it works great. Thank you! Now confused at how I had it working before. I don’t think I had a zwave jar in my 3.4 addons directory.

I don’t know either.

Do you have DB access to change the entries so all can benefit (and you can get back to the UI binding in the future?)

Oh and congrats on the new family addition. :smiley:

I do have DB access and thanks! I just wasn’t sure if this was some bug in my hardware. Does it make sense the same device id and those are in two different manufacturers? If it does yes I can add my changes.

Replying to email so hope this works.


Yes. I does happen. If there was a problem you would have noticed with the modified jar.

Ok. Thanks for all your help. I updated the device and requested review.

1 Like